Bug 304474 - Amarok Krash on Kwit!
Summary: Amarok Krash on Kwit!
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-02 22:50 UTC by Philippe
Modified: 2012-08-04 12:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe 2012-08-02 22:50:26 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Closing Amarok even while leving it in memory and sometimes while sutting down computer.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f069a2f17c0 (LWP 2484))]

Thread 13 (Thread 0x7f066c388700 (LWP 2489)):
#0  0x00007f0696be60bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f06918218cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f06917e6ba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f06917e6fd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f06917e7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f069757e426 in QEventDispatcherGlib::processEvents (this=0x7f0664000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f069754dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f069754ded7 in QEventLoop::exec (this=0x7f066c387d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f069744cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f069752d9ff in QInotifyFileSystemWatcherEngine::run (this=0x15b3b80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f069744ffcb in QThreadPrivate::start (arg=0x15b3b80) at thread/qthread_unix.cpp:298
#11 0x00007f0693304e9a in start_thread (arg=0x7f066c388700) at pthread_create.c:308
#12 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f0669e2f700 (LWP 2490)):
#0  0x00007fff53fb48de in ?? ()
#1  0x00007f069021b15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f06974a6bb4 in do_gettime (frac=0x7f0669e2ebe8, sec=0x7f0669e2ebe0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f069757eb8d in QTimerInfoList::updateCurrentTime (this=0x7f065c002060) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f069757e841 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f06917e6b43 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f06917e6fd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f06917e7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f069757e426 in QEventDispatcherGlib::processEvents (this=0x7f065c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f069754dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f069754ded7 in QEventLoop::exec (this=0x7f0669e2edc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f069744cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f069744ffcb in QThreadPrivate::start (arg=0x1771ed0) at thread/qthread_unix.cpp:298
#15 0x00007f0693304e9a in start_thread (arg=0x7f0669e2f700) at pthread_create.c:308
#16 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f066898f700 (LWP 2491)):
#0  0x00007f0693306f69 in __pthread_mutex_lock (mutex=0x7f0660000a60) at pthread_mutex_lock.c:92
#1  0x00007f06918225a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f06917e701b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f06917e7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f069757e426 in QEventDispatcherGlib::processEvents (this=0x7f06600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f069754dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f069754ded7 in QEventLoop::exec (this=0x7f066898edc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f069744cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f069744ffcb in QThreadPrivate::start (arg=0x16c79c0) at thread/qthread_unix.cpp:298
#9  0x00007f0693304e9a in start_thread (arg=0x7f066898f700) at pthread_create.c:308
#10 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f065b3f3700 (LWP 2493)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f06974504db in wait (time=18446744073709551615, this=0x196e190) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x196e310, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f06948990eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x196e040, th=0x1970100) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f069489b9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1970100) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f069489a84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f065b3f2de0, parent=0x196e040, th=0x1970100) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f069489a8db in ThreadWeaver::Thread::run (this=0x1970100) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f069744ffcb in QThreadPrivate::start (arg=0x1970100) at thread/qthread_unix.cpp:298
#8  0x00007f0693304e9a in start_thread (arg=0x7f065b3f3700) at pthread_create.c:308
#9  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f0659d3d700 (LWP 2494)):
#0  0x00007f0696c010f0 in pthread_mutex_unlock (mutex=0x7f0650000a60) at forward.c:184
#1  0x00007f06918225d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f06917e716e in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f069757e426 in QEventDispatcherGlib::processEvents (this=0x7f06500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f069754dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f069754ded7 in QEventLoop::exec (this=0x7f0659d3cd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f069744cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f069752d9ff in QInotifyFileSystemWatcherEngine::run (this=0x1c50380) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f069744ffcb in QThreadPrivate::start (arg=0x1c50380) at thread/qthread_unix.cpp:298
#9  0x00007f0693304e9a in start_thread (arg=0x7f0659d3d700) at pthread_create.c:308
#10 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f0659114700 (LWP 2495)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f06974504db in wait (time=18446744073709551615, this=0x196e190) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x196e310, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f06948990eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x196e040, th=0x1d45290) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f069489b9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d45290) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f069489a84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f0659113de0, parent=0x196e040, th=0x1d45290) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f069489a8db in ThreadWeaver::Thread::run (this=0x1d45290) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f069744ffcb in QThreadPrivate::start (arg=0x1d45290) at thread/qthread_unix.cpp:298
#8  0x00007f0693304e9a in start_thread (arg=0x7f0659114700) at pthread_create.c:308
#9  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f0658913700 (LWP 2496)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f06974504db in wait (time=18446744073709551615, this=0x196e190) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x196e310, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f06948990eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x196e040, th=0x1d087f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f069489b9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d087f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f069489b9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d087f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f069489b9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d087f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f069489b9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d087f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f069489a84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f0658912de0, parent=0x196e040, th=0x1d087f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#9  0x00007f069489a8db in ThreadWeaver::Thread::run (this=0x1d087f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#10 0x00007f069744ffcb in QThreadPrivate::start (arg=0x1d087f0) at thread/qthread_unix.cpp:298
#11 0x00007f0693304e9a in start_thread (arg=0x7f0658913700) at pthread_create.c:308
#12 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f064bfff700 (LWP 2497)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f06974504db in wait (time=18446744073709551615, this=0x196e190) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x196e310, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f06948990eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x196e040, th=0x1d3e200) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f069489b9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d3e200) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f069489b9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x196fdb0, th=0x1d3e200) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f069489a84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f064bffede0, parent=0x196e040, th=0x1d3e200) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f069489a8db in ThreadWeaver::Thread::run (this=0x1d3e200) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f069744ffcb in QThreadPrivate::start (arg=0x1d3e200) at thread/qthread_unix.cpp:298
#9  0x00007f0693304e9a in start_thread (arg=0x7f064bfff700) at pthread_create.c:308
#10 0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f064b1bd700 (LWP 2498)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f068e422dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f068e422f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f0693304e9a in start_thread (arg=0x7f064b1bd700) at pthread_create.c:308
#4  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f0649fa6700 (LWP 2501)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f06938de222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f06938de259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f0693304e9a in start_thread (arg=0x7f0649fa6700) at pthread_create.c:308
#4  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f062ef86700 (LWP 2507)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f069182282f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0689493f7c in ?? () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#3  0x00007f0691809248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f06918089e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0693304e9a in start_thread (arg=0x7f062ef86700) at pthread_create.c:308
#6  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f067961d700 (LWP 2537)):
#0  0x00007f068f0357cc in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#1  0x00007f068f035dd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f068f035e90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f068f04430f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f068a489d18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#5  0x00007f0693304e9a in start_thread (arg=0x7f067961d700) at pthread_create.c:308
#6  0x00007f0696bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f069a2f17c0 (LWP 2484)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f069919c02e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x141a260, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f069919c209 in CollectionManager::~CollectionManager (this=0x141a260, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f069919a4b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f06992cf4cf in App::~App (this=0x7fff53eb4290, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=2, argv=0x7fff53eb6718) at ../../src/main.cpp:303

Possible duplicates by query: bug 304007, bug 303999, bug 303372, bug 303333, bug 303102.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-03 15:17:14 UTC

*** This bug has been marked as a duplicate of bug 285951 ***
Comment 2 Myriam Schweingruber 2012-08-04 12:08:23 UTC
And please use English words in bug reports, else this is not searchable in the bug database.