Bug 305079 - Please allow nepomuk digikam service being installable separately
Summary: Please allow nepomuk digikam service being installable separately
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Baloo (show other bugs)
Version: 2.8.0
Platform: Mageia RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-13 12:43 UTC by Angelo Naselli
Modified: 2014-02-17 12:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angelo Naselli 2012-08-13 12:43:00 UTC
Fixing this bug in mageia:
https://bugs.mageia.org/show_bug.cgi?id=7015
we've realized we could provide digikam nepomuk
service as an additional package containing it
and bringing with, all the nepomuk dependencies.
And now we've realized also that nepomuk tab into setup
is there anyway, and if you set up things of course it
does not work if you don't have installed the related
package, and we cannot say it to users.

We wonder if we can add a setup tab directly into nepomuk
service implementation, so that it can stay alone or at least
enabling it when the service is loaded?
Why? Because not all the users like and/or use nepomuk and
we'd like to avoid installing it if they just want to use
digikam .
Thanks,
  Angelo

Reproducible: Always
Comment 1 Marcel Wiesweg 2012-08-21 20:41:34 UTC
The config tab, if I'm not mistaken, will not have a direct nepomuk dependency, it should only write config files and issue DBUS calls. Keeping it in digikam and not providing it without the nepomuk package seems as an easier solution, but there needs to be a runtime check then, which I wouldnt know how to do without further investigation.
Comment 2 Marcel Wiesweg 2012-10-17 18:44:59 UTC
Git commit b882df3641e6a3b6b0ff35552d1c9cda434e868e by Marcel Wiesweg.
Committed on 17/10/2012 at 18:36.
Pushed by mwiesweg into branch 'master'.

Disable the current implementation of a digikam-nepomuk integration.

By information from the Nepomuk maintainer, the relevant API have been replaced.
Essentially, the current code is at best not functional, at worst polluting your Nepomuk db.
A new implementation needs to be written based on current APIs.
Related: bug 258837, bug 264124, bug 276457, bug 282918, bug 283168, bug 304052, bug 279404

M  +35   -35   CMakeLists.txt
M  +12   -0    utilities/nepomuk/digikamnepomukservice.cpp
M  +13   -0    utilities/nepomuk/digikamnepomukservice.h

http://commits.kde.org/digikam/b882df3641e6a3b6b0ff35552d1c9cda434e868e