Bug 283168 - Nepomuk interface crash
Summary: Nepomuk interface crash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Baloo (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 283525 286517 288144 289015 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-02 11:22 UTC by Steven Ward
Modified: 2012-10-17 18:52 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments
New crash information added by DrKonqi (6.34 KB, text/plain)
2011-11-11 10:23 UTC, Mircea Sava
Details
New crash information added by DrKonqi (6.34 KB, text/plain)
2011-11-11 10:23 UTC, Mircea Sava
Details
New crash information added by DrKonqi (6.49 KB, text/plain)
2011-11-16 19:19 UTC, Mircea Sava
Details
New crash information added by DrKonqi (6.43 KB, text/plain)
2011-12-14 22:50 UTC, rasmus.h
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Ward 2011-10-02 11:22:43 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-0.rc8.git0.0.fc16.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I was doing a fresh install of a nightly build of Fedora 16 (30-09-2011)

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Illegal instruction
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#7  0x4ce0b460 in Allocate (this=0x9cb0388) at ../../../../Source/OpenNI/XnNodeManager.cpp:113
#8  XnNodeManager::Allocate (this=0x9cb0388) at ../../../../Source/OpenNI/XnNodeManager.cpp:91
#9  0x4cdf2a1d in xnAllocateBaseNode () at ../../../../Source/OpenNI/XnBaseNode.cpp:33
#10 0x4cdf4265 in Allocate () at ../../../../Include/XnNode.h:44
#11 XnNodeAllocator::Allocate (this=0x9d652f0) at ../../../../Include/XnNodeAllocator.h:39
#12 0x4cdf7c6a in Init (pNodeAllocator=<optimized out>, this=0x9c47540) at ../../../../Include/XnList.h:513
#13 XnList (this=0x9c47540) at ../../../../Include/XnList.h:225
#14 Init (this=0x4ce379a0) at ../../../../Include/XnHash.h:714
#15 XnHash (this=0x4ce379a0) at ../../../../Include/XnHash.h:345
#16 XnStringsHash::XnStringsHash (this=0x4ce379a0) at ../../../../Include/XnStringsHash.h:120
#17 0x4cdf0f0a in XnLoggerData (this=0x4ce379a0) at ../../../../Source/OpenNI/XnLog.cpp:49
#18 __static_initialization_and_destruction_0 (__priority=65535, __initialize_p=1) at ../../../../Source/OpenNI/XnLog.cpp:90
#19 _GLOBAL__sub_I_XnLog.cpp(void) () at ../../../../Source/OpenNI/XnLog.cpp:785
#20 0x49662e52 in call_init (l=<optimized out>, argc=2, argv=0xbfdcab34, env=0xbfdcab40) at dl-init.c:83
#21 0x49662f40 in call_init (env=<optimized out>, argv=<optimized out>, argc=<optimized out>, l=<optimized out>) at dl-init.c:50
#22 _dl_init (main_map=<optimized out>, argc=2, argv=0xbfdcab34, env=0xbfdcab40) at dl-init.c:132
#23 0x496674f1 in dl_open_worker (a=0xbfdc9b30) at dl-open.c:485
#24 0x49662cdf in _dl_catch_error (objname=0xbfdc9b54, errstring=0xbfdc9b58, mallocedp=0xbfdc9b5f, operate=0x496670d0 <dl_open_worker>, args=0xbfdc9b30) at dl-error.c:178
#25 0x49666cd6 in _dl_open (file=0x9ca94f0 "/usr/lib/kde4/digikamnepomukservice.so", mode=-2147483647, caller_dlopen=0x4a3757d3, nsid=-2, argc=2, argv=0xbfdcab34, env=0xbfdcab40) at dl-open.c:575
#26 0x49854c09 in dlopen_doit (a=0xbfdc9d00) at dlopen.c:67
#27 0x49662cdf in _dl_catch_error (objname=0x9c8a344, errstring=0x9c8a348, mallocedp=0x9c8a340, operate=0x49854b70 <dlopen_doit>, args=0xbfdc9d00) at dl-error.c:178
#28 0x498553ba in _dlerror_run (operate=0x49854b70 <dlopen_doit>, args=0xbfdc9d00) at dlerror.c:164
#29 0x49854cb7 in __dlopen (file=0x9ca94f0 "/usr/lib/kde4/digikamnepomukservice.so", mode=1) at dlopen.c:88
#30 0x4a3757d3 in QLibraryPrivate::load_sys (this=0x9d85798) at plugin/qlibrary_unix.cpp:209
#31 0x4a371c44 in load (this=0x9d85798) at plugin/qlibrary.cpp:466
#32 QLibraryPrivate::load (this=0x9d85798) at plugin/qlibrary.cpp:458
#33 0x4a37200e in QLibraryPrivate::loadPlugin (this=0x9d85798) at plugin/qlibrary.cpp:516
#34 0x4a3668c3 in QPluginLoader::load (this=0xbfdca030) at plugin/qpluginloader.cpp:227
#35 0x4aad3d18 in KPluginLoader::load (this=0xbfdca030) at /usr/src/debug/kdelibs-4.7.1/kdecore/util/kpluginloader.cpp:224
#36 0x4aad4053 in KPluginLoader::factory (this=0xbfdca030) at /usr/src/debug/kdelibs-4.7.1/kdecore/util/kpluginloader.cpp:189
#37 0x0804bd31 in createInstance<Nepomuk::Service> (error=0x0, args=..., parent=0x9d83328, parentWidget=0x0, this=0x9d62288) at /usr/include/kde4/kservice.h:549
#38 createInstance<Nepomuk::Service> (error=0x0, args=..., parent=0x9d83328, this=0x9d62288) at /usr/include/kde4/kservice.h:528
#39 Nepomuk::ServiceControl::start (this=0x9d83328) at /usr/src/debug/kde-runtime-4.7.1/nepomuk/servicestub/servicecontrol.cpp:79
#40 0x4a396602 in QMetaCallEvent::placeMetaCall (this=0x9d3e6d8, object=0x9d83328) at kernel/qobject.cpp:524
#41 0x4a39f2cb in QObject::event (this=0x9d83328, e=0x9d3e6d8) at kernel/qobject.cpp:1194
#42 0x4ad0ab54 in notify_helper (e=0x9d3e6d8, receiver=0x9d83328, this=0x9c5c5e0) at kernel/qapplication.cpp:4495
#43 QApplicationPrivate::notify_helper (this=0x9c5c5e0, receiver=0x9d83328, e=0x9d3e6d8) at kernel/qapplication.cpp:4467
#44 0x4ad0fff3 in QApplication::notify (this=0x9d3e6d8, receiver=0x9d83328, e=0x9d3e6d8) at kernel/qapplication.cpp:4224
#45 0x4b9310d2 in KApplication::notify (this=0xbfdca984, receiver=0x9d83328, event=0x9d3e6d8) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:311
#46 0x4a3844ae in QCoreApplication::notifyInternal (this=0xbfdca984, receiver=0x9d83328, event=0x9d3e6d8) at kernel/qcoreapplication.cpp:853
#47 0x4a388408 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9c43a60) at kernel/qcoreapplication.cpp:1477
#49 0x4a38873d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1370
#50 0x4a3b6d55 in sendPostedEvents () at kernel/qcoreapplication.h:236
#51 postEventSourceDispatch (s=0x9c5e880) at kernel/qeventdispatcher_glib.cpp:279
#52 0x49a9b59f in g_main_dispatch (context=0x9c5f270) at gmain.c:2441
#53 g_main_context_dispatch (context=0x9c5f270) at gmain.c:3011
#54 0x49a9bce0 in g_main_context_iterate (context=0x9c5f270, block=1235920768, dispatch=1, self=0x9c5c6c0) at gmain.c:3089
#55 0x49a9bf8f in g_main_context_iteration (context=0x9c5f270, may_block=1) at gmain.c:3152
#56 0x4a3b7158 in QEventDispatcherGlib::processEvents (this=0x9c445b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#57 0x4adbefeb in QGuiEventDispatcherGlib::processEvents (this=0x9c445b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#58 0x4a38339e in QEventLoop::processEvents (this=0xbfdca7f4, flags=...) at kernel/qeventloop.cpp:149
#59 0x4a383649 in QEventLoop::exec (this=0xbfdca7f4, flags=...) at kernel/qeventloop.cpp:204
#60 0x4a3887eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1125
#61 0x4ad08955 in QApplication::exec () at kernel/qapplication.cpp:3756
#62 0x0804ae98 in main (argc=2, argv=0xbfdcab34) at /usr/src/debug/kde-runtime-4.7.1/nepomuk/servicestub/main.cpp:167

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-10-07 09:56:07 UTC
*** Bug 283525 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2011-11-03 12:42:35 UTC
digiKam 2.2.0 is out since few weeks. Crash still valid with this version ?

Gilles Caulier
Comment 3 Mircea Sava 2011-11-11 10:23:32 UTC
Created attachment 65514 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.8.0

- What I was doing when the application crashed:
My system just finished starting up
- Unusual behavior I noticed:
Crash
- Custom settings of the application:
Strigi was disabled

-- Backtrace (Reduced):
#7  0x00c43460 in Allocate (this=0x9de85a8) at ../../../../Source/OpenNI/XnNodeManager.cpp:113
#8  XnNodeManager::Allocate (this=0x9de85a8) at ../../../../Source/OpenNI/XnNodeManager.cpp:91
#9  0x00c2aa1d in xnAllocateBaseNode () at ../../../../Source/OpenNI/XnBaseNode.cpp:33
#10 0x00c2c265 in Allocate () at ../../../../Include/XnNode.h:44
#11 XnNodeAllocator::Allocate (this=0x9ec12b0) at ../../../../Include/XnNodeAllocator.h:39
Comment 4 Mircea Sava 2011-11-11 10:23:33 UTC
Created attachment 65515 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.8.0

- What I was doing when the application crashed:
My system just finished starting up
- Unusual behavior I noticed:
Crash
- Custom settings of the application:
Strigi was disabled

-- Backtrace (Reduced):
#7  0x00c43460 in Allocate (this=0x9de85a8) at ../../../../Source/OpenNI/XnNodeManager.cpp:113
#8  XnNodeManager::Allocate (this=0x9de85a8) at ../../../../Source/OpenNI/XnNodeManager.cpp:91
#9  0x00c2aa1d in xnAllocateBaseNode () at ../../../../Source/OpenNI/XnBaseNode.cpp:33
#10 0x00c2c265 in Allocate () at ../../../../Include/XnNode.h:44
#11 XnNodeAllocator::Allocate (this=0x9ec12b0) at ../../../../Include/XnNodeAllocator.h:39
Comment 5 Sebastian Trueg 2011-11-16 10:10:54 UTC
*** Bug 286647 has been marked as a duplicate of this bug. ***
Comment 6 Sebastian Trueg 2011-11-16 10:11:08 UTC
*** Bug 286517 has been marked as a duplicate of this bug. ***
Comment 7 Mircea Sava 2011-11-16 19:19:25 UTC
Created attachment 65754 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.3 (4.7.3) using Qt 4.8.0

- What I was doing when the application crashed:
The system just finished starting up when when Nepomuk crashed.
- Unusual behavior I noticed:
When I click Close in DrKonqi the prompt reappears and keeps reappearing till I click Close for the sixth time.
- Custom settings of the application:
Strigi is disabled.

-- Backtrace (Reduced):
#7  0x4bb40460 in Allocate (this=0x84ca820) at ../../../../Source/OpenNI/XnNodeManager.cpp:113
#8  XnNodeManager::Allocate (this=0x84ca820) at ../../../../Source/OpenNI/XnNodeManager.cpp:91
#9  0x4bb27a1d in xnAllocateBaseNode () at ../../../../Source/OpenNI/XnBaseNode.cpp:33
#10 0x4bb29265 in Allocate () at ../../../../Include/XnNode.h:44
#11 XnNodeAllocator::Allocate (this=0x854eb70) at ../../../../Include/XnNodeAllocator.h:39
Comment 8 Sebastian Trueg 2011-12-05 08:46:35 UTC
*** Bug 288144 has been marked as a duplicate of this bug. ***
Comment 9 rasmus.h 2011-12-14 22:50:59 UTC
Created attachment 66762 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.3 (4.7.3) using Qt 4.8.0

- What I was doing when the application crashed:

After my fresh Installation of Fedora 16 the crash happenend just after every start up of the system and ever since. However if I restart the application or don't the crash happens again, according to the reporting assistent.

-- Backtrace (Reduced):
#7  0x4f7d0460 in Allocate (this=0x902f810) at ../../../../Source/OpenNI/XnNodeManager.cpp:113
#8  XnNodeManager::Allocate (this=0x902f810) at ../../../../Source/OpenNI/XnNodeManager.cpp:91
#9  0x4f7b7a1d in xnAllocateBaseNode () at ../../../../Source/OpenNI/XnBaseNode.cpp:33
#10 0x4f7b9265 in Allocate () at ../../../../Include/XnNode.h:44
#11 XnNodeAllocator::Allocate (this=0x90e6880) at ../../../../Include/XnNodeAllocator.h:39
Comment 10 caulier.gilles 2011-12-15 08:25:50 UTC
Which digiKam version you use ?

Gilles Caulier
Comment 11 caulier.gilles 2011-12-15 08:26:01 UTC
*** Bug 282287 has been marked as a duplicate of this bug. ***
Comment 12 Thijs 2011-12-15 10:51:41 UTC
*** Bug 289015 has been marked as a duplicate of this bug. ***
Comment 13 caulier.gilles 2012-06-22 08:51:42 UTC
Official digiKam 2.6.0 release is out since few days now :

http://www.digikam.org/drupal/node/656

Please, check if this entry still valid, or update report accordingly.

Thanks in advance.

Gilles Caulier
Comment 14 Marcel Wiesweg 2012-10-17 18:44:54 UTC
Git commit b882df3641e6a3b6b0ff35552d1c9cda434e868e by Marcel Wiesweg.
Committed on 17/10/2012 at 18:36.
Pushed by mwiesweg into branch 'master'.

Disable the current implementation of a digikam-nepomuk integration.

By information from the Nepomuk maintainer, the relevant API have been replaced.
Essentially, the current code is at best not functional, at worst polluting your Nepomuk db.
A new implementation needs to be written based on current APIs.
Related: bug 258837, bug 264124, bug 276457, bug 282918, bug 304052, bug 279404, bug 305079

M  +35   -35   CMakeLists.txt
M  +12   -0    utilities/nepomuk/digikamnepomukservice.cpp
M  +13   -0    utilities/nepomuk/digikamnepomukservice.h

http://commits.kde.org/digikam/b882df3641e6a3b6b0ff35552d1c9cda434e868e