Bug 304894 - Crash on save draft
Summary: Crash on save draft
Status: RESOLVED DUPLICATE of bug 298831
Alias: None
Product: kontact
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-09 22:20 UTC by Neil Whelchel
Modified: 2012-08-10 00:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Whelchel 2012-08-09 22:20:51 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
When I click the save draft button Kmail crashes 100% of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3ed92aa7c0 (LWP 8554))]

Thread 4 (Thread 0x7f3ebca44700 (LWP 8555)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3ed5aa0dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f3ed5aa0f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f3ed0f64e9a in start_thread (arg=0x7f3ebca44700) at pthread_create.c:308
#4  0x00007f3ed67d24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3ebc243700 (LWP 8556)):
#0  __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:49
#1  __pthread_mutex_unlock (mutex=0x7f3eb4000a60) at pthread_mutex_unlock.c:290
#2  0x00007f3ed0ad35d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3ed0a9783b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3ed0a97f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3ed0a98164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f3ed6f47426 in QEventDispatcherGlib::processEvents (this=0x7f3eb40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f3ed6f16c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f3ed6f16ed7 in QEventLoop::exec (this=0x7f3ebc242dc0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f3ed6e15fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f3ed6e18fcb in QThreadPrivate::start (arg=0x7009c0) at thread/qthread_unix.cpp:298
#11 0x00007f3ed0f64e9a in start_thread (arg=0x7f3ebc243700) at pthread_create.c:308
#12 0x00007f3ed67d24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3e6e8b4700 (LWP 8559)):
#0  0x00007f3ed67c6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3ed0a98036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3ed0a98164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3ed6f47426 in QEventDispatcherGlib::processEvents (this=0x7f3e680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f3ed6f16c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3ed6f16ed7 in QEventLoop::exec (this=0x7f3e6e8b3d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f3ed6e15fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f3ed6ef69ff in QInotifyFileSystemWatcherEngine::run (this=0xd1b020) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3ed6e18fcb in QThreadPrivate::start (arg=0xd1b020) at thread/qthread_unix.cpp:298
#9  0x00007f3ed0f64e9a in start_thread (arg=0x7f3e6e8b4700) at pthread_create.c:308
#10 0x00007f3ed67d24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3ed92aa7c0 (LWP 8554)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fff1e36d510) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f3ed3290c9e in Akonadi::Entity::operator= (this=0x7fff1e36d550, other=...) at ../../akonadi/entity.cpp:116
#9  0x00007f3e72db31b5 in operator= (this=0x7fff1e36d550) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x3dbc740, job=0x6f44d00) at ../../messagecomposer/composerviewbase.cpp:944
#11 0x00007f3ed6f2c281 in QMetaObject::activate (sender=0x6f44d00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1e36d700) at kernel/qobject.cpp:3547
#12 0x00007f3ed73a2182 in KJob::result (this=<optimized out>, _t1=0x6f44d00) at ./kjob.moc:208
#13 0x00007f3ed73a21c0 in KJob::emitResult (this=0x6f44d00) at ../../kdecore/jobs/kjob.cpp:318
#14 0x00007f3ed6f31446 in QObject::event (this=0x6f44d00, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00007f3ed7912894 in notify_helper (e=0x6adb0d0, receiver=0x6f44d00, this=0x6f56f0) at kernel/qapplication.cpp:4559
#16 QApplicationPrivate::notify_helper (this=0x6f56f0, receiver=0x6f44d00, e=0x6adb0d0) at kernel/qapplication.cpp:4531
#17 0x00007f3ed7917713 in QApplication::notify (this=0x7fff1e36e090, receiver=0x6f44d00, e=0x6adb0d0) at kernel/qapplication.cpp:4420
#18 0x00007f3ed864c9e6 in KApplication::notify (this=0x7fff1e36e090, receiver=0x6f44d00, event=0x6adb0d0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f3ed6f17e9c in QCoreApplication::notifyInternal (this=0x7fff1e36e090, receiver=0x6f44d00, event=0x6adb0d0) at kernel/qcoreapplication.cpp:876
#20 0x00007f3ed6f1bc6a in sendEvent (event=0x6adb0d0, receiver=0x6f44d00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6bb380) at kernel/qcoreapplication.cpp:1500
#22 0x00007f3ed6f46f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007f3ed0a97d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f3ed0a980a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f3ed0a98164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f3ed6f473bf in QEventDispatcherGlib::processEvents (this=0x6bcc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f3ed79bad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f3ed6f16c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f3ed6f16ed7 in QEventLoop::exec (this=0x7fff1e36e020, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f3ed6f1bf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x0000000000403629 in main (argc=1, argv=0x7fff1e36e6b8) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 298831.

Possible duplicates by query: bug 301006, bug 298831, bug 297038, bug 284842, bug 284505.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-10 00:06:54 UTC

*** This bug has been marked as a duplicate of bug 298831 ***