Bug 280769 - Using latest trunk as of 2011-08-25 crashes at startup
Summary: Using latest trunk as of 2011-08-25 crashes at startup
Status: RESOLVED WORKSFORME
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4-GIT
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-25 13:15 UTC by Henrik Tjäder
Modified: 2011-09-26 11:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.88 KB, text/plain)
2011-08-26 19:41 UTC, Henrik Tjäder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Tjäder 2011-08-25 13:15:51 UTC
Application: amarok (2.4-GIT)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.7.3
Operating System: Linux 3.1.0-rc3AfoHT+ i686
Distribution: "Mandriva Linux 2010.2"

-- Information about the crash:
Trying to start amarok the program crashes after the start screen is shown.

The crash can be reproduced every time.

 -- Backtrace:
Application: Amarok (amarok), signal: Aborted
[Current thread is 1 (Thread 0xb16c88e0 (LWP 29031))]

Thread 2 (Thread 0xaaf42b70 (LWP 29166)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5467c75 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb56b026d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libc.so.6
#3  0xb58bcd70 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb50ed81a in ?? () from /usr/lib/libthreadweaver.so.4
#5  0xb50f008b in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb50ebcda in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb50f018c in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb50edab3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb50ee164 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb50ee8fa in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb58bbfb3 in ?? () from /usr/lib/libQtCore.so.4
#12 0xb5463ae5 in start_thread () from /lib/i686/libpthread.so.0
#13 0xb56a203e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb16c88e0 (LWP 29031)):
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb55f3a81 in raise () from /lib/i686/libc.so.6
#8  0xb55f53d2 in abort () from /lib/i686/libc.so.6
#9  0xb58b1894 in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#10 0xb58b1ab3 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb58b1bd8 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#12 0xb58b1c65 in qt_assert(char const*, char const*, int) () from /usr/lib/libQtCore.so.4
#13 0xb6ab618f in KSharedPtr<Meta::Track>::operator-> (this=0xbfe92e20) at /usr/include/KDE/../ksharedptr.h:126
#14 0xb6bb8c57 in Playlist::TrackNavigator::queueIds (this=0x865cc90, ids=...) at /home/henrik/kde/amarok/src/playlist/navigators/TrackNavigator.cpp:61
#15 0xb6bb8b3a in Playlist::TrackNavigator::queueId (this=0x865cc90, id=0) at /home/henrik/kde/amarok/src/playlist/navigators/TrackNavigator.cpp:51
#16 0xb6b28918 in Playlist::Actions::queue (this=0x863d338, rows=...) at /home/henrik/kde/amarok/src/playlist/PlaylistActions.cpp:400
#17 0xb6b29454 in Playlist::Actions::restoreDefaultPlaylist (this=0x863d338) at /home/henrik/kde/amarok/src/playlist/PlaylistActions.cpp:514
#18 0xb6b277d0 in Playlist::Actions::init (this=0x863d338) at /home/henrik/kde/amarok/src/playlist/PlaylistActions.cpp:94
#19 0xb6b273d8 in Playlist::Actions::instance () at /home/henrik/kde/amarok/src/playlist/PlaylistActions.cpp:59
#20 0xb6b296c5 in The::playlistActions () at /home/henrik/kde/amarok/src/playlist/PlaylistActions.cpp:534
#21 0xb6ec82aa in MainWindow::createActions (this=0x81450b8) at /home/henrik/kde/amarok/src/MainWindow.cpp:689
#22 0xb6ec3890 in MainWindow::MainWindow (this=0x81450b8) at /home/henrik/kde/amarok/src/MainWindow.cpp:145
#23 0xb6ea812f in App::continueInit (this=0xbfe93908) at /home/henrik/kde/amarok/src/App.cpp:542
#24 0xb6ea4afd in App::App (this=0xbfe93908) at /home/henrik/kde/amarok/src/App.cpp:185
#25 0x080584b6 in main (argc=1, argv=0xbfe94354) at /home/henrik/kde/amarok/src/main.cpp:289

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-08-26 06:07:59 UTC
Please try again, I can't reproduce that here.
Comment 2 Henrik Tjäder 2011-08-26 19:41:19 UTC
Created attachment 63162 [details]
New crash information added by DrKonqi

I cleaned the build directory and then updated and built again with latest trunk.

To me it looks like very similar problem occuring.
Comment 3 Myriam Schweingruber 2011-08-27 22:13:28 UTC
Please upgrade your KDE version, that might be the problem as you use a very old one. We plan to upgrade the dependency for kdelibs to KDE 4.6.x for the next release, it just didn't arrive in the README yet.
Comment 4 Henrik Tjäder 2011-08-28 10:18:32 UTC
Okey. I'll do that. Mandriva 2011 ships in a few days anyway.

I'm really looking forward to Amarok + KDE 4.6 (I've tried it in a virtualbox install)

Should I give this bugreport status "RESOLVED" ? 

Thanks for the time, 
I'll see you around.