Bug 302407 - Crash dragging bookmarks
Summary: Crash dragging bookmarks
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 15:01 UTC by Steven Schmidt
Modified: 2012-06-23 15:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Schmidt 2012-06-23 15:01:41 UTC
Application: keditbookmarks (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.43.2-6.fc15.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
dragging all booksmarks from Red Hat folder to Fedora Folder (both in bookmark bar)
- Unusual behavior I noticed:
a blank gray rectangle above menu bar, blotting out everything before "ew Go"

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  QDomNode::QDomNode (this=0x7fffffa649e0, n=...) at dom/qdom.cpp:2038
#7  0x0000003004811d7d in KBookmark (this=0x7fffffa649e0) at /usr/include/kde4/kbookmark.h:34
#8  TreeItem::bookmark (this=<optimized out>) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#9  0x000000300480fd55 in KBookmarkModel::bookmarkForIndex (this=<optimized out>, index=<optimized out>) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/model.cpp:396
#10 0x000000300480fdc0 in KBookmarkModel::parent (this=0x23d4ca0, index=...) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/model.cpp:263
#11 0x0000003895141883 in parent (this=0x7fffffa64c50) at ../../src/corelib/kernel/qabstractitemmodel.h:389
#12 can_create_mapping (source_parent=..., this=0x25821f0) at itemviews/qsortfilterproxymodel.cpp:399
#13 QSortFilterProxyModelPrivate::can_create_mapping (this=0x25821f0, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:396
#14 0x0000003895144a09 in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0x25821f0, source_parent=..., start=<optimized out>, end=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:1271
#15 0x00000038951489ac in QSortFilterProxyModel::qt_metacall (this=0x25817d0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0x7fffffa64bc0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:136
#16 0x0000003ca2b6d5aa in QMetaObject::activate (sender=0x23d4ca0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffffa64bc0) at kernel/qobject.cpp:3278
#17 0x0000003ca2bb5904 in QAbstractItemModel::rowsAboutToBeInserted (this=<optimized out>, _t1=<optimized out>, _t2=3, _t3=3) at .moc/release-shared/moc_qabstractitemmodel.cpp:174
#18 0x0000003ca2b54de8 in QAbstractItemModel::beginInsertRows (this=0x23d4ca0, parent=..., first=3, last=3) at kernel/qabstractitemmodel.cpp:2395
#19 0x00000030048109ba in KBookmarkModel::beginInsert (this=0x23d4ca0, group=<optimized out>, first=3, last=3) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/model.cpp:404
#20 0x000000300480be0f in CreateCommand::redo (this=0x2432bb0) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/commands.cpp:113
#21 0x000000300480d3b2 in MoveCommand::redo (this=0x27106a0) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/commands.cpp:374
#22 0x00000038952082f3 in QUndoCommand::redo (this=0x258ce50) at util/qundostack.cpp:208
#23 0x0000003895209863 in QUndoStack::push (this=0x2418538, cmd=0x258ce50) at util/qundostack.cpp:541
#24 0x000000300480b866 in CommandHistory::addCommand (this=0x241bbc0, cmd=0x258ce50) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#25 0x0000003004811214 in KBookmarkModel::dropMimeData (this=0x23d4ca0, data=<optimized out>, action=<optimized out>, row=-1, column=<optimized out>, parent=<optimized out>) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/kbookmarkmodel/model.cpp:380
#26 0x00000038950c30e1 in QAbstractItemView::dropEvent (this=0x2568fd0, event=0x7fffffa65cd0) at itemviews/qabstractitemview.cpp:1990
#27 0x0000003894c0d6f1 in QWidget::event (this=0x2568fd0, event=0x7fffffa65cd0) at kernel/qwidget.cpp:8485
#28 0x0000003894fad8c6 in QFrame::event (this=0x2568fd0, e=0x7fffffa65cd0) at widgets/qframe.cpp:557
#29 0x00000038950bcdab in QAbstractItemView::viewportEvent (this=0x2568fd0, event=0x7fffffa65cd0) at itemviews/qabstractitemview.cpp:1628
#30 0x0000003895101695 in QTreeView::viewportEvent (this=0x2568fd0, event=0x7fffffa65cd0) at itemviews/qtreeview.cpp:1256
#31 0x0000003ca2b5aa78 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25692c0, event=0x7fffffa65cd0) at kernel/qcoreapplication.cpp:902
#32 0x0000003894bbcc2f in notify_helper (e=0x7fffffa65cd0, receiver=0x25692c0, this=0x2331f30) at kernel/qapplication.cpp:4477
#33 QApplicationPrivate::notify_helper (this=0x2331f30, receiver=0x25692c0, e=0x7fffffa65cd0) at kernel/qapplication.cpp:4453
#34 0x0000003894bc206e in QApplication::notify (this=<optimized out>, receiver=<optimized out>, e=0x7fffffa65cd0) at kernel/qapplication.cpp:4285
#35 0x00000030024431c6 in KApplication::notify (this=0x7fffffa68ee0, receiver=0x25692c0, event=0x7fffffa65cd0) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#36 0x0000003ca2b5a8ec in QCoreApplication::notifyInternal (this=0x7fffffa68ee0, receiver=0x25692c0, event=0x7fffffa65cd0) at kernel/qcoreapplication.cpp:787
#37 0x0000003894c43df9 in sendEvent (event=0x7fffffa65cd0, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#38 QX11Data::xdndHandleDrop (this=<optimized out>, xe=<optimized out>, passive=<optimized out>) at kernel/qdnd_x11.cpp:1184
#39 0x0000003894c47ba3 in QDragManager::drop (this=0x270a5d0) at kernel/qdnd_x11.cpp:1726
#40 0x0000003894c47d78 in QDragManager::eventFilter (this=0x270a5d0, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1313
#41 0x0000003ca2b5a9bc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x2331f30, receiver=0x2711240, event=0x7fffffa66530) at kernel/qcoreapplication.cpp:883
#42 0x0000003894bbcbd6 in QApplicationPrivate::notify_helper (this=0x2331f30, receiver=0x2711240, e=0x7fffffa66530) at kernel/qapplication.cpp:4456
#43 0x0000003894bc23eb in QApplication::notify (this=<optimized out>, receiver=0x2711240, e=0x7fffffa66530) at kernel/qapplication.cpp:4042
#44 0x00000030024431c6 in KApplication::notify (this=0x7fffffa68ee0, receiver=0x2711240, event=0x7fffffa66530) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#45 0x0000003ca2b5a8ec in QCoreApplication::notifyInternal (this=0x7fffffa68ee0, receiver=0x2711240, event=0x7fffffa66530) at kernel/qcoreapplication.cpp:787
#46 0x0000003894bbdc32 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#47 QApplicationPrivate::sendMouseEvent (receiver=0x2711240, event=0x7fffffa66530, alienWidget=0x0, nativeWidget=0x2711240, buttonDown=0x25692c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#48 0x0000003894c39a25 in QETWidget::translateMouseEvent (this=0x2711240, event=<optimized out>) at kernel/qapplication_x11.cpp:4472
#49 0x0000003894c388fa in QApplication::x11ProcessEvent (this=0x7fffffa68ee0, event=0x7fffffa66df0) at kernel/qapplication_x11.cpp:3593
#50 0x0000003894c5ff2c in x11EventSourceDispatch (s=0x2335600, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#51 0x00000039b8c427ed in g_main_dispatch (context=0x2334440) at gmain.c:2441
#52 g_main_context_dispatch (context=0x2334440) at gmain.c:3014
#53 0x00000039b8c42fc8 in g_main_context_iterate (context=0x2334440, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#54 0x00000039b8c4325c in g_main_context_iteration (context=0x2334440, may_block=1) at gmain.c:3155
#55 0x0000003ca2b8538f in QEventDispatcherGlib::processEvents (this=0x2331c70, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#56 0x0000003894c5fc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#57 0x0000003ca2b59e02 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#58 0x0000003ca2b59fff in QEventLoop::exec (this=0x2634c60, flags=...) at kernel/qeventloop.cpp:201
#59 0x0000003894c477d3 in QDragManager::drag (this=0x270a5d0, o=<optimized out>) at kernel/qdnd_x11.cpp:1986
#60 0x0000003894bce9c8 in QDrag::exec (this=0x27116b0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#61 0x00000038950c6d13 in QAbstractItemView::startDrag (this=0x2568fd0, supportedActions=...) at itemviews/qabstractitemview.cpp:3448
#62 0x00000038950c546e in QAbstractItemView::mouseMoveEvent (this=0x2568fd0, event=<optimized out>) at itemviews/qabstractitemview.cpp:1709
#63 0x0000003894c0d3d8 in QWidget::event (this=0x2568fd0, event=0x7fffffa681c0) at kernel/qwidget.cpp:8280
#64 0x0000003894fad8c6 in QFrame::event (this=0x2568fd0, e=0x7fffffa681c0) at widgets/qframe.cpp:557
#65 0x00000038950bcdab in QAbstractItemView::viewportEvent (this=0x2568fd0, event=0x7fffffa681c0) at itemviews/qabstractitemview.cpp:1628
#66 0x0000003895101695 in QTreeView::viewportEvent (this=0x2568fd0, event=0x7fffffa681c0) at itemviews/qtreeview.cpp:1256
#67 0x0000003ca2b5aa78 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25692c0, event=0x7fffffa681c0) at kernel/qcoreapplication.cpp:902
#68 0x0000003894bbcc2f in notify_helper (e=0x7fffffa681c0, receiver=0x25692c0, this=0x2331f30) at kernel/qapplication.cpp:4477
#69 QApplicationPrivate::notify_helper (this=0x2331f30, receiver=0x25692c0, e=0x7fffffa681c0) at kernel/qapplication.cpp:4453
#70 0x0000003894bc23eb in QApplication::notify (this=<optimized out>, receiver=0x25692c0, e=0x7fffffa681c0) at kernel/qapplication.cpp:4042
#71 0x00000030024431c6 in KApplication::notify (this=0x7fffffa68ee0, receiver=0x25692c0, event=0x7fffffa681c0) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#72 0x0000003ca2b5a8ec in QCoreApplication::notifyInternal (this=0x7fffffa68ee0, receiver=0x25692c0, event=0x7fffffa681c0) at kernel/qcoreapplication.cpp:787
#73 0x0000003894bbdc32 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#74 QApplicationPrivate::sendMouseEvent (receiver=0x25692c0, event=0x7fffffa681c0, alienWidget=0x25692c0, nativeWidget=0x2408100, buttonDown=0x25692c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#75 0x0000003894c39a25 in QETWidget::translateMouseEvent (this=0x2408100, event=<optimized out>) at kernel/qapplication_x11.cpp:4472
#76 0x0000003894c388fa in QApplication::x11ProcessEvent (this=0x7fffffa68ee0, event=0x7fffffa68a80) at kernel/qapplication_x11.cpp:3593
#77 0x0000003894c5ff2c in x11EventSourceDispatch (s=0x2335600, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#78 0x00000039b8c427ed in g_main_dispatch (context=0x2334440) at gmain.c:2441
#79 g_main_context_dispatch (context=0x2334440) at gmain.c:3014
#80 0x00000039b8c42fc8 in g_main_context_iterate (context=0x2334440, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#81 0x00000039b8c4325c in g_main_context_iteration (context=0x2334440, may_block=1) at gmain.c:3155
#82 0x0000003ca2b8538f in QEventDispatcherGlib::processEvents (this=0x2331c70, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#83 0x0000003894c5fc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#84 0x0000003ca2b59e02 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#85 0x0000003ca2b59fff in QEventLoop::exec (this=0x7fffffa68e50, flags=...) at kernel/qeventloop.cpp:201
#86 0x0000003ca2b5e117 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#87 0x000000300541b5ae in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdebase-4.6.5/keditbookmarks/main.cpp:212
#88 0x00000039b6c2135d in __libc_start_main (main=0x400750 <main(int, char**)>, argc=6, ubp_av=0x7fffffa69788, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffa69778) at libc-start.c:226
#89 0x0000000000400781 in _start ()

This bug may be a duplicate of or related to bug 226187.

Possible duplicates by query: bug 301493, bug 294031, bug 294008, bug 287038.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-23 15:12:41 UTC

*** This bug has been marked as a duplicate of bug 287038 ***