Bug 301493 - Bookmark editor crashes and does not work as expected
Summary: Bookmark editor crashes and does not work as expected
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-09 07:56 UTC by nicolas.hueppelshaeuser
Modified: 2012-06-11 17:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolas.hueppelshaeuser 2012-06-09 07:56:17 UTC
I wanted to import bookmarks as html file from mozilla.

(1) The existing bookmarks were the default ones.
I created a folder and moved all of them into it.

(2) I imported the mozilla bookmarks html file and choose to add them to the bookmarks as a folder.

(3) Now the folder, to which I moved the KDE default bookmarks was lost.  Instead of the folder one of the KDE-default bookmarks occured in its place.  The other bookmarks have been lost.

(4) Trying to move a couple of selected bookmarks including folders from within the mozilla bookmarks folder to the top, just below the remainig single KDE default bookmark causes the bookmark editor to crash.  This was reproducible.

I am using keditbookmarks of version 4.8.3

Reproducible: Always
Comment 1 Christoph Feck 2012-06-11 10:46:37 UTC
Please add the backtrace of the crash if it happens again. For more information, see http://techbase.kde.org/User:DarioAndres/How_to_provide_more_information_about_crash_reports
Comment 2 nicolas.hueppelshaeuser 2012-06-11 16:45:40 UTC
Here we go:

Application: Lesezeichen-Editor (keditbookmarks), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6ddf6cc780 (LWP 1733))]

Thread 2 (Thread 0x7f6dcc8e8700 (LWP 1734)):
#0  0x00007f6ddefd1b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6dd883dff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6dd883e124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6ddd523426 in QEventDispatcherGlib::processEvents (this=0x7f6dc80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6ddd4f2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6ddd4f2ed7 in QEventLoop::exec (this=0x7f6dcc8e7dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6ddd3f1fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6ddd4d29ff in QInotifyFileSystemWatcherEngine::run (this=0x188cd20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6ddd3f4fcb in QThreadPrivate::start (arg=0x188cd20) at thread/qthread_unix.cpp:298
#9  0x00007f6dd9102e9a in start_thread (arg=0x7f6dcc8e8700) at pthread_create.c:308
#10 0x00007f6ddefdd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6ddf6cc780 (LWP 1733)):
[KCrash Handler]
#6  QDomNode::QDomNode (this=0x7fff7d074050, n=...) at dom/qdom.cpp:2038
#7  0x00007f6ddece4cfd in KBookmark (this=0x7fff7d074050) at /usr/include/kbookmark.h:34
#8  TreeItem::bookmark (this=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#9  0x00007f6ddece2d65 in KBookmarkModel::bookmarkForIndex (this=<optimized out>, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:396
#10 0x00007f6ddece2dd0 in KBookmarkModel::parent (this=0x140fe20, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:263
#11 0x00007f6ddf2d8717 in parent (this=<optimized out>) at /usr/include/qt4/QtCore/qabstractitemmodel.h:393
#12 KViewSearchLine::setVisible (this=0x181f890, index=..., v=<optimized out>) at ../../keditbookmarks/kebsearchline.cpp:589
#13 0x00007f6ddf2d8848 in KViewSearchLine::slotRowsInserted (this=0x181f890, parent=..., first=43, last=43) at ../../keditbookmarks/kebsearchline.cpp:564
#14 0x00007f6ddf2da02d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kebsearchline.moc:88
#15 KViewSearchLine::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./kebsearchline.moc:72
#16 0x00007f6ddd508281 in QMetaObject::activate (sender=0x140fe20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7d0743a0) at kernel/qobject.cpp:3547
#17 0x00007f6ddd554644 in QAbstractItemModel::rowsInserted (this=<optimized out>, _t1=..., _t2=43, _t3=43) at .moc/release-shared/moc_qabstractitemmodel.cpp:197
#18 0x00007f6ddd4ee02d in QAbstractItemModel::endInsertRows (this=0x140fe20) at kernel/qabstractitemmodel.cpp:2433
#19 0x00007f6ddecdec2c in CreateCommand::redo (this=0x1605ed0) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:142
#20 0x00007f6ddece0092 in MoveCommand::redo (this=0x1ce6970) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:374
#21 0x00007f6ddcc6e533 in QUndoCommand::redo (this=0x1ce97d0) at util/qundostack.cpp:208
#22 0x00007f6ddcc6fde3 in QUndoStack::push (this=<optimized out>, cmd=0x1ce97d0) at util/qundostack.cpp:583
#23 0x00007f6ddecde4f6 in CommandHistory::addCommand (this=0x14fb080, cmd=0x1ce97d0) at ../../../keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#24 0x00007f6ddece4277 in KBookmarkModel::dropMimeData (this=0x140fe20, data=0x1c30ab0, action=<optimized out>, row=<optimized out>, column=<optimized out>, parent=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:380
#25 0x00007f6ddcb1d7b2 in QAbstractItemView::dropEvent (this=0x16912f0, event=0x7fff7d075470) at itemviews/qabstractitemview.cpp:2006
#26 0x00007f6ddc64a491 in QWidget::event (this=0x16912f0, event=0x7fff7d075470) at kernel/qwidget.cpp:8552
#27 0x00007f6ddca0a3b6 in QFrame::event (this=0x16912f0, e=0x7fff7d075470) at widgets/qframe.cpp:557
#28 0x00007f6ddcb1e89b in QAbstractItemView::viewportEvent (this=0x16912f0, event=0x7fff7d075470) at itemviews/qabstractitemview.cpp:1644
#29 0x00007f6ddcb664b5 in QTreeView::viewportEvent (this=0x16912f0, event=0x7fff7d075470) at itemviews/qtreeview.cpp:1257
#30 0x00007f6ddd4f4028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x169a290, event=0x7fff7d075470) at kernel/qcoreapplication.cpp:986
#31 0x00007f6ddc5f985f in notify_helper (e=0x7fff7d075470, receiver=0x169a290, this=0x138b980) at kernel/qapplication.cpp:4555
#32 QApplicationPrivate::notify_helper (this=0x138b980, receiver=0x169a290, e=0x7fff7d075470) at kernel/qapplication.cpp:4531
#33 0x00007f6ddc5fec5f in QApplication::notify (this=<optimized out>, receiver=<optimized out>, e=0x7fff7d075470) at kernel/qapplication.cpp:4345
#34 0x00007f6dddf54bb6 in KApplication::notify (this=0x7fff7d0785f0, receiver=0x169a290, event=0x7fff7d075470) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f6ddd4f3e9c in QCoreApplication::notifyInternal (this=0x7fff7d0785f0, receiver=0x169a290, event=0x7fff7d075470) at kernel/qcoreapplication.cpp:876
#36 0x00007f6ddc684163 in sendEvent (event=0x7fff7d075470, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#37 QX11Data::xdndHandleDrop (this=<optimized out>, xe=<optimized out>, passive=<optimized out>) at kernel/qdnd_x11.cpp:1185
#38 0x00007f6ddc6856f3 in QDragManager::drop (this=0x19a9cd0) at kernel/qdnd_x11.cpp:1750
#39 0x00007f6ddc688488 in QDragManager::eventFilter (this=0x19a9cd0, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1314
#40 0x00007f6ddd4f3f6c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x138b980, receiver=0x1c30a40, event=0x7fff7d075c90) at kernel/qcoreapplication.cpp:967
#41 0x00007f6ddc5f9806 in QApplicationPrivate::notify_helper (this=0x138b980, receiver=0x1c30a40, e=0x7fff7d075c90) at kernel/qapplication.cpp:4534
#42 0x00007f6ddc5ff0bf in QApplication::notify (this=<optimized out>, receiver=0x1c30a40, e=0x7fff7d075c90) at kernel/qapplication.cpp:4102
#43 0x00007f6dddf54bb6 in KApplication::notify (this=0x7fff7d0785f0, receiver=0x1c30a40, event=0x7fff7d075c90) at ../../kdeui/kernel/kapplication.cpp:311
#44 0x00007f6ddd4f3e9c in QCoreApplication::notifyInternal (this=0x7fff7d0785f0, receiver=0x1c30a40, event=0x7fff7d075c90) at kernel/qcoreapplication.cpp:876
#45 0x00007f6ddc5fa862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#46 QApplicationPrivate::sendMouseEvent (receiver=0x1c30a40, event=0x7fff7d075c90, alienWidget=0x0, nativeWidget=0x1c30a40, buttonDown=0x169a290, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#47 0x00007f6ddc679bf5 in QETWidget::translateMouseEvent (this=0x1c30a40, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#48 0x00007f6ddc678bae in QApplication::x11ProcessEvent (this=0x7fff7d0785f0, event=0x7fff7d076560) at kernel/qapplication_x11.cpp:3732
#49 0x00007f6ddc6a20d2 in x11EventSourceDispatch (s=0x137ead0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#50 0x00007f6dd883dc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#51 0x00007f6dd883e060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#52 0x00007f6dd883e124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#53 0x00007f6ddd5233bf in QEventDispatcherGlib::processEvents (this=0x138b640, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#54 0x00007f6ddc6a1d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007f6ddd4f2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007f6ddd4f2ed7 in QEventLoop::exec (this=0x1c411f0, flags=...) at kernel/qeventloop.cpp:204
#57 0x00007f6ddc688183 in QDragManager::drag (this=0x19a9cd0, o=<optimized out>) at kernel/qdnd_x11.cpp:2017
#58 0x00007f6ddc60b4f8 in QDrag::exec (this=0x1c17080, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#59 0x00007f6ddcb2a5a3 in QAbstractItemView::startDrag (this=0x16912f0, supportedActions=...) at itemviews/qabstractitemview.cpp:3540
#60 0x00007f6ddcb27f6e in QAbstractItemView::mouseMoveEvent (this=0x16912f0, event=<optimized out>) at itemviews/qabstractitemview.cpp:1725
#61 0x00007f6ddc64a178 in QWidget::event (this=0x16912f0, event=0x7fff7d0778f0) at kernel/qwidget.cpp:8347
#62 0x00007f6ddca0a3b6 in QFrame::event (this=0x16912f0, e=0x7fff7d0778f0) at widgets/qframe.cpp:557
#63 0x00007f6ddcb1e89b in QAbstractItemView::viewportEvent (this=0x16912f0, event=0x7fff7d0778f0) at itemviews/qabstractitemview.cpp:1644
#64 0x00007f6ddcb664b5 in QTreeView::viewportEvent (this=0x16912f0, event=0x7fff7d0778f0) at itemviews/qtreeview.cpp:1257
#65 0x00007f6ddd4f4028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x169a290, event=0x7fff7d0778f0) at kernel/qcoreapplication.cpp:986
#66 0x00007f6ddc5f985f in notify_helper (e=0x7fff7d0778f0, receiver=0x169a290, this=0x138b980) at kernel/qapplication.cpp:4555
#67 QApplicationPrivate::notify_helper (this=0x138b980, receiver=0x169a290, e=0x7fff7d0778f0) at kernel/qapplication.cpp:4531
#68 0x00007f6ddc5ff0bf in QApplication::notify (this=<optimized out>, receiver=0x169a290, e=0x7fff7d0778f0) at kernel/qapplication.cpp:4102
#69 0x00007f6dddf54bb6 in KApplication::notify (this=0x7fff7d0785f0, receiver=0x169a290, event=0x7fff7d0778f0) at ../../kdeui/kernel/kapplication.cpp:311
#70 0x00007f6ddd4f3e9c in QCoreApplication::notifyInternal (this=0x7fff7d0785f0, receiver=0x169a290, event=0x7fff7d0778f0) at kernel/qcoreapplication.cpp:876
#71 0x00007f6ddc5fa862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#72 QApplicationPrivate::sendMouseEvent (receiver=0x169a290, event=0x7fff7d0778f0, alienWidget=0x169a290, nativeWidget=0x17326e0, buttonDown=0x169a290, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#73 0x00007f6ddc679bf5 in QETWidget::translateMouseEvent (this=0x17326e0, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#74 0x00007f6ddc678bae in QApplication::x11ProcessEvent (this=0x7fff7d0785f0, event=0x7fff7d0781c0) at kernel/qapplication_x11.cpp:3732
#75 0x00007f6ddc6a20d2 in x11EventSourceDispatch (s=0x137ead0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#76 0x00007f6dd883dc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#77 0x00007f6dd883e060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#78 0x00007f6dd883e124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f6ddd5233bf in QEventDispatcherGlib::processEvents (this=0x138b640, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#80 0x00007f6ddc6a1d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#81 0x00007f6ddd4f2c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#82 0x00007f6ddd4f2ed7 in QEventLoop::exec (this=0x7fff7d078560, flags=...) at kernel/qeventloop.cpp:204
#83 0x00007f6ddd4f7f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#84 0x00007f6ddf2c3e4e in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../keditbookmarks/main.cpp:212
#85 0x00007f6ddef0c76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff7d078e98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7d078e88) at libc-start.c:226
#86 0x0000000000400671 in _start ()
Comment 3 Tommi Tervo 2012-06-11 17:09:27 UTC

*** This bug has been marked as a duplicate of bug 226187 ***