Bug 294031 - Crashed Importing Mozilla
Summary: Crashed Importing Mozilla
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 00:47 UTC by Tedd
Modified: 2012-06-11 17:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tedd 2012-02-14 00:47:15 UTC
Application: keditbookmarks (4.7.4 (4.7.4))
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Import Mozilla Bookmarks, open bookmark.html and it crash

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe398273780 (LWP 2458))]

Thread 2 (Thread 0x7fe3887ec700 (LWP 2479)):
#0  0x00007fe397b84773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe391d0df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe391d0e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe395433f3e in QEventDispatcherGlib::processEvents (this=0x1cd9a90, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe395407cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe395407ef7 in QEventLoop::exec (this=0x7fe3887ebdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe39531f27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe3953eacbf in QInotifyFileSystemWatcherEngine::run (this=0x1cd9b70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe395321d05 in QThreadPrivate::start (arg=0x1cd9b70) at thread/qthread_unix.cpp:331
#9  0x00007fe3921dfefc in start_thread (arg=0x7fe3887ec700) at pthread_create.c:304
#10 0x00007fe397b9089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe398273780 (LWP 2458)):
[KCrash Handler]
#6  QDomNode::QDomNode (this=0x7fff9ec58c20, n=...) at dom/qdom.cpp:2038
#7  0x00007fe3978a9bdd in KBookmark (this=0x7fff9ec58c20) at /usr/include/kbookmark.h:34
#8  TreeItem::bookmark (this=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#9  0x00007fe3978a7d35 in KBookmarkModel::bookmarkForIndex (this=<optimized out>, index=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:396
#10 0x00007fe3978a7da0 in KBookmarkModel::parent (this=0x1b37210, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:263
#11 0x00007fe3978a7be7 in sibling (acolumn=3, arow=0, this=0x7fff9ec58ca0) at /usr/include/qt4/QtCore/qabstractitemmodel.h:392
#12 KBookmarkModel::emitDataChanged (this=0x1b37210, bk=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:299
#13 0x00007fe3978a41a3 in EditCommand::redo (this=0x1d3d500) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:228
#14 0x00007fe396460ab3 in QUndoStack::push (this=<optimized out>, cmd=0x1d3d500) at util/qundostack.cpp:541
#15 0x00007fe3978a3456 in CommandHistory::addCommand (this=0x1b1a820, cmd=0x1d3d500) at ../../../keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#16 0x00007fe3978a8020 in setData (value=..., index=<optimized out>, this=0x1b37210, role=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:205
#17 KBookmarkModel::setData (this=0x1b37210, index=<optimized out>, value=..., role=<optimized out>) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:200
#18 0x00007fe3963b8adf in QStyledItemDelegate::setModelData (this=<optimized out>, editor=0x1d75500, model=0x1b37210, index=...) at itemviews/qstyleditemdelegate.cpp:543
#19 0x00007fe39631526a in QAbstractItemView::commitData (this=<optimized out>, editor=0x1d75500) at itemviews/qabstractitemview.cpp:2770
#20 0x00007fe396318055 in QAbstractItemView::qt_metacall (this=0x1bb85b0, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0x7fff9ec59270) at .moc/release-shared/moc_qabstractitemview.cpp:247
#21 0x00007fe39635ebc5 in QTreeView::qt_metacall (this=0x1bb85b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9ec59270) at .moc/release-shared/moc_qtreeview.cpp:119
#22 0x00007fe3978aa9a0 in KBookmarkView::qt_metacall (this=0x1bb85b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9ec59270) at ./view.moc:69
#23 0x00007fe39541beba in QMetaObject::activate (sender=0x1bb98e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9ec59270) at kernel/qobject.cpp:3278
#24 0x00007fe39648164f in QAbstractItemDelegate::commitData (this=<optimized out>, _t1=0x1d75500) at .moc/release-shared/moc_qabstractitemdelegate.cpp:102
#25 0x00007fe3963b8814 in QStyledItemDelegate::eventFilter (this=0x1bb98e0, object=<optimized out>, event=<optimized out>) at itemviews/qstyleditemdelegate.cpp:696
#26 0x00007fe395408c88 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1d75500, event=0x7fff9ec597b0) at kernel/qcoreapplication.cpp:902
#27 0x00007fe395e0943f in notify_helper (e=0x7fff9ec597b0, receiver=0x1d75500, this=0x1a4db30) at kernel/qapplication.cpp:4482
#28 QApplicationPrivate::notify_helper (this=0x1a4db30, receiver=0x1d75500, e=0x7fff9ec597b0) at kernel/qapplication.cpp:4458
#29 0x00007fe395e0e2e1 in QApplication::notify (this=0x7fff9ec5bed0, receiver=0x1d75500, e=0x7fff9ec597b0) at kernel/qapplication.cpp:4365
#30 0x00007fe396b1e466 in KApplication::notify (this=0x7fff9ec5bed0, receiver=0x1d75500, event=0x7fff9ec597b0) at ../../kdeui/kernel/kapplication.cpp:311
#31 0x00007fe395408afc in QCoreApplication::notifyInternal (this=0x7fff9ec5bed0, receiver=0x1d75500, event=0x7fff9ec597b0) at kernel/qcoreapplication.cpp:787
#32 0x00007fe395e07c8e in sendEvent (event=0x7fff9ec597b0, receiver=0x1d75500) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QApplicationPrivate::setFocusWidget (focus=0x1e24180, reason=Qt::ActiveWindowFocusReason) at kernel/qapplication.cpp:2246
#34 0x00007fe395e4d7e9 in QWidget::setFocus (this=0x1e24180, reason=Qt::ActiveWindowFocusReason) at kernel/qwidget.cpp:6391
#35 0x00007fe395e0ce0c in QApplication::setActiveWindow (act=<optimized out>) at kernel/qapplication.cpp:2659
#36 0x00007fe395e88c4d in QApplication::x11ProcessEvent (this=0x7fff9ec5bed0, event=0x7fff9ec59e50) at kernel/qapplication_x11.cpp:3612
#37 0x00007fe395eb14a2 in x11EventSourceDispatch (s=0x1a51530, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x00007fe391d0da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007fe391d0e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007fe391d0e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fe395433ed6 in QEventDispatcherGlib::processEvents (this=0x1a2bfa0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#42 0x00007fe395eb110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007fe395407cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007fe395407ef7 in QEventLoop::exec (this=0x7fff9ec5a220, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007fe3962c02d6 in QDialog::exec (this=0x7fff9ec5a2a0) at dialogs/qdialog.cpp:552
#46 0x00007fe3973728d7 in KFileDialogPrivate::getOpenFileName (startDir=..., filter=..., parent=0x1b17ce0, caption=<optimized out>, selectedFilter=0x0) at ../../kio/kfile/kfiledialog.cpp:492
#47 0x00007fe3973732fc in KFileDialog::getOpenFileName (startDir=<optimized out>, filter=<optimized out>, parent=<optimized out>, caption=<optimized out>) at ../../kio/kfile/kfiledialog.cpp:468
#48 0x00007fe39735e453 in KNSBookmarkImporterImpl::findDefaultLocation (this=<optimized out>, forSaving=<optimized out>) at ../../kio/bookmarks/kbookmarkimporter_ns.cc:120
#49 0x00007fe397e7324c in MozImportCommand::requestFilename (this=<optimized out>) at ../../keditbookmarks/importers.cpp:176
#50 0x00007fe397e74c04 in ImportCommand::performImport (model=<optimized out>, type=<optimized out>, top=0x1b17ce0) at ../../keditbookmarks/importers.cpp:84
#51 0x00007fe397e71cdb in ActionsImpl::slotImport (this=0x1b3a880) at ../../keditbookmarks/actionsimpl.cpp:410
#52 0x00007fe397e72f05 in ActionsImpl::qt_metacall (this=0x1b3a880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=<optimized out>) at ./actionsimpl.moc:142
#53 0x00007fe39541beba in QMetaObject::activate (sender=0x1b5f770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9ec5a840) at kernel/qobject.cpp:3278
#54 0x00007fe395e02bb2 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#55 0x00007fe395e02d9f in QAction::activate (this=0x1b5f770, event=<optimized out>) at kernel/qaction.cpp:1257
#56 0x00007fe39623d6c9 in QMenuPrivate::activateCausedStack (this=0x1b97a20, causedStack=..., action=0x1b5f770, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1005
#57 0x00007fe396243312 in QMenuPrivate::activateAction (this=0x1b97a20, action=0x1b5f770, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1097
#58 0x00007fe396be00d0 in KMenu::mouseReleaseEvent (this=0x1b83670, e=0x7fff9ec5b250) at ../../kdeui/widgets/kmenu.cpp:464
#59 0x00007fe395e59cea in QWidget::event (this=0x1b83670, event=0x7fff9ec5b250) at kernel/qwidget.cpp:8295
#60 0x00007fe3962448bb in QMenu::event (this=0x1b83670, e=0x7fff9ec5b250) at widgets/qmenu.cpp:2405
#61 0x00007fe395e09474 in notify_helper (e=0x7fff9ec5b250, receiver=0x1b83670, this=0x1a4db30) at kernel/qapplication.cpp:4486
#62 QApplicationPrivate::notify_helper (this=0x1a4db30, receiver=0x1b83670, e=0x7fff9ec5b250) at kernel/qapplication.cpp:4458
#63 0x00007fe395e0ecbb in QApplication::notify (this=<optimized out>, receiver=0x1b83670, e=0x7fff9ec5b250) at kernel/qapplication.cpp:4047
#64 0x00007fe396b1e466 in KApplication::notify (this=0x7fff9ec5bed0, receiver=0x1b83670, event=0x7fff9ec5b250) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00007fe395408afc in QCoreApplication::notifyInternal (this=0x7fff9ec5bed0, receiver=0x1b83670, event=0x7fff9ec5b250) at kernel/qcoreapplication.cpp:787
#66 0x00007fe395e0a442 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#67 QApplicationPrivate::sendMouseEvent (receiver=0x1b83670, event=0x7fff9ec5b250, alienWidget=0x0, nativeWidget=0x1b83670, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#68 0x00007fe395e8a091 in QETWidget::translateMouseEvent (this=0x1b83670, event=<optimized out>) at kernel/qapplication_x11.cpp:4505
#69 0x00007fe395e8894e in QApplication::x11ProcessEvent (this=0x7fff9ec5bed0, event=0x7fff9ec5ba70) at kernel/qapplication_x11.cpp:3693
#70 0x00007fe395eb14a2 in x11EventSourceDispatch (s=0x1a51530, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#71 0x00007fe391d0da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#72 0x00007fe391d0e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#73 0x00007fe391d0e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#74 0x00007fe395433ed6 in QEventDispatcherGlib::processEvents (this=0x1a2bfa0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#75 0x00007fe395eb110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#76 0x00007fe395407cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#77 0x00007fe395407ef7 in QEventLoop::exec (this=0x7fff9ec5be40, flags=...) at kernel/qeventloop.cpp:201
#78 0x00007fe39540c789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#79 0x00007fe397e69afe in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../keditbookmarks/main.cpp:212
#80 0x00007fe397ad030d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff9ec5c778, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9ec5c768) at libc-start.c:226
#81 0x0000000000400671 in _start ()

Possible duplicates by query: bug 294008, bug 287038.

Reported using DrKonqi
Comment 1 Tommi Tervo 2012-06-11 17:12:52 UTC

*** This bug has been marked as a duplicate of bug 226187 ***