Bug 299938 - login bug
Summary: login bug
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-13 13:33 UTC by Doug L
Modified: 2012-05-27 00:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug L 2012-05-13 13:33:31 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.3.5-2.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
I had just installed the new kernel 3.3.5-2.fc16.x86_64 and rebooted.  I logged in and the error occurred.  

I have been having problems with nepomukservicestub and virtuoso-t for the last month.  both would crash right after login.  when I deleted the error in the bug reporting tool, they would crash again.

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  QMutex::lock (this=0x1a49ed8) at thread/qmutex.cpp:153
#7  0x0000003b32c1552d in lockInline (this=0x1a49ed8) at /usr/include/QtCore/qmutex.h:198
#8  QMutexLocker (m=0x1a49ed8, this=<synthetic pointer>) at /usr/include/QtCore/qmutex.h:109
#9  Soprano::Client::SocketHandler::~SocketHandler (this=0x19bd130, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:58
#10 0x0000003b32c15659 in Soprano::Client::SocketHandler::~SocketHandler (this=0x19bd130, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:61
#11 0x0000003b2e479aad in QThreadStorageData::set (this=0x1a607a0, p=0x1a23fd0) at thread/qthreadstorage.cpp:165
#12 0x0000003b32c1301f in qThreadStorage_setLocalData<Soprano::Client::SocketHandler> (t=<synthetic pointer>, d=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:92
#13 setLocalData (t=0x1a23fd0, this=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:155
#14 Soprano::Client::ClientConnection::socketForCurrentThread (this=0x1a3ab00) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:95
#15 0x0000003b32c13089 in Soprano::Client::ClientConnection::connectInCurrentThread (this=<optimized out>) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:800
#16 0x0000003b32c1265a in Soprano::Client::LocalSocketClient::connect (this=0x1a734f8, name=...) at /usr/src/debug/soprano-2.7.4/client/localsocketclient.cpp:141
#17 0x0000003ea6256531 in init (forced=true, this=0x1a734d0) at /usr/src/debug/kdelibs-4.8.3/nepomuk/core/nepomukmainmodel.cpp:102
#18 Nepomuk::MainModel::init (this=0x19ad490) at /usr/src/debug/kdelibs-4.8.3/nepomuk/core/nepomukmainmodel.cpp:176
#19 0x0000003ea624e501 in Nepomuk::ResourceManager::init (this=0x1a57e60) at /usr/src/debug/kdelibs-4.8.3/nepomuk/core/resourcemanager.cpp:326
#20 0x0000003ea6251ce5 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x19b94a0, success=<optimized out>) at /usr/src/debug/kdelibs-4.8.3/nepomuk/core/resourcemanager.cpp:225
#21 0x0000003ea6251e5b in Nepomuk::ResourceManager::qt_metacall (this=0x1a57e60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffab1bc680) at /usr/src/debug/kdelibs-4.8.3/x86_64-redhat-linux-gnu/nepomuk/resourcemanager.moc:111
#22 0x0000003b2ea22d2b in QDBusConnectionPrivate::deliverCall (this=0x1872100, object=0x1a57e60, msg=..., metaTypes=..., slotIdx=10) at qdbusintegrator.cpp:947
#23 0x0000003b2e5927a6 in QObject::event (this=0x1a57e60, e=<optimized out>) at kernel/qobject.cpp:1195
#24 0x0000003b2fdc9bc4 in notify_helper (e=0x19ada20, receiver=0x1a57e60, this=0x18891c0) at kernel/qapplication.cpp:4554
#25 QApplicationPrivate::notify_helper (this=0x18891c0, receiver=0x1a57e60, e=0x19ada20) at kernel/qapplication.cpp:4526
#26 0x0000003b2fdcea43 in QApplication::notify (this=0x7fffab1bd0b0, receiver=0x1a57e60, e=0x19ada20) at kernel/qapplication.cpp:4415
#27 0x0000003ea5851ff6 in KApplication::notify (this=0x7fffab1bd0b0, receiver=0x1a57e60, event=0x19ada20) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#28 0x0000003b2e5798dc in QCoreApplication::notifyInternal (this=0x7fffab1bd0b0, receiver=0x1a57e60, event=0x19ada20) at kernel/qcoreapplication.cpp:876
#29 0x0000003b2e57d36a in sendEvent (event=0x19ada20, receiver=0x1a57e60) at kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x184e2e0) at kernel/qcoreapplication.cpp:1500
#31 0x0000003b2e5a8193 in sendPostedEvents () at kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=0x1880110) at kernel/qeventdispatcher_glib.cpp:279
#33 0x0000003b2c844f3d in g_main_dispatch (context=0x187ede0) at gmain.c:2441
#34 g_main_context_dispatch (context=0x187ede0) at gmain.c:3011
#35 0x0000003b2c845738 in g_main_context_iterate (context=0x187ede0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#36 0x0000003b2c84590c in g_main_context_iteration (context=0x187ede0, may_block=1) at gmain.c:3152
#37 0x0000003b2e5a85bf in QEventDispatcherGlib::processEvents (this=0x184f7a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#38 0x0000003b2fe6c8ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#39 0x0000003b2e578a12 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x0000003b2e578c67 in QEventLoop::exec (this=0x7fffab1bd040, flags=...) at kernel/qeventloop.cpp:204
#41 0x0000003b2e57d665 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#42 0x0000000000405e64 in main (argc=1, argv=0x7fffab1bd2a8) at /usr/src/debug/kactivities-4.8.3/service/main.cpp:37

Possible duplicates by query: bug 299325, bug 297279, bug 295755, bug 293308, bug 293188.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-27 00:33:57 UTC

*** This bug has been marked as a duplicate of bug 290234 ***