Bug 299325 - KActivitymanager crash
Summary: KActivitymanager crash
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-03 20:30 UTC by Kevin Goeser
Modified: 2012-05-04 01:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Goeser 2012-05-03 20:30:38 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-tuxonice x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was starting the nepomuk services and also pressed ctrl-esc for opening the process list

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  QMutex::lock (this=0xd6f048) at thread/qmutex.cpp:153
#7  0x00007f27617140fa in lockInline (this=0xd6f048) at /usr/include/qt4/QtCore/qmutex.h:198
#8  QMutexLocker (m=0xd6f048, this=<synthetic pointer>) at /usr/include/qt4/QtCore/qmutex.h:109
#9  Soprano::Client::SocketHandler::~SocketHandler (this=0xd79940, __in_chrg=<optimized out>) at ../../client/clientconnection.cpp:58
#10 0x00007f27617141c9 in Soprano::Client::SocketHandler::~SocketHandler (this=0xd79940, __in_chrg=<optimized out>) at ../../client/clientconnection.cpp:61
#11 0x00007f2765414f9d in QThreadStorageData::set (this=0xd7dd00, p=0xd66430) at thread/qthreadstorage.cpp:165
#12 0x00007f2761711bef in qThreadStorage_setLocalData<Soprano::Client::SocketHandler> (d=..., t=<optimized out>) at /usr/include/qt4/QtCore/qthreadstorage.h:92
#13 setLocalData (t=0xd66430, this=<optimized out>) at /usr/include/qt4/QtCore/qthreadstorage.h:155
#14 Soprano::Client::ClientConnection::socketForCurrentThread (this=0xbb0f10) at ../../client/clientconnection.cpp:95
#15 0x00007f2761711c59 in Soprano::Client::ClientConnection::connectInCurrentThread (this=<optimized out>) at ../../client/clientconnection.cpp:800
#16 0x00007f276171122a in Soprano::Client::LocalSocketClient::connect (this=0xbb0918, name=...) at ../../client/localsocketclient.cpp:141
#17 0x00007f2765b3d431 in init (forced=true, this=0xbb08f0) at ../../nepomuk/core/nepomukmainmodel.cpp:102
#18 Nepomuk::MainModel::init (this=0xd60640) at ../../nepomuk/core/nepomukmainmodel.cpp:176
#19 0x00007f2765b35281 in Nepomuk::ResourceManager::init (this=0xd64a50) at ../../nepomuk/core/resourcemanager.cpp:326
#20 0x00007f2765b38a55 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0xd75a90, success=<optimized out>) at ../../nepomuk/core/resourcemanager.cpp:225
#21 0x00007f2765b38bcb in Nepomuk::ResourceManager::qt_metacall (this=0xd64a50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb6c28c70) at ./resourcemanager.moc:112
#22 0x00007f276589037b in QDBusConnectionPrivate::deliverCall (this=0xba6f90, object=0xd64a50, msg=..., metaTypes=..., slotIdx=10) at qdbusintegrator.cpp:947
#23 0x00007f276552f446 in QObject::event (this=0xd64a50, e=<optimized out>) at kernel/qobject.cpp:1195
#24 0x00007f2764898894 in notify_helper (e=0xd7e160, receiver=0xd64a50, this=0xbb2a00) at kernel/qapplication.cpp:4559
#25 QApplicationPrivate::notify_helper (this=0xbb2a00, receiver=0xd64a50, e=0xd7e160) at kernel/qapplication.cpp:4531
#26 0x00007f276489d713 in QApplication::notify (this=0x7fffb6c29670, receiver=0xd64a50, e=0xd7e160) at kernel/qapplication.cpp:4420
#27 0x00007f2765ffab46 in KApplication::notify (this=0x7fffb6c29670, receiver=0xd64a50, event=0xd7e160) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f2765515e9c in QCoreApplication::notifyInternal (this=0x7fffb6c29670, receiver=0xd64a50, event=0xd7e160) at kernel/qcoreapplication.cpp:876
#29 0x00007f2765519c6a in sendEvent (event=0xd7e160, receiver=0xd64a50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xb822c0) at kernel/qcoreapplication.cpp:1500
#31 0x00007f2765544f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#33 0x00007f2760beac9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f2760beb060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f2760beb124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f27655453bf in QEventDispatcherGlib::processEvents (this=0xb83780, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0x00007f2764940d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f2765514c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f2765514ed7 in QEventLoop::exec (this=0x7fffb6c29600, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f2765519f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#41 0x0000000000405b14 in main (argc=1, argv=0x7fffb6c29868) at ../../service/main.cpp:37

Possible duplicates by query: bug 297279, bug 295755, bug 293308, bug 293188.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-04 01:22:39 UTC

*** This bug has been marked as a duplicate of bug 290234 ***