Bug 297279 - kmedia crashes on login
Summary: kmedia crashes on login
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-02 05:40 UTC by Mark Rooks
Modified: 2012-04-02 07:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rooks 2012-04-02 05:40:03 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-8.fc16.i686.PAE i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

every time i log in it crashes.

it might be linked to an intermittent pulseaudio crash i am also getting

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb75b7780 (LWP 1951))]

Thread 2 (Thread 0xb6212b40 (LWP 1955)):
[KCrash Handler]
#7  QMutex::lock (this=0x859cecc) at thread/qmutex.cpp:153
#8  0x428daed8 in lockInline (this=<optimized out>) at /usr/include/QtCore/qmutex.h:198
#9  QMutexLocker (m=<optimized out>, this=0xb6211df4) at /usr/include/QtCore/qmutex.h:109
#10 Soprano::Error::ErrorCache::clearError (this=0xb59033d8) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:238
#11 0x428db228 in Soprano::Error::ErrorCache::setError (this=0xb59033d8, error=...) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:225
#12 0x42c1dcfa in Soprano::Client::DBusModel::executeQuery (this=0xb59033d0, query=..., language=Soprano::Query::QueryLanguageNone, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/dbus/dbusmodel.cpp:112
#13 0x423a4617 in Nepomuk::MainModel::executeQuery (this=0x866a528, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#14 0xb621868d in activityResource (id=...) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/NepomukCommon.cpp:49
#15 0xb621fd53 in RankingsUpdateThread::run (this=0x86d0bd8) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/Rankings.cpp:104
#16 0x415be0b1 in QThreadPrivate::start (arg=0x86d0bd8) at thread/qthread_unix.cpp:298
#17 0x4b6bccd3 in start_thread (arg=0xb6212b40) at pthread_create.c:309
#18 0x4b5f9a2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb75b7780 (LWP 1951)):
#0  0xb7740424 in __kernel_vsyscall ()
#1  0x4b5f22e1 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x41702c3c in qt_safe_select (nfds=5, fdread=0xbf8b75f8, fdwrite=0xbf8b7678, fdexcept=0x0, orig_timeout=0xbf8b76f8) at kernel/qcore_unix.cpp:93
#3  0x4144dec5 in QNativeSocketEnginePrivate::nativeSelect (this=0x8690d40, timeout=600000, checkRead=true, checkWrite=false, selectForRead=0xbf8b77be, selectForWrite=0xbf8b77bf) at socket/qnativesocketengine_unix.cpp:1115
#4  0x4144b9e5 in QNativeSocketEngine::waitForReadOrWrite (this=0x85d5660, readyToRead=0xbf8b77be, readyToWrite=0xbf8b77bf, checkRead=true, checkWrite=false, msecs=600000, timedOut=0x0) at socket/qnativesocketengine.cpp:1000
#5  0x41442157 in QAbstractSocket::waitForReadyRead (this=0x86fea5c, msecs=600000) at socket/qabstractsocket.cpp:1888
#6  0x41450422 in QLocalSocket::waitForReadyRead (this=0x85d8cf0, msecs=600000) at socket/qlocalsocket_unix.cpp:576
#7  0x42bf6aa6 in Soprano::Client::ClientConnection::executeQuery (this=0x866bb08, modelId=1734059733, query=..., type=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:269
#8  0x42bf8639 in Soprano::Client::ClientModel::executeQuery (this=0x86b0678, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/clientmodel.cpp:101
#9  0x423a4617 in Nepomuk::MainModel::executeQuery (this=0x866a528, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#10 0x423c162c in Nepomuk::Types::EntityPrivate::load (this=0x8702a28) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:76
#11 0x423c57fb in Nepomuk::Types::ClassPrivate::load (this=0x8702a28) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:54
#12 0x423c0264 in Nepomuk::Types::EntityPrivate::init (this=0x8702a28) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:51
#13 0x423c6afc in Nepomuk::Types::Class::isSubClassOf (this=0x86af3a0, other=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:493
#14 0x423c6b79 in Nepomuk::Types::Class::isSubClassOf (this=0xbf8b7b98, other=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:501
#15 0x4238ca9c in Nepomuk::ResourceData::constHasType (this=0x86fef40, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:255
#16 0x4238f0c0 in Nepomuk::ResourceData::load (this=0x86fef40) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:438
#17 0x4238f851 in Nepomuk::ResourceData::property (this=0x86fef40, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:265
#18 0x423a87c2 in Nepomuk::Resource::property (this=0xbf8b7df0, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:301
#19 0x423a895b in Nepomuk::Resource::symbols (this=0xbf8b7df0) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:841
#20 0x0804f424 in ActivityManager::ActivityIcon (this=0xbf8b89a0, id=...) at /usr/src/debug/kactivities-4.8.1/service/ActivityManager.cpp:736
#21 0x0805de17 in ActivityManagerAdaptor::ActivityIcon (this=0x85a6870, id=...) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.cpp:45
#22 0x0805e537 in qt_static_metacall (_a=0xbf8b7f7c, _id=8, _o=0x85a6870, _c=<optimized out>) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:186
#23 ActivityManagerAdaptor::qt_static_metacall (_o=0x85a6870, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbf8b7f7c) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:171
#24 0x0805e914 in ActivityManagerAdaptor::qt_metacall (this=0x85a6870, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8b7f7c) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:255
#25 0x414de6a8 in QDBusConnectionPrivate::deliverCall (this=0x8599810, object=0x85a6870, msg=..., metaTypes=..., slotIdx=-514) at qdbusintegrator.cpp:947
#26 0x414df8f8 in QDBusConnectionPrivate::activateCall (this=0x8599810, object=0x85a6870, flags=273, msg=...) at qdbusintegrator.cpp:857
#27 0x414e00cd in QDBusConnectionPrivate::activateObject (this=0x8599810, node=..., msg=..., pathStartPos=-1081376560) at qdbusintegrator.cpp:1443
#28 0x414e0469 in QDBusActivateObjectEvent::placeMetaCall (this=0x866b800) at qdbusintegrator.cpp:1537
#29 0x416ee42b in QObject::event (this=0xbf8b89a0, e=0x866b800) at kernel/qobject.cpp:1195
#30 0x416d3c3b in QCoreApplication::event (this=0xbf8b89a0, e=0x866b800) at kernel/qcoreapplication.cpp:1688
#31 0x44cb82fe in QApplication::event (this=0xbf8b89a0, e=0x866b800) at kernel/qapplication.cpp:2532
#32 0x44cb4134 in notify_helper (e=0x866b800, receiver=0xbf8b89a0, this=0x85a1288) at kernel/qapplication.cpp:4550
#33 QApplicationPrivate::notify_helper (this=0x85a1288, receiver=0xbf8b89a0, e=0x866b800) at kernel/qapplication.cpp:4522
#34 0x44cb95d3 in QApplication::notify (this=0x866b800, receiver=0xbf8b89a0, e=0x866b800) at kernel/qapplication.cpp:4279
#35 0x41e3e0d2 in KApplication::notify (this=0xbf8b89a0, receiver=0xbf8b89a0, event=0x866b800) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#36 0x416d35fe in QCoreApplication::notifyInternal (this=0xbf8b89a0, receiver=0xbf8b89a0, event=0x866b800) at kernel/qcoreapplication.cpp:876
#37 0x416d7558 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x857ca58) at kernel/qcoreapplication.cpp:1500
#39 0x416d788d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#40 0x41705eb5 in sendPostedEvents () at kernel/qcoreapplication.h:236
#41 postEventSourceDispatch (s=0x859d858) at kernel/qeventdispatcher_glib.cpp:279
#42 0x4b7af62f in g_main_dispatch (context=0x85a2af0) at gmain.c:2441
#43 g_main_context_dispatch (context=0x85a2af0) at gmain.c:3011
#44 0x4b7afd70 in g_main_context_iterate (context=0x85a2af0, block=1266411536, dispatch=1, self=0x85a0608) at gmain.c:3089
#45 0x4b7b001f in g_main_context_iteration (context=0x85a2af0, may_block=1) at gmain.c:3152
#46 0x417062b8 in QEventDispatcherGlib::processEvents (this=0x857d5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#47 0x44d68a9b in QGuiEventDispatcherGlib::processEvents (this=0x857d5c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#48 0x416d24ee in QEventLoop::processEvents (this=0xbf8b8904, flags=...) at kernel/qeventloop.cpp:149
#49 0x416d2799 in QEventLoop::exec (this=0xbf8b8904, flags=...) at kernel/qeventloop.cpp:204
#50 0x416d793b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#51 0x44cb1f35 in QApplication::exec () at kernel/qapplication.cpp:3811
#52 0x0804c62b in main (argc=1, argv=0xbf8b8aa4) at /usr/src/debug/kactivities-4.8.1/service/main.cpp:37

This bug may be a duplicate of or related to bug 290234.

Possible duplicates by query: bug 295755, bug 293308, bug 293188.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-04-02 07:36:56 UTC

*** This bug has been marked as a duplicate of bug 290234 ***