Bug 299710 - HTML5 Drag and drop doesn't work in Facebook's Words With Friends in rekonq.
Summary: HTML5 Drag and drop doesn't work in Facebook's Words With Friends in rekonq.
Status: REPORTED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdewebkit (show other bugs)
Version: 4.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: webkit-devel
URL: https://apps.facebook.com/wordswithfr...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-09 21:22 UTC by Ronald Buckman
Modified: 2014-11-19 01:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Buckman 2012-05-09 21:22:25 UTC
When I was using rekonq 0.9.2 with kdelibs 4.8.3 and tried to move a letter from the rack to the board while playing Words With Friends, the letter wouldn't move.   The letter moves as expected in QupZilla 1.2.0 running QtWebKit 2.2.1.

Reproducible: Always

Steps to Reproduce:
1.Make sure HTML5 local storage is enabled in Configure rekonq -> WebKit.
2. Facebook users should enter http://apps.facebook.com/wordswithfriends/
3.After the game is loaded and started try to drag a letter from the rack to the board.
Actual Results:  
The letter doesn't move.

Expected Results:  
The letter should move from the rack to the board.

The user may get logged off due to Bug 299590.  If the user is logged off, the user will have to log in again.  The game will not load in Konqueror due to Konqueror's non-support of HTML5 local storage.
Comment 1 Dawit Alemayehu 2012-05-11 20:05:18 UTC
Git commit 2cf247f4ebdee44d0620e57f9cd17fa963b36b73 by Dawit Alemayehu.
Committed on 11/05/2012 at 19:35.
Pushed by adawit into branch 'KDE/4.8'.

Revert commit 462a06ea as it causes many regressions. Use KIO::synchronousRun
to fulfill synchrounous XmlHttpRequest instead.

Unofrtunately this means that the fix for the crash reported in bug# 287778
is reverted until we can find a solution for the side effects of using nested
event loops.
Related: bug 297954, bug 299590, bug 287778
FIXED-IN: 4.8.4

M  +63   -37   kio/kio/accessmanager.cpp
M  +1    -0    kio/kio/accessmanager.h
M  +126  -81   kio/kio/accessmanagerreply_p.cpp
M  +22   -8    kio/kio/accessmanagerreply_p.h

http://commits.kde.org/kdelibs/2cf247f4ebdee44d0620e57f9cd17fa963b36b73
Comment 2 Dawit Alemayehu 2012-07-16 22:57:16 UTC
See comment #1. Feel free to reopen this ticket if the issue is not resolved in KDE 4.8.4 or higher for you.
Comment 3 Ronald Buckman 2012-10-11 22:41:58 UTC
The bug is still present in KDE 4.9.2.
Comment 4 Ronald Buckman 2014-04-11 21:01:08 UTC
There is a bug in QtWebKit 2.3.3 in which Words with Friends starts to load and the part of the screen where the game is located turns white.  Confirmed on both QupZilla 1.6.3 and rekonq 2.4.2 on KDE SC 4.12.4 in siduction OS (based on Debian sid).  I marked it as RESOLVED UPSTREAM.  It could be reopened after KDE becomes based on a version of Qt in which that bug is fixed if the drag and drop bug still persists in rekonq.
Comment 5 Ronald Buckman 2014-11-19 01:39:05 UTC
This bug should be reopened, because Words with Friends runs in QupZilla 1.4.4 running the same version of QtWebKIt (2.3.4) as rekonq and Konqueror.  Confirmed in Fedora 20.