Bug 299590 - rekonq logoff everytime I click on a link that keeps me in Facebook
Summary: rekonq logoff everytime I click on a link that keeps me in Facebook
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdewebkit (show other bugs)
Version: 4.8
Platform: Compiled Sources Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: webkit-devel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-07 21:15 UTC by Ezio Vergine
Modified: 2012-06-04 08:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ezio Vergine 2012-05-07 21:15:54 UTC
From facebook, every time I click on a link a link that point at a facebook paga, rekonq logoff everytime. This doesn' occour with old 9.1.

Rekonq 0.9.2 build from source on kubuntu 11.10. Kde 4.8.2

Reproducible: Always

Steps to Reproduce:
1. Login on facebook
2. click on a link that point to a facebook page
Actual Results:  
rekonq logoff

Expected Results:  
stay logged on facebook
Comment 1 Hendrik Borghorst 2012-05-08 05:35:30 UTC
It also happens with konqueror and kdewebkit. So I think the Product should be changed. It seems to be a bug of kdewebkit in combination with qt 4.8. 

I've compiled arora against qt 4.8 which works fine for Facebook. But all the Kdewebkit browsers won't.
Comment 2 Andrea Diamantini 2012-05-08 06:39:59 UTC
Ok, moving product..
Comment 3 Dawit Alemayehu 2012-05-11 20:05:18 UTC
Git commit 2cf247f4ebdee44d0620e57f9cd17fa963b36b73 by Dawit Alemayehu.
Committed on 11/05/2012 at 19:35.
Pushed by adawit into branch 'KDE/4.8'.

Revert commit 462a06ea as it causes many regressions. Use KIO::synchronousRun
to fulfill synchrounous XmlHttpRequest instead.

Unofrtunately this means that the fix for the crash reported in bug# 287778
is reverted until we can find a solution for the side effects of using nested
event loops.
Related: bug 297954, bug 299710, bug 287778
FIXED-IN: 4.8.4

M  +63   -37   kio/kio/accessmanager.cpp
M  +1    -0    kio/kio/accessmanager.h
M  +126  -81   kio/kio/accessmanagerreply_p.cpp
M  +22   -8    kio/kio/accessmanagerreply_p.h

http://commits.kde.org/kdelibs/2cf247f4ebdee44d0620e57f9cd17fa963b36b73
Comment 4 Simply 2012-06-04 08:30:49 UTC
Problem exists in both rekonq 0.9.1 & 0.9.61 on Kubuntu 12.04 (KDE 4.8.3). Clicking on a link oon the page results in logoff BUT if I right click on the link and open in a new tab, there is no issue.
Comment 5 Hendrik Borghorst 2012-06-04 08:34:40 UTC
Ofcourse the problem exists for kde 4.8.3, you need 4.8.4 or manually patch your kdelibs with patch above. 

See comment 3 "FIXED-IN: 4.8.4"
Comment 6 Simply 2012-06-04 08:54:59 UTC
(In reply to comment #5)
> Ofcourse the problem exists for kde 4.8.3, you need 4.8.4 or manually patch
> your kdelibs with patch above. 
> 
> See comment 3 "FIXED-IN: 4.8.4"

Thanks. I missed that one.