Bug 299567 - app managercrashes at startup
Summary: app managercrashes at startup
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-07 16:47 UTC by lueichmeyer
Modified: 2012-05-27 00:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lueichmeyer 2012-05-07 16:47:17 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-2-desktop x86_64
Distribution: "openSUSE 12.2 Milestone 3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

just after system startup before any action was taken

- Custom settings of the application:

in software raid configuration with ssd and revodrive

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2a401e6780 (LWP 1424))]

Thread 2 (Thread 0x7f2a308de700 (LWP 1473)):
[KCrash Handler]
#6  lockInline (this=0x151d258) at /usr/include/QtCore/qmutex.h:187
#7  QMutexLocker (m=0x151d258, this=0x7f2a308dd440) at /usr/include/QtCore/qmutex.h:109
#8  Soprano::Error::ErrorCache::clearError (this=0x15797a0) at /usr/src/debug/soprano-2.7.5/soprano/error.cpp:238
#9  0x00007f2a3ef12e68 in Soprano::Error::ErrorCache::setError (this=0x15797a0, error=...) at /usr/src/debug/soprano-2.7.5/soprano/error.cpp:225
#10 0x00007f2a3a3523bf in Soprano::Client::DBusModel::executeQuery (this=0x1579790, query=<optimized out>, language=<optimized out>, userQueryLanguage=<optimized out>) at /usr/src/debug/soprano-2.7.5/client/dbus/dbusmodel.cpp:112
#11 0x00007f2a3f219d6c in Nepomuk::MainModel::executeQuery (this=0x1530db0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x00007f2a308e695c in activityResource (id=...) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/NepomukCommon.cpp:49
#13 0x00007f2a308ed618 in RankingsUpdateThread::run (this=0x1580b90) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/Rankings.cpp:104
#14 0x00007f2a3e5a046b in QThreadPrivate::start (arg=0x1580b90) at thread/qthread_unix.cpp:298
#15 0x00007f2a3e309daa in start_thread (arg=0x7f2a308de700) at pthread_create.c:305
#16 0x00007f2a3c9000ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f2a401e6780 (LWP 1424)):
#0  0x00007f2a3e31041d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f2a39a4e59f in read (__nbytes=16, __buf=0x7fff45f0bf60, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0x13c4310) at gwakeup.c:212
#3  0x00007f2a39a137ed in g_main_context_check (context=0x13c4440, max_priority=2147483647, fds=0x1582900, n_fds=4) at gmain.c:2957
#4  0x00007f2a39a13cc6 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x13c4440, self=<optimized out>) at gmain.c:3120
#5  g_main_context_iterate (context=0x13c4440, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3060
#6  0x00007f2a39a13e54 in g_main_context_iteration (context=0x13c4440, may_block=1) at gmain.c:3184
#7  0x00007f2a3e6cc7f6 in QEventDispatcherGlib::processEvents (this=0x139de30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#8  0x00007f2a3d8aa2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#9  0x00007f2a3e69c572 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#10 0x00007f2a3e69c7c7 in QEventLoop::exec (this=0x7fff45f0c110, flags=...) at kernel/qeventloop.cpp:204
#11 0x00007f2a3e6a1325 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#12 0x00000000004060e4 in main (argc=1, argv=0x7fff45f0c378) at /usr/src/debug/kactivities-4.8.1/service/main.cpp:37

This bug may be a duplicate of or related to bug 290234.

Possible duplicates by query: bug 297279, bug 296846, bug 296418, bug 295755, bug 295007.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-27 00:33:12 UTC

*** This bug has been marked as a duplicate of bug 290234 ***