Bug 295007 - kactivitymanagered crashed on me
Summary: kactivitymanagered crashed on me
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 16:25 UTC by Steven Ward
Modified: 2012-02-28 16:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Ward 2012-02-28 16:25:37 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.00 (4.8.0)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-0.rc4.git1.4.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:I was booting my Fedora 17 dual-boot computer as normal. When I logged in, Crash Report Assistant had opened up telling me abou this problem

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f0d4de00880 (LWP 858))]

Thread 2 (Thread 0x7f0d42dd8700 (LWP 881)):
[KCrash Handler]
#6  0x0000003a594527d5 in lockInline (this=0x15bca88) at /usr/include/QtCore/qmutex.h:187
#7  QMutexLocker (m=0x15bca88, this=0x7f0d42dd7720) at /usr/include/QtCore/qmutex.h:109
#8  Soprano::Error::ErrorCache::clearError (this=this@entry=0x7f0d3c002b80) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:238
#9  0x0000003a59452ab0 in Soprano::Error::ErrorCache::setError (this=0x7f0d3c002b80, error=...) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:225
#10 0x0000003a58035bec in Soprano::Client::DBusModel::executeQuery (this=0x7f0d3c002b70, query=..., language=<optimized out>, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/dbus/dbusmodel.cpp:112
#11 0x0000003a59c5298a in Nepomuk::MainModel::executeQuery (this=0x173c030, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.0/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x0000003a5945debc in Soprano::FilterModel::executeQuery (this=0x1714b80, query=..., language=<optimized out>, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/soprano/filtermodel.cpp:164
#13 0x00007f0d42de0235 in activityResource (id=...) at /usr/src/debug/kactivities-4.8.0/service/plugins/nepomuk/NepomukCommon.cpp:49
#14 0x00007f0d42de64f8 in RankingsUpdateThread::run (this=0x17819b0) at /usr/src/debug/kactivities-4.8.0/service/plugins/nepomuk/Rankings.cpp:104
#15 0x0000003a5387b4cb in QThreadPrivate::start (arg=0x17819b0) at thread/qthread_unix.cpp:298
#16 0x000000399d207d14 in start_thread (arg=0x7f0d42dd8700) at pthread_create.c:309
#17 0x000000399caf105d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f0d4de00880 (LWP 858)):
#0  0x000000399d20e07d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000003a514827af in read (__nbytes=16, __buf=0x7fff23544970, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0x15c4d10) at gwakeup.c:212
#3  0x0000003a514474fa in g_main_context_check (context=context@entry=0x15c32c0, max_priority=2147483647, fds=fds@entry=0x178f340, n_fds=n_fds@entry=4) at gmain.c:2952
#4  0x0000003a51447a02 in g_main_context_iterate (context=context@entry=0x15c32c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3115
#5  0x0000003a51447b84 in g_main_context_iteration (context=0x15c32c0, may_block=1) at gmain.c:3179
#6  0x0000003a539a2956 in QEventDispatcherGlib::processEvents (this=0x1596780, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x0000003a55269c0e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#8  0x0000003a5397382f in QEventLoop::processEvents (this=this@entry=0x7fff23544b50, flags=...) at kernel/qeventloop.cpp:149
#9  0x0000003a53973ab8 in QEventLoop::exec (this=0x7fff23544b50, flags=...) at kernel/qeventloop.cpp:204
#10 0x0000003a539782fc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#11 0x0000000000405ab5 in main (argc=1, argv=0x7fff23544da8) at /usr/src/debug/kactivities-4.8.0/service/main.cpp:37

Possible duplicates by query: bug 293188, bug 291375, bug 290234.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-28 16:49:20 UTC

*** This bug has been marked as a duplicate of bug 290234 ***