Bug 299058 - Crash on shotdown
Summary: Crash on shotdown
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-29 19:17 UTC by harun.pekdemir
Modified: 2012-04-30 00:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description harun.pekdemir 2012-04-29 19:17:39 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

When I try to shotdown the application crashed. It also crashed when I try to open mp3 file.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4ef6634780 (LWP 2518))]

Thread 12 (Thread 0x7f4ed4a6f700 (LWP 2578)):
#0  0x00007f4ef2f37b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4eeb39a35f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f4eeb38b76c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f4eeb38bdd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f4eeb38be90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f4eeb39a30f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f4ee67dfd18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007f4eef65ae9a in start_thread (arg=0x7f4ed4a6f700) at pthread_create.c:308
#8  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f4ec7556700 (LWP 2639)):
#0  0x00007f4eef65cf69 in __pthread_mutex_lock (mutex=0x7f4ec0000aa0) at pthread_mutex_lock.c:92
#1  0x00007f4eedb78561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4eedb3ca3e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4eedb3cf96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4eedb3d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4ef38ce426 in QEventDispatcherGlib::processEvents (this=0x7f4ec0000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f4ef389dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4ef389ded7 in QEventLoop::exec (this=0x7f4ec7555dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4ef379cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f4ef387d9ff in QInotifyFileSystemWatcherEngine::run (this=0x1d62190) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x1d62190) at thread/qthread_unix.cpp:298
#11 0x00007f4eef65ae9a in start_thread (arg=0x7f4ec7556700) at pthread_create.c:308
#12 0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f4ec5238700 (LWP 2649)):
#0  qt_gettime () at tools/qelapsedtimer_unix.cpp:138
#1  0x00007f4ef38ceb8d in QTimerInfoList::updateCurrentTime (this=0x7f4eb8002060) at kernel/qeventdispatcher_unix.cpp:343
#2  0x00007f4ef38ce841 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#3  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#4  0x00007f4eedb3ca33 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4eedb3cf96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f4eedb3d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f4ef38ce426 in QEventDispatcherGlib::processEvents (this=0x7f4eb80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0x00007f4ef389dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f4ef389ded7 in QEventLoop::exec (this=0x7f4ec5237e00, flags=...) at kernel/qeventloop.cpp:204
#10 0x00007f4ef379cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#11 0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x207a7a0) at thread/qthread_unix.cpp:298
#12 0x00007f4eef65ae9a in start_thread (arg=0x7f4ec5238700) at pthread_create.c:308
#13 0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f4ebfc37700 (LWP 2650)):
#0  0x00007f4ef2f37b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4eedb3cff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4eedb3d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4ef38ce426 in QEventDispatcherGlib::processEvents (this=0x7f4eb40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4ef389dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4ef389ded7 in QEventLoop::exec (this=0x7f4ebfc36e00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4ef379cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x2081e10) at thread/qthread_unix.cpp:298
#8  0x00007f4eef65ae9a in start_thread (arg=0x7f4ebfc37700) at pthread_create.c:308
#9  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f4ebe627700 (LWP 2660)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4ef37a04db in wait (time=18446744073709551615, this=0x210bb80) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x210bd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4ef0bee0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x210ba30, th=0x210c120) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4ef0bf09db in ThreadWeaver::WorkingHardState::applyForWork (this=0x210bdd0, th=0x210c120) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4ef0bef84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4ebe626e20, parent=0x210ba30, th=0x210c120) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f4ef0bef8db in ThreadWeaver::Thread::run (this=0x210c120) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x210c120) at thread/qthread_unix.cpp:298
#8  0x00007f4eef65ae9a in start_thread (arg=0x7f4ebe627700) at pthread_create.c:308
#9  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f4ebf436700 (LWP 3621)):
#0  0x00007f4eef65cf69 in __pthread_mutex_lock (mutex=0x7f4eac003100) at pthread_mutex_lock.c:92
#1  0x00007f4eedb78561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4eedb3c555 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4eedb3cf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4eedb3d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4ef38ce426 in QEventDispatcherGlib::processEvents (this=0x7f4eac002470, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f4ef389dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4ef389ded7 in QEventLoop::exec (this=0x7f4ebf435dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4ef379cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f4ef387d9ff in QInotifyFileSystemWatcherEngine::run (this=0x286cae0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x286cae0) at thread/qthread_unix.cpp:298
#11 0x00007f4eef65ae9a in start_thread (arg=0x7f4ebf436700) at pthread_create.c:308
#12 0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f4ebcb49700 (LWP 3625)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4ef37a04db in wait (time=18446744073709551615, this=0x210bb80) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x210bd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4ef0bee0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x210ba30, th=0x27a05d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4ef0bf09db in ThreadWeaver::WorkingHardState::applyForWork (this=0x210bdd0, th=0x27a05d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4ef0bef84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4ebcb48e20, parent=0x210ba30, th=0x27a05d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f4ef0bef8db in ThreadWeaver::Thread::run (this=0x27a05d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x27a05d0) at thread/qthread_unix.cpp:298
#8  0x00007f4eef65ae9a in start_thread (arg=0x7f4ebcb49700) at pthread_create.c:308
#9  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f4eabfff700 (LWP 3626)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4ef37a04db in wait (time=18446744073709551615, this=0x210bb80) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x210bd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4ef0bee0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x210ba30, th=0x27a1260) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4ef0bf09db in ThreadWeaver::WorkingHardState::applyForWork (this=0x210bdd0, th=0x27a1260) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4ef0bef84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4eabffee20, parent=0x210ba30, th=0x27a1260) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f4ef0bef8db in ThreadWeaver::Thread::run (this=0x27a1260) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x27a1260) at thread/qthread_unix.cpp:298
#8  0x00007f4eef65ae9a in start_thread (arg=0x7f4eabfff700) at pthread_create.c:308
#9  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4eab7fe700 (LWP 3627)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4ef37a04db in wait (time=18446744073709551615, this=0x210bb80) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x210bd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4ef0bee0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x210ba30, th=0x27a1f30) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4ef0bf09db in ThreadWeaver::WorkingHardState::applyForWork (this=0x210bdd0, th=0x27a1f30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4ef0bef84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4eab7fde20, parent=0x210ba30, th=0x27a1f30) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f4ef0bef8db in ThreadWeaver::Thread::run (this=0x27a1f30) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f4ef379ffcb in QThreadPrivate::start (arg=0x27a1f30) at thread/qthread_unix.cpp:298
#8  0x00007f4eef65ae9a in start_thread (arg=0x7f4eab7fe700) at pthread_create.c:308
#9  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4eaabd7700 (LWP 3628)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4eea778dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f4eea778f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f4eef65ae9a in start_thread (arg=0x7f4eaabd7700) at pthread_create.c:308
#4  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4ea99c0700 (LWP 3634)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4eefc34222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f4eefc34259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f4eef65ae9a in start_thread (arg=0x7f4ea99c0700) at pthread_create.c:308
#4  0x00007f4ef2f434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4ef6634780 (LWP 2518)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f4ef54e602e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x1c53840, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f4ef54e6209 in CollectionManager::~CollectionManager (this=0x1c53840, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f4ef54e44b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f4ef56194cf in App::~App (this=0x7ffff419e9b0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=3, argv=0x7ffff41a0e38) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 298331.

Possible duplicates by query: bug 298760, bug 298331, bug 298222, bug 297555, bug 297164.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-04-30 00:16:29 UTC

*** This bug has been marked as a duplicate of bug 285951 ***