Bug 297555 - Amarok crashed on shutdown step of restart
Summary: Amarok crashed on shutdown step of restart
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-05 19:47 UTC by Russ Fineman
Modified: 2012-04-06 09:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Fineman 2012-04-05 19:47:13 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.2 (4.8.2) "release 491"
Qt Version: 4.8.1
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Selected leave -->restart.

openSUSE 11.4
KDE 4.8.2 release 491

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbdbe3ff7a0 (LWP 4703))]

Thread 11 (Thread 0x7fbd66c8b700 (LWP 4729)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbda210c314 in ?? () from /usr/lib64/libvlccore.so.4
#2  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#3  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fbd64b11700 (LWP 4733)):
#0  0x00007fff03bda8de in ?? ()
#1  0x00007fbdb4c21d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007fbdbc25df64 in do_gettime (frac=0x7fbd64b10a78, sec=0x7fbd64b10a70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbdbc334a4d in QTimerInfoList::updateCurrentTime (this=0x7fbd58001140) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fbdbc334d83 in QTimerInfoList::timerWait (this=0x7fbd58001140, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fbdbc3337bc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbd64b10b5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbdbc333865 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fbdb496cb22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fbdb496d92d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fbdb496df59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fbdbc3342e6 in QEventDispatcherGlib::processEvents (this=0x7fbd58002280, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fbdbc304012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fbdbc304267 in QEventLoop::exec (this=0x7fbd64b10cf0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fbdbc204547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fbdbc2e3dff in QInotifyFileSystemWatcherEngine::run (this=0xfc1e60) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fbdbc20756b in QThreadPrivate::start (arg=0xfc1e60) at thread/qthread_unix.cpp:298
#17 0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#18 0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#19 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fbd5f09b700 (LWP 4734)):
#0  0x00007fbdb496c1b7 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fbdb496d8b1 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbdb496df59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbdbc3342e6 in QEventDispatcherGlib::processEvents (this=0x7fbd4c0008e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbdbc304012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbdbc304267 in QEventLoop::exec (this=0x7fbd5f09ad20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbdbc204547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x11acb40) at thread/qthread_unix.cpp:298
#8  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fbd5e21f700 (LWP 4735)):
#0  0x00007fbdb8e2211f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007fbdb496d8a9 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbdb496df59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbdbc3342e6 in QEventDispatcherGlib::processEvents (this=0x7fbd440008e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbdbc304012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbdbc304267 in QEventLoop::exec (this=0x7fbd5e21ed20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbdbc204547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x1141280) at thread/qthread_unix.cpp:298
#8  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fbd5cc0a700 (LWP 4737)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbdbc207a7b in wait (time=18446744073709551615, this=0x9c5e70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x98ad80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbdb81fd96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10487d0, th=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fbdb820025b in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fbdb8200274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fbdb8200274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fbdb81ff0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7fbd5cc09d40, parent=0x10487d0, th=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#8  0x00007fbdb81ff15b in ThreadWeaver::Thread::run (this=0x1242770) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#9  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x1242770) at thread/qthread_unix.cpp:298
#10 0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#12 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fbd535b1700 (LWP 4740)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbdbc207a7b in wait (time=18446744073709551615, this=0x9c5e70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x98ad80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbdb81fd96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10487d0, th=0x15b77f0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fbdb820025b in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x15b77f0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fbdb8200274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x15b77f0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fbdb81ff0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7fbd535b0d40, parent=0x10487d0, th=0x15b77f0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#7  0x00007fbdb81ff15b in ThreadWeaver::Thread::run (this=0x15b77f0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#8  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x15b77f0) at thread/qthread_unix.cpp:298
#9  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fbd52db0700 (LWP 4741)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbdbc207a7b in wait (time=18446744073709551615, this=0x9c5e70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x98ad80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbdb81fd96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10487d0, th=0x15b8530) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fbdb820025b in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x15b8530) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fbdb81ff0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7fbd52dafd40, parent=0x10487d0, th=0x15b8530) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#6  0x00007fbdb81ff15b in ThreadWeaver::Thread::run (this=0x15b8530) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#7  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x15b8530) at thread/qthread_unix.cpp:298
#8  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fbd525af700 (LWP 4742)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbdbc207a7b in wait (time=18446744073709551615, this=0x9c5e70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x98ad80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fbdb81fd96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10487d0, th=0x15b92b0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fbdb820025b in ThreadWeaver::WorkingHardState::applyForWork (this=0x9dca20, th=0x15b92b0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fbdb81ff0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7fbd525aed40, parent=0x10487d0, th=0x15b92b0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#6  0x00007fbdb81ff15b in ThreadWeaver::Thread::run (this=0x15b92b0) at /usr/src/debug/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#7  0x00007fbdbc20756b in QThreadPrivate::start (arg=0x15b92b0) at thread/qthread_unix.cpp:298
#8  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fbd5176b700 (LWP 4745)):
#0  0x00007fbdb8e22e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbdb17b9c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fbdb21581a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007fbdb17b9c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#4  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbd33fff700 (LWP 4788)):
#0  0x00007fbdbaca58dd in nanosleep () from /lib64/libc.so.6
#1  0x00007fbdbaca5768 in sleep () from /lib64/libc.so.6
#2  0x00007fbdb72198e5 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fbdb7512e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2363
#3  0x00007fbdb7219989 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x00007fbdac2d3354 in ?? () from /usr/lib64/libGL.so.1
#5  0x00007fbdb8e1ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fbdbacd710d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbdbe3ff7a0 (LWP 4703)):
[KCrash Handler]
#6  0x00007fbdbc31d44d in QObject::~QObject (this=0x100c8a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:820
#7  0x00007fbdbc31dcd9 in QObject::~QObject (this=0x100c8a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:940
#8  0x00007fbdbd2a8a9e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#9  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#10 CollectionManager::~CollectionManager (this=0x81ae00, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#11 0x00007fbdbd2a8c89 in CollectionManager::~CollectionManager (this=0x81ae00, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#12 0x00007fbdbd2a6f26 in CollectionManager::destroy () at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#13 0x00007fbdbd3dbedf in App::~App (this=0x7fff03b99bc0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/App.cpp:248
#14 0x000000000040909a in main (argc=3, argv=0x7fff03b9c048) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301

Possible duplicates by query: bug 294709, bug 281312, bug 270918.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-04-06 09:29:26 UTC

*** This bug has been marked as a duplicate of bug 285951 ***