Bug 297164 - Amarok always crashes when I quit
Summary: Amarok always crashes when I quit
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-31 06:41 UTC by Mark Szentes-Wanner
Modified: 2012-04-01 22:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Szentes-Wanner 2012-03-31 06:41:32 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.2.0-20-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Any time I terminate amaroK, it crashes. No matter if by control+Q, File->Exit or system shut down.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4c46b40780 (LWP 31543))]

Thread 11 (Thread 0x7f4c1775f700 (LWP 31548)):
#0  0x00007f4c4343bb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4c3e0410e6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4c3e041214 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c43dd1a96 in QEventDispatcherGlib::processEvents (this=0x7f4c10000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4c43da12f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4c43da1547 in QEventLoop::exec (this=0x7f4c1775edd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4c43ca0f97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4c43d8106f in QInotifyFileSystemWatcherEngine::run (this=0x143c6c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x143c6c0) at thread/qthread_unix.cpp:298
#9  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4c1775f700) at pthread_create.c:308
#10 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f4c15384700 (LWP 31549)):
#0  0x00007f4c3e07c8b9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f4c3e040fac in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4c3e041214 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c43dd1a96 in QEventDispatcherGlib::processEvents (this=0x7f4c080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4c43da12f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4c43da1547 in QEventLoop::exec (this=0x7f4c15383e00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4c43ca0f97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x16fc2b0) at thread/qthread_unix.cpp:298
#8  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4c15384700) at pthread_create.c:308
#9  0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f4c0fda3700 (LWP 31550)):
#0  0x00007f4c3fb6205d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f4c04000a60) at pthread_mutex_unlock.c:290
#2  0x00007f4c3e07c8c1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c3e040ffe in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4c3e041214 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4c43dd1a96 in QEventDispatcherGlib::processEvents (this=0x7f4c040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f4c43da12f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4c43da1547 in QEventLoop::exec (this=0x7f4c0fda2e00, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4c43ca0f97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x172a320) at thread/qthread_unix.cpp:298
#10 0x00007f4c3fb5ee9a in start_thread (arg=0x7f4c0fda3700) at pthread_create.c:308
#11 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f4c0e996700 (LWP 31552)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c43ca44cb in wait (time=18446744073709551615, this=0x1783a70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1783bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4c410f20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1783920, th=0x1785890) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4c410f49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1785890) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4c410f49f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1785890) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f4c410f49f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1785890) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f4c410f384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4c0e995e20, parent=0x1783920, th=0x1785890) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f4c410f38db in ThreadWeaver::Thread::run (this=0x1785890) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x1785890) at thread/qthread_unix.cpp:298
#10 0x00007f4c3fb5ee9a in start_thread (arg=0x7f4c0e996700) at pthread_create.c:308
#11 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f4c0d2e0700 (LWP 31553)):
#0  0x00007f4c3fb60e8c in __pthread_mutex_lock (mutex=0x7f4bf4000a60) at pthread_mutex_lock.c:50
#1  0x00007f4c3e07c891 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4c3e040819 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4c3e04100b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4c3e041214 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4c43dd1a96 in QEventDispatcherGlib::processEvents (this=0x7f4bf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f4c43da12f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4c43da1547 in QEventLoop::exec (this=0x7f4c0d2dfdd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4c43ca0f97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f4c43d8106f in QInotifyFileSystemWatcherEngine::run (this=0x1a07a00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x1a07a00) at thread/qthread_unix.cpp:298
#11 0x00007f4c3fb5ee9a in start_thread (arg=0x7f4c0d2e0700) at pthread_create.c:308
#12 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f4bfbfff700 (LWP 31554)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c43ca44cb in wait (time=18446744073709551615, this=0x1783a70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1783bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4c410f20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1783920, th=0x1acb650) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4c410f49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1acb650) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4c410f49f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1acb650) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f4c410f384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4bfbffee20, parent=0x1783920, th=0x1acb650) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f4c410f38db in ThreadWeaver::Thread::run (this=0x1acb650) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x1acb650) at thread/qthread_unix.cpp:298
#9  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4bfbfff700) at pthread_create.c:308
#10 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f4bfb7fe700 (LWP 31555)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c43ca44cb in wait (time=18446744073709551615, this=0x1783a70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1783bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4c410f20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1783920, th=0x1abb550) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4c410f49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1abb550) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4c410f49f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1abb550) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f4c410f384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4bfb7fde20, parent=0x1783920, th=0x1abb550) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f4c410f38db in ThreadWeaver::Thread::run (this=0x1abb550) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x1abb550) at thread/qthread_unix.cpp:298
#9  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4bfb7fe700) at pthread_create.c:308
#10 0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4bfaffd700 (LWP 31556)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c43ca44cb in wait (time=18446744073709551615, this=0x1783a70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1783bf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4c410f20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1783920, th=0x1a62d50) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4c410f49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1783cc0, th=0x1a62d50) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f4c410f384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4bfaffce20, parent=0x1783920, th=0x1a62d50) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f4c410f38db in ThreadWeaver::Thread::run (this=0x1a62d50) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f4c43ca3fbb in QThreadPrivate::start (arg=0x1a62d50) at thread/qthread_unix.cpp:298
#8  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4bfaffd700) at pthread_create.c:308
#9  0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4bfa7fc700 (LWP 31557)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c3ac7cdec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f4c3b645de0) at wtf/FastMalloc.cpp:2495
#2  0x00007f4c3ac7cf19 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4bfa7fc700) at pthread_create.c:308
#4  0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4bf95e5700 (LWP 31560)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4c40139212 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f4c40139249 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f4c3fb5ee9a in start_thread (arg=0x7f4bf95e5700) at pthread_create.c:308
#4  0x00007f4c434474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4c46b40780 (LWP 31543)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f4c459ea02e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x136e760, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f4c459ea209 in CollectionManager::~CollectionManager (this=0x136e760, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f4c459e84b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f4c45b1d4cf in App::~App (this=0x7fffc9213330, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fffc92157b8) at ../../src/main.cpp:303

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-04-01 22:15:17 UTC

*** This bug has been marked as a duplicate of bug 285951 ***