Bug 295213 - Nepomuk crashed on shutdown
Summary: Nepomuk crashed on shutdown
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 297065 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-02 15:06 UTC by Lewkow Brigitte
Modified: 2012-05-26 02:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (19.26 KB, text/plain)
2012-03-23 17:32 UTC, Rudolf Leitgeb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2012-03-02 15:06:06 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I'd just shutdown computer.. That is not the first time but i don't know what can produce this crash?!

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7fb0a5513780 (LWP 2309))]

Thread 10 (Thread 0x7fb08b44f700 (LWP 2581)):
#0  0x00007fb0a2b57773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb0a1d8af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb0a5016f3e in QEventDispatcherGlib::processEvents (this=0x225a3e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb08b44edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb0a4fcdcbf in QInotifyFileSystemWatcherEngine::run (this=0x225ca00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x225ca00) at thread/qthread_unix.cpp:331
#9  0x00007fb0a286cefc in start_thread (arg=0x7fb08b44f700) at pthread_create.c:304
#10 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fb0837fe700 (LWP 2610)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fb0a4febafc in QCoreApplication::notifyInternal (this=0x7fffd3eef860, receiver=0x264d210, event=0x7fb0837fdb50) at kernel/qcoreapplication.cpp:787
#8  0x00007fb0a50165b7 in sendEvent (event=0x7fb0837fdb50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x224bfb0) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00007fb0a1d8aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fb0a1d8b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fb0a5016ed6 in QEventDispatcherGlib::processEvents (this=0x229d260, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb0837fdd60, flags=...) at kernel/qeventloop.cpp:201
#16 0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#17 0x00007fb095f300ae in ?? () from /usr/lib/libsopranoserver.so.1
#18 0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x2294790) at thread/qthread_unix.cpp:331
#19 0x00007fb0a286cefc in start_thread (arg=0x7fb0837fe700) at pthread_create.c:304
#20 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fb082ffd700 (LWP 2613)):
#0  0x00007fb0a2b57773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb0a1d8af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb0a5016f3e in QEventDispatcherGlib::processEvents (this=0x2248eb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb082ffcd60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb095f300ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x7fb08c0645b0) at thread/qthread_unix.cpp:331
#9  0x00007fb0a286cefc in start_thread (arg=0x7fb082ffd700) at pthread_create.c:304
#10 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fb0827fc700 (LWP 2614)):
#0  0xffffffffff60014c in ?? ()
#1  0x00007fb0827fba80 in ?? ()
#2  0x00007fffd3f8b7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7fb0817fa700 (LWP 2617)):
#0  0x00007fb0a2b71ad4 in pthread_mutex_unlock (mutex=0x2298258) at forward.c:184
#1  0x00007fb0a1d89f3f in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb0a1d8adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb0a5016f3e in QEventDispatcherGlib::processEvents (this=0x22c80b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb0817f9d60, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fb095f300ae in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x25ea290) at thread/qthread_unix.cpp:331
#10 0x00007fb0a286cefc in start_thread (arg=0x7fb0817fa700) at pthread_create.c:304
#11 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fb080ff9700 (LWP 2619)):
#0  0x00007fb0a1d8a08d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb0a1d8adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb0a5016f3e in QEventDispatcherGlib::processEvents (this=0x225d340, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb080ff8d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb095f300ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x7fb08400bc10) at thread/qthread_unix.cpp:331
#9  0x00007fb0a286cefc in start_thread (arg=0x7fb080ff9700) at pthread_create.c:304
#10 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fb0807f8700 (LWP 2797)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb0a4f051ab in wait (time=18446744073709551615, this=0x7fb08c052df0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb08c052d20, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fb0a4ef981f in QThreadPoolThread::run (this=0x263afc0) at concurrent/qthreadpool.cpp:140
#4  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x263afc0) at thread/qthread_unix.cpp:331
#5  0x00007fb0a286cefc in start_thread (arg=0x7fb0807f8700) at pthread_create.c:304
#6  0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb08ac4e700 (LWP 4698)):
#0  0x00007fb0a2b57773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb0a1d8af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb0a1d8b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb0a5016f3e in QEventDispatcherGlib::processEvents (this=0x2267040, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb0a4feacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb0a4feaef7 in QEventLoop::exec (this=0x7fb08ac4dd60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb0a4f0227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb095f300ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x7fb08c07fff0) at thread/qthread_unix.cpp:331
#9  0x00007fb0a286cefc in start_thread (arg=0x7fb08ac4e700) at pthread_create.c:304
#10 0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb08bc50700 (LWP 5792)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb0a4f051ab in wait (time=18446744073709551615, this=0x7fb08c052df0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb08c052d20, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fb0a4ef981f in QThreadPoolThread::run (this=0x22dbbc0) at concurrent/qthreadpool.cpp:140
#4  0x00007fb0a4f04d05 in QThreadPrivate::start (arg=0x22dbbc0) at thread/qthread_unix.cpp:331
#5  0x00007fb0a286cefc in start_thread (arg=0x7fb08bc50700) at pthread_create.c:304
#6  0x00007fb0a2b6389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb0a5513780 (LWP 2309)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb0a4f051ab in wait (time=18446744073709551615, this=0x2678d90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22d4730, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fb0a4f04a4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007fb095f2f628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007fb095f35c43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007fb095f2be7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007fb096163c8c in Nepomuk::Core::~Core (this=0x21c4b50, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:46
#8  0x00007fb096163d39 in Nepomuk::Core::~Core (this=0x21c4b50, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:49
#9  0x00007fb0a4ffdd75 in QObjectPrivate::deleteChildren (this=0x21c4f90) at kernel/qobject.cpp:1955
#10 0x00007fb0a5003349 in QObject::~QObject (this=0x218acb0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007fb096162ef3 in ~Storage (this=0x218acb0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x218acb0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007fb0a4ffdd75 in QObjectPrivate::deleteChildren (this=0x21c00e0) at kernel/qobject.cpp:1955
#14 0x00007fb0a5003349 in QObject::~QObject (this=0x21be680, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404439 in Nepomuk::ServiceControl::~ServiceControl (this=0x21be680, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007fb0a4ffdd75 in QObjectPrivate::deleteChildren (this=0x1ff6830) at kernel/qobject.cpp:1955
#17 0x00007fb0a5003349 in QObject::~QObject (this=0x7fffd3eef860, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007fb0a332dfd7 in QApplication::~QApplication (this=0x7fffd3eef860, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a54 in main (argc=2, argv=0x7fffd3eefd08) at ../../../nepomuk/servicestub/main.cpp:105

Possible duplicates by query: bug 295021, bug 294822, bug 294701, bug 294449, bug 294374.

Reported using DrKonqi
Comment 1 Rudolf Leitgeb 2012-03-23 17:32:56 UTC
Created attachment 69836 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
shut down the computer, when KDE shuts down I infrequently get a nepomuk crash

-- Backtrace (Reduced):
#7  0x00007f235094cafc in QCoreApplication::notifyInternal (this=0x7fff1e96a230, receiver=0x25c03c0, event=0x7f2333ffeb50) at kernel/qcoreapplication.cpp:787
#8  0x00007f23509775b7 in sendEvent (event=0x7f2333ffeb50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x24d08e0) at kernel/qeventdispatcher_glib.cpp:110
[...]
#13 0x00007f2350977ed6 in QEventDispatcherGlib::processEvents (this=0x251d2d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007f235094bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
Comment 2 Jekyll Wu 2012-03-29 18:51:11 UTC
*** Bug 297065 has been marked as a duplicate of this bug. ***
Comment 3 Vishesh Handa 2012-05-26 02:08:37 UTC

*** This bug has been marked as a duplicate of bug 292950 ***