Bug 298070 - Unplugging Bluetooth adapter
Summary: Unplugging Bluetooth adapter
Status: RESOLVED DUPLICATE of bug 284052
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-13 18:30 UTC by Gordon
Modified: 2012-04-13 20:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon 2012-04-13 18:30:44 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.3.1-5.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Unplugged my Bluetooth Adapter for Microsoft Wireless Lasermouse 8000.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-demon (kded4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb93e352880 (LWP 1020))]

Thread 3 (Thread 0x7fb929ec1700 (LWP 1029)):
#0  g_main_context_prepare (context=context@entry=0x7fb9240009a0, priority=priority@entry=0x7fb929ec0b98) at gmain.c:2810
#1  0x000000301e04789b in g_main_context_iterate (context=context@entry=0x7fb9240009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3103
#2  0x000000301e047a94 in g_main_context_iteration (context=0x7fb9240009a0, may_block=1) at gmain.c:3184
#3  0x00007fb93b574a06 in QEventDispatcherGlib::processEvents (this=0x7fb9240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb93b54595f in QEventLoop::processEvents (this=this@entry=0x7fb929ec0cf0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb93b545be8 in QEventLoop::exec (this=0x7fb929ec0cf0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb93b4495a0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb93b5263df in QInotifyFileSystemWatcherEngine::run (this=0x21b1370) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb93b44c53b in QThreadPrivate::start (arg=0x21b1370) at thread/qthread_unix.cpp:298
#9  0x00007fb93b1bcd14 in start_thread (arg=0x7fb929ec1700) at pthread_create.c:309
#10 0x00007fb93abf494d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb9235b0700 (LWP 1090)):
#0  0x00007fb93abebe9f in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x000000301e047974 in g_main_context_poll (n_fds=3, fds=0x7fb9180010c0, timeout=-1, context=0x225cb80, priority=<optimized out>) at gmain.c:3417
#2  g_main_context_iterate (context=0x225cb80, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3118
#3  0x000000301e047dd2 in g_main_loop_run (loop=0x21588d0) at gmain.c:3317
#4  0x00000030220c9136 in gdbus_shared_thread_func (user_data=0x225cb50) at gdbusprivate.c:277
#5  0x000000301e06a315 in g_thread_proxy (data=0x225a720) at gthread.c:801
#6  0x00007fb93b1bcd14 in start_thread (arg=0x7fb9235b0700) at pthread_create.c:309
#7  0x00007fb93abf494d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb93e352880 (LWP 1020)):
[KCrash Handler]
#6  0x00007fb93b558db0 in QObject::property (this=0x21950c0, name=0x7fb93b8fe2f0 "_qdbus_slotCache") at kernel/qobject.cpp:3741
#7  0x00007fb93b8c0c2c in QDBusConnectionPrivate::activateCall (this=this@entry=0x21942f0, object=0x21950c0, flags=flags@entry=273, msg=...) at qdbusintegrator.cpp:807
#8  0x00007fb93b8c1906 in QDBusConnectionPrivate::activateObject (this=0x21942f0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x00007fb93b8c19fb in QDBusActivateObjectEvent::placeMetaCall (this=0x23b7e50) at qdbusintegrator.cpp:1537
#10 0x00007fb93b55b1ee in QObject::event (this=0x21974f0, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007fb93c40147c in QApplicationPrivate::notify_helper (this=this@entry=0x1fc9200, receiver=receiver@entry=0x21974f0, e=e@entry=0x23b7e50) at kernel/qapplication.cpp:4554
#12 0x00007fb93c4059aa in QApplication::notify (this=0x7fff8b30e700, receiver=0x21974f0, e=0x23b7e50) at kernel/qapplication.cpp:4415
#13 0x00007fb93d11d9f6 in KApplication::notify (this=0x7fff8b30e700, receiver=0x21974f0, event=0x23b7e50) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#14 0x00007fb93b54695e in QCoreApplication::notifyInternal (this=0x7fff8b30e700, receiver=receiver@entry=0x21974f0, event=event@entry=0x23b7e50) at kernel/qcoreapplication.cpp:876
#15 0x00007fb93b54a401 in sendEvent (event=0x23b7e50, receiver=0x21974f0) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1f964b0) at kernel/qcoreapplication.cpp:1500
#17 0x00007fb93b574853 in sendPostedEvents () at kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=s@entry=0x1fca700) at kernel/qeventdispatcher_glib.cpp:279
#19 0x000000301e0475bc in g_main_dispatch (context=0x1fca520) at gmain.c:2515
#20 g_main_context_dispatch (context=context@entry=0x1fca520) at gmain.c:3052
#21 0x000000301e0479d8 in g_main_context_iterate (context=context@entry=0x1fca520, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3123
#22 0x000000301e047a94 in g_main_context_iteration (context=0x1fca520, may_block=1) at gmain.c:3184
#23 0x00007fb93b5749e6 in QEventDispatcherGlib::processEvents (this=0x1f97970, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007fb93c4a141e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#25 0x00007fb93b54595f in QEventLoop::processEvents (this=this@entry=0x7fff8b30e480, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fb93b545be8 in QEventLoop::exec (this=0x7fff8b30e480, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007fb93b54a718 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x00007fb93df694e0 in kdemain (argc=1, argv=0x7fff8b30e848) at /usr/src/debug/kdelibs-4.8.2/kded/kded.cpp:924
#29 0x00007fb93ab24735 in __libc_start_main (main=0x400770 <main(int, char**)>, argc=1, ubp_av=0x7fff8b30e848, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8b30e838) at libc-start.c:226
#30 0x00000000004007a1 in _start ()

Possible duplicates by query: bug 296575, bug 293507, bug 291344, bug 284052.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-04-13 20:50:13 UTC

*** This bug has been marked as a duplicate of bug 284052 ***