Bug 293507 - KDED4 Daemon crash after resume from sleep
Summary: KDED4 Daemon crash after resume from sleep
Status: RESOLVED DUPLICATE of bug 284052
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 05:17 UTC by Raymond Wooninck
Modified: 2012-02-07 09:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Wooninck 2012-02-07 05:17:29 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.00 (4.8.0) "release 48"
Qt Version: 4.8.0
Operating System: Linux 3.2.0-2-desktop x86_64
Distribution: "openSUSE 12.2 Milestone 0 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
When having BlueDevil running, the KDED4 daemon crashes everytime when resuming from a sleep.  When I remove the BlueDevil daemon through systemsettings, then the system is resuming normally without a crash. 

I compared the backtrace of bug #284052 and they seem similar, but I do not have any issue when the system is idle. However I also have the Network Management Plasmoid active, so it could be related.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4c7c53d780 (LWP 2266))]

Thread 2 (Thread 0x7f4c5ad86700 (LWP 2278)):
#0  0x00007f4c79b3b763 in poll () from /lib64/libc.so.6
#1  0x00007f4c76a4e906 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4c76a4ea34 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f4c7b1aa8e6 in QEventDispatcherGlib::processEvents (this=0x9dd9d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4c7b17a682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4c7b17a8d7 in QEventLoop::exec (this=0x7f4c5ad85dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4c7b07b4e7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4c7b15a48f in QInotifyFileSystemWatcherEngine::run (this=0xa632d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4c7b07e50b in QThreadPrivate::start (arg=0xa632d0) at thread/qthread_unix.cpp:298
#9  0x00007f4c7ade7daa in start_thread () from /lib64/libpthread.so.0
#10 0x00007f4c79b4367d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4c7c53d780 (LWP 2266)):
[KCrash Handler]
#6  0x00007f4c7b18dc90 in QObject::property (this=0x9ebc90, name=0x7f4c77ed1510 "_qdbus_slotCache") at kernel/qobject.cpp:3750
#7  0x00007f4c77e91d19 in QDBusConnectionPrivate::activateCall (this=0x742460, object=0x9ebc90, flags=273, msg=...) at qdbusintegrator.cpp:807
#8  0x00007f4c77e92a9b in QDBusConnectionPrivate::activateObject (this=0x742460, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x00007f4c77e92b8b in QDBusActivateObjectEvent::placeMetaCall (this=0xda3050) at qdbusintegrator.cpp:1537
#10 0x00007f4c7b194926 in QObject::event (this=0x9ed480, e=<optimized out>) at kernel/qobject.cpp:1204
#11 0x00007f4c7a2e4ee4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007f4c7a2e9d63 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#13 0x00007f4c7bf3a816 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#14 0x00007f4c7b17b89c in QCoreApplication::notifyInternal (this=0x7fff1c151920, receiver=0x9ed480, event=0xda3050) at kernel/qcoreapplication.cpp:876
#15 0x00007f4c7b17f13a in sendEvent (event=0xda3050, receiver=0x9ed480) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x611360) at kernel/qcoreapplication.cpp:1500
#17 0x00007f4c7b1aa453 in sendPostedEvents () at kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007f4c76a4e5aa in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f4c76a4e970 in ?? () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f4c76a4ea34 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f4c7b1aa87f in QEventDispatcherGlib::processEvents (this=0x617eb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f4c7a38833e in ?? () from /usr/lib64/libQtGui.so.4
#24 0x00007f4c7b17a682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f4c7b17a8d7 in QEventLoop::exec (this=0x7fff1c1518b0, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f4c7b17f435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00007f4c69568495 in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#28 0x00000000004089e4 in _start ()

Possible duplicates by query: bug 291344, bug 284052.

Reported using DrKonqi
Comment 1 Raymond Wooninck 2012-02-07 09:44:42 UTC

*** This bug has been marked as a duplicate of bug 284052 ***