Bug 296575 - kded4 crashes when wifi adapter is turned off
Summary: kded4 crashes when wifi adapter is turned off
Status: RESOLVED DUPLICATE of bug 284052
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 20:05 UTC by Leonid Zhaldybin
Modified: 2012-03-23 10:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Zhaldybin 2012-03-22 20:05:58 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-1.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
On my Fedora 17 installation, kded4 process crashes every time I turn off the wifi adapter by hardware switch. The active wifi connection is not necessary, turning the adapter on and then off again is enough to reproduce the problem.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kded4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f83b9ea1880 (LWP 947))]

Thread 2 (Thread 0x7f83a9ade700 (LWP 995)):
#0  0x0000003ac2e0e0ad in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000003ac2682d4f in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003ac26474fa in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x0000003ac2647a02 in ?? () from /lib64/libglib-2.0.so.0
#4  0x0000003ac2647b84 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x0000003acbfa2976 in QEventDispatcherGlib::processEvents (this=0x7f839c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0000003acbf7382f in QEventLoop::processEvents (this=this@entry=0x7f83a9addcf0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0000003acbf73ab8 in QEventLoop::exec (this=0x7f83a9addcf0, flags=...) at kernel/qeventloop.cpp:204
#8  0x0000003acbe78588 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x0000003acbf5467f in QInotifyFileSystemWatcherEngine::run (this=0x16d1ca0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0000003acbe7b4cb in QThreadPrivate::start (arg=0x16d1ca0) at thread/qthread_unix.cpp:298
#11 0x0000003ac2e07d14 in start_thread (arg=0x7f83a9ade700) at pthread_create.c:309
#12 0x0000003ac2af18fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f83b9ea1880 (LWP 947)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x0000003acbf86cc2 in QObject::property (this=0x1899bb0, name=0x3acd0613d0 "_qdbus_slotCache") at kernel/qobject.cpp:3741
#8  0x0000003acd023c8c in QDBusConnectionPrivate::activateCall (this=this@entry=0x16ffda0, object=0x1899bb0, flags=flags@entry=273, msg=...) at qdbusintegrator.cpp:807
#9  0x0000003acd024966 in QDBusConnectionPrivate::activateObject (this=0x16ffda0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#10 0x0000003acd024a5b in QDBusActivateObjectEvent::placeMetaCall (this=0x1834720) at qdbusintegrator.cpp:1537
#11 0x0000003acbf890ee in QObject::event (this=0x1705c80, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x0000003acffca2dc in QApplicationPrivate::notify_helper (this=this@entry=0x15337d0, receiver=receiver@entry=0x1705c80, e=e@entry=0x1834720) at kernel/qapplication.cpp:4550
#13 0x0000003acffce85a in QApplication::notify (this=0x7ffffb5b0310, receiver=0x1705c80, e=0x1834720) at kernel/qapplication.cpp:4411
#14 0x0000003ad0e45806 in KApplication::notify (this=0x7ffffb5b0310, receiver=0x1705c80, event=0x1834720) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#15 0x0000003acbf7482e in QCoreApplication::notifyInternal (this=0x7ffffb5b0310, receiver=receiver@entry=0x1705c80, event=event@entry=0x1834720) at kernel/qcoreapplication.cpp:876
#16 0x0000003acbf77fb1 in sendEvent (event=0x1834720, receiver=0x1705c80) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x15024d0) at kernel/qcoreapplication.cpp:1500
#18 0x0000003acbfa27c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=0x1535e00) at kernel/qeventdispatcher_glib.cpp:279
#20 0x0000003ac26476ac in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x0000003ac2647ac8 in ?? () from /lib64/libglib-2.0.so.0
#22 0x0000003ac2647b84 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x0000003acbfa2956 in QEventDispatcherGlib::processEvents (this=0x1503990, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x0000003ad0069c0e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#25 0x0000003acbf7382f in QEventLoop::processEvents (this=this@entry=0x7ffffb5b0090, flags=...) at kernel/qeventloop.cpp:149
#26 0x0000003acbf73ab8 in QEventLoop::exec (this=0x7ffffb5b0090, flags=...) at kernel/qeventloop.cpp:204
#27 0x0000003acbf782fc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x0000003ad5a084e0 in kdemain (argc=1, argv=0x7ffffb5b0458) at /usr/src/debug/kdelibs-4.8.1/kded/kded.cpp:924
#29 0x0000003ac2a21735 in __libc_start_main (main=0x400770 <main(int, char**)>, argc=1, ubp_av=0x7ffffb5b0458, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffb5b0448) at libc-start.c:226
#30 0x00000000004007a1 in _start ()

This bug may be a duplicate of or related to bug 284052.

Possible duplicates by query: bug 293507, bug 291344, bug 284052.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-23 10:09:35 UTC

*** This bug has been marked as a duplicate of bug 284052 ***