Bug 293714 - crash from stanby
Summary: crash from stanby
Status: RESOLVED DUPLICATE of bug 268185
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 14:03 UTC by pjbnunes
Modified: 2012-02-10 17:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pjbnunes 2012-02-09 14:03:39 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic-pae i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Nothing, The bug report appear after leaving standby
I usually use Kontact a firefox  when entering standby state.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5a6fb60 (LWP 1272))]

Thread 2 (Thread 0xb0226b70 (LWP 1277)):
#0  0xb5dacd41 in clock_gettime (clock_id=1, tp=0xb0226000) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb6f33dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb70004f2 in updateCurrentTime (this=0x88c7ff4, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x88c7ff4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6ffed32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb02260dc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6ffedcd in timerSourcePrepare (source=0x88c7fc0, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5d11fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb5d12e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb5d13524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6fff577 in QEventDispatcherGlib::processEvents (this=0x8907ee0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6fd1289 in QEventLoop::processEvents (this=0xb0226290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6fd1522 in QEventLoop::exec (this=0xb0226290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6edb2a0 in QThread::exec (this=0x8908d78) at thread/qthread.cpp:492
#14 0xb6fb2fdb in QInotifyFileSystemWatcherEngine::run (this=0x8908d78) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6eddda2 in QThreadPrivate::start (arg=0x8908d78) at thread/qthread_unix.cpp:320
#16 0xb5dbce99 in start_thread (arg=0xb0226b70) at pthread_create.c:304
#17 0xb628173e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb5a6fb60 (LWP 1272)):
[KCrash Handler]
#7  __strcpy_chk (dest=0x8993ad8 "pcm.(null)", src=0x0, destlen=128) at strcpy_chk.c:38
#8  0xaf779a4f in ?? () from /usr/lib/libasound.so.2
#9  0xaf77ab02 in snd_device_name_hint () from /usr/lib/libasound.so.2
#10 0xaa67561d in PhononServer::findVirtualDevices (this=0x890f040) at ../../../phonon/kded-module/phononserver.cpp:164
#11 0xaa6797ef in PhononServer::findDevices (this=0x890f040) at ../../../phonon/kded-module/phononserver.cpp:518
#12 0xaa67ca36 in PhononServer::PhononServer (this=0x890f040, parent=0x8839030) at ../../../phonon/kded-module/phononserver.cpp:62
#13 0xaa682c58 in KPluginFactory::createInstance<PhononServer, QObject> (parentWidget=0x0, parent=0x8839030, args=...) at /usr/include/KDE/../kpluginfactory.h:473
#14 0xb731f0f4 in KPluginFactory::create (this=0x8905ed8, iface=0xb73705a0 "KDEDModule", parentWidget=0x0, parent=0x8839030, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#15 0xb5615455 in create<KDEDModule> (this=0x8839030, s=..., onDemand=true) at ../../kdecore/util/kpluginfactory.h:503
#16 Kded::loadModule (this=0x8839030, s=..., onDemand=true) at ../../kded/kded.cpp:410
#17 0xb5615cac in Kded::loadModule (this=0x8839030, obj=..., onDemand=true) at ../../kded/kded.cpp:362
#18 0xb5615f54 in Kded::messageFilter (message=...) at ../../kded/kded.cpp:205
#19 0xb5e97f47 in QDBusConnectionPrivate::handleMessage (this=0x8839670, amsg=...) at qdbusintegrator.cpp:552
#20 0xb5e9c33e in qDBusSignalFilter (connection=0x883c3d0, message=0x8929b58, data=0x8839670) at qdbusintegrator.cpp:541
#21 0xb5b463ab in dbus_connection_dispatch () from /lib/i386-linux-gnu/libdbus-1.so.3
#22 0xb5e8e92b in q_dbus_connection_dispatch (this=0x8839670) at qdbus_symbols_p.h:115
#23 QDBusConnectionPrivate::doDispatch (this=0x8839670) at qdbusintegrator.cpp:1125
#24 0xb5e90f25 in QDBusConnectionPrivate::socketRead (this=0x8839670, fd=5) at qdbusintegrator.cpp:1145
#25 0xb5ed40bf in QDBusConnectionPrivate::qt_metacall (this=0x8839670, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe935d8) at .moc/release-shared/moc_qdbusconnection_p.cpp:99
#26 0xb6fd86ba in QMetaObject::metacall (object=0x8839670, cl=QMetaObject::InvokeMetaMethod, idx=8, argv=0xbfe935d8) at kernel/qmetaobject.cpp:237
#27 0xb6fe84ff in QMetaObject::activate (sender=0x887b388, m=0xb710d550, local_signal_index=0, argv=0xbfe935d8) at kernel/qobject.cpp:3287
#28 0xb7035183 in QSocketNotifier::activated (this=0x887b388, _t1=5) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#29 0xb6fedfb7 in QSocketNotifier::event (this=0x887b388, e=0xbfe93a54) at kernel/qsocketnotifier.cpp:317
#30 0xb652ad24 in QApplicationPrivate::notify_helper (this=0x8841580, receiver=0x887b388, e=0xbfe93a54) at kernel/qapplication.cpp:4462
#31 0xb652f8ce in QApplication::notify (this=0xbfe93d60, receiver=0x887b388, e=0xbfe93a54) at kernel/qapplication.cpp:3862
#32 0xb767f32a in KApplication::notify (this=0xbfe93d60, receiver=0x887b388, event=0xbfe93a54) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb6fd20bb in QCoreApplication::notifyInternal (this=0xbfe93d60, receiver=0x887b388, event=0xbfe93a54) at kernel/qcoreapplication.cpp:731
#34 0xb6ffeec7 in sendEvent (source=0x8844800) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 socketNotifierSourceDispatch (source=0x8844800) at kernel/qeventdispatcher_glib.cpp:110
#36 0xb5d12aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb5d13270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb5d13524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb6fff53c in QEventDispatcherGlib::processEvents (this=0x87a81a0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#40 0xb65e11e5 in QGuiEventDispatcherGlib::processEvents (this=0x87a81a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0xb6fd1289 in QEventLoop::processEvents (this=0xbfe93cc4, flags=...) at kernel/qeventloop.cpp:149
#42 0xb6fd1522 in QEventLoop::exec (this=0xbfe93cc4, flags=...) at kernel/qeventloop.cpp:201
#43 0xb6fd5ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#44 0xb65288e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#45 0xb5614b50 in kdemain (argc=1, argv=0x8800d50) at ../../kded/kded.cpp:925
#46 0x0804dc5f in launch (argc=1, _name=0x8052207 "kded4", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x805208e "0") at ../../kinit/kinit.cpp:746
#47 0x0805085c in main (argc=) at ../../kinit/kinit.cpp:1861

Possible duplicates by query: bug 292817, bug 292294, bug 284836, bug 279989, bug 275797.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-02-10 17:09:42 UTC

*** This bug has been marked as a duplicate of bug 268185 ***