Bug 292421 - Nepomuk Crashes with no clear cause
Summary: Nepomuk Crashes with no clear cause
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: fileindexer (show other bugs)
Version: 4.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-25 23:59 UTC by Yasha B.-K.
Modified: 2012-11-02 03:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.83 KB, text/plain)
2012-01-27 15:53 UTC, David Homoney
Details
New crash information added by DrKonqi (7.62 KB, text/plain)
2012-02-21 17:43 UTC, David Homoney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yasha B.-K. 2012-01-25 23:59:09 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.41.9-1.fc15.i686 i686
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
I was away from my computer and the screen was locked. The only evidence of the crash when I returned was two copies of the crash reporting assistant.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted
[Current thread is 1 (Thread 0xb783f780 (LWP 1783))]

Thread 3 (Thread 0xb56b9b70 (LWP 1808)):
[KCrash Handler]
#7  0x0085c416 in __kernel_vsyscall ()
#8  0x4906d0ef in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x4906ea25 in __GI_abort () at abort.c:93
#10 0x490a8c8a in __libc_message (do_abort=2, fmt=0x4918c2b4 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
#11 0x490afb72 in malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x9c77020) at malloc.c:6283
#12 0x490b086a in _int_free (av=0x491c73e0, p=0x9c77020, have_lock=0) at malloc.c:4964
#13 0x49c1808c in qFree (ptr=0x9c77090) at global/qmalloc.cpp:60
#14 0x49c697f3 in QString::free (d=0x9c77090) at tools/qstring.cpp:1186
#15 0x49e667ca in QString::~QString (this=0x9c766b0, __in_chrg=<optimized out>) at ../../src/corelib/tools/qstring.h:883
#16 0x49e70a7d in ~QHashNode (this=0x9c766a8, __in_chrg=<optimized out>) at ../../src/corelib/tools/qhash.h:216
#17 deleteNode2 (node=0x9c766a8) at ../../src/corelib/tools/qhash.h:519
#18 deleteNode (node=0x9c766a8, this=0x9c25a34) at ../../src/corelib/tools/qhash.h:507
#19 erase (it=..., this=0x9c25a34) at ../../src/corelib/tools/qhash.h:838
#20 QDBusConnectionPrivate::disconnectSignal (this=0x9c259e0, it=...) at qdbusintegrator.cpp:2171
#21 0x49e72240 in QDBusConnectionPrivate::objectDestroyed (this=0x9c259e0, obj=0x9c767c8) at qdbusintegrator.cpp:1175
#22 0x49eb3a15 in QDBusConnectionPrivate::qt_metacall (this=0x9c259e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xb56b8e38) at .moc/release-shared/moc_qdbusconnection_p.cpp:101
#23 0x49d2127e in metacall (argv=0xb56b8e38, idx=10, cl=QMetaObject::InvokeMetaMethod, object=0x9c259e0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9c259e0, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xb56b8e38) at kernel/qmetaobject.cpp:232
#25 0x49d2f19a in QMetaObject::activate (sender=0x9c767c8, m=0x804e710, local_signal_index=0, argv=0xb56b8e38) at kernel/qobject.cpp:3278
#26 0x49d2f646 in QObject::destroyed (this=0x9c767c8, _t1=0x9c767c8) at .moc/release-shared/moc_qobject.cpp:149
#27 0x49d3348e in QObject::~QObject (this=0x9c767c8, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#28 0x49e815a7 in ~QDBusAbstractInterfaceBase (this=0x9c767c8, __in_chrg=<optimized out>) at qdbusabstractinterface.h:67
#29 QDBusAbstractInterface::~QDBusAbstractInterface (this=0x9c767c8, __in_chrg=<optimized out>) at qdbusabstractinterface.cpp:327
#30 0x4b57bc44 in Soprano::Client::DBusAbstractInterface::~DBusAbstractInterface (this=0x9c767c8, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/client/dbus/dbusabstractinterface.cpp:33
#31 0x4b57c16b in ~DBusModelInterface (this=0x9c767c8, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/client/dbus/dbusmodelinterface.cpp:29
#32 Soprano::Client::DBusModelInterface::~DBusModelInterface (this=0x9c767c8, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/client/dbus/dbusmodelinterface.cpp:31
#33 0x49d2df82 in QObjectPrivate::deleteChildren (this=0x9c77258) at kernel/qobject.cpp:1955
#34 0x49d33899 in QObject::~QObject (this=0x9c79158, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#35 0x4ba60c9a in Soprano::Model::~Model (this=0x9c79158, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/soprano/model.cpp:44
#36 0x4ba7950f in Soprano::StorageModel::~StorageModel (this=0x9c79158, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/soprano/storagemodel.cpp:46
#37 0x4b586a0f in Soprano::Client::DBusModel::~DBusModel (this=0x9c79158, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/client/dbus/dbusmodel.cpp:61
#38 0x4b586a53 in Soprano::Client::DBusModel::~DBusModel (this=0x9c79158, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.6.0/client/dbus/dbusmodel.cpp:64
#39 0x4bb5c8d2 in init (forced=true, this=0x9c76278) at /usr/src/debug/kdelibs-4.6.5/nepomuk/core/nepomukmainmodel.cpp:86
#40 Nepomuk::MainModel::init (this=0x9c75918) at /usr/src/debug/kdelibs-4.6.5/nepomuk/core/nepomukmainmodel.cpp:176
#41 0x4bb54baf in Nepomuk::ResourceManager::init (this=0x9c72850) at /usr/src/debug/kdelibs-4.6.5/nepomuk/core/resourcemanager.cpp:328
#42 0x4bb5505c in Nepomuk::ResourceManager::mainModel (this=0x9c72850) at /usr/src/debug/kdelibs-4.6.5/nepomuk/core/resourcemanager.cpp:506
#43 0x002db6fb in Nepomuk::IndexFeeder::addToModel (this=0x9cae220, rs=...) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexfeeder.cpp:153
#44 0x002dca1b in Nepomuk::IndexFeeder::handleRequest (this=0x9cae220, request=...) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexfeeder.cpp:248
#45 0x002dd30a in Nepomuk::IndexFeeder::run (this=0x9cae220) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexfeeder.cpp:176
#46 0x49c1eae4 in QThreadPrivate::start (arg=0x9cae220) at thread/qthread_unix.cpp:331
#47 0x49205a2e in start_thread (arg=0xb56b9b70) at pthread_create.c:305
#48 0x4911889e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb4cffb70 (LWP 1819)):
#0  0x0085c416 in __kernel_vsyscall ()
#1  0x4920bd42 in __lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S:145
#2  0x49209225 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:302
#3  0x49c1d8a3 in QMutexPrivate::wait (this=0x9c77028, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x49c199d2 in QMutex::lock (this=0x9c76bcc) at thread/qmutex.cpp:167
#5  0x4ba6a854 in QMutexLocker (m=<optimized out>, this=0xb4cfeca8) at /usr/include/QtCore/qmutex.h:102
#6  Soprano::Error::ErrorCache::lastError (this=0x9c79160) at /usr/src/debug/soprano-2.6.0/soprano/error.cpp:208
#7  0x4bb5d90d in Nepomuk::MainModel::removeAllStatements (this=0x9c75918, statement=...) at /usr/src/debug/kdelibs-4.6.5/nepomuk/core/nepomukmainmodel.cpp:269
#8  0x4ba784ac in Soprano::FilterModel::removeAllStatements (this=0x9c72c80, statement=...) at /usr/src/debug/soprano-2.6.0/soprano/filtermodel.cpp:203
#9  0x4ba612b3 in Soprano::Model::removeContext (this=0x9c72c80, context=...) at /usr/src/debug/soprano-2.6.0/soprano/model.cpp:112
#10 0x002db0ed in Nepomuk::IndexFeeder::clearIndexedDataForResourceUri (res=...) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexfeeder.cpp:327
#11 0x002d9912 in Nepomuk::StrigiIndexWriter::startAnalysis (this=0x9c88430, idx=0xb4cff0bc) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexwriter.cpp:403
#12 0x4b5f2c91 in Strigi::AnalysisResult::AnalysisResult (this=0xb4cff0bc, path="/home/yashabk/Music/Beatles/With the Beatles/04 - Don't Bother Me.flac", mt=1327525706, w=..., indexer=..., parentpath="/home/yashabk/Music/Beatles/With the Beatles") at /usr/src/debug/strigi-0.7.6/libstreamanalyzer/lib/analysisresult.cpp:180
#13 0x002dfc72 in Nepomuk::Indexer::indexFile (this=0x9c76bb8, info=...) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/nepomukindexer.cpp:127
#14 0x002d0e27 in Nepomuk::IndexScheduler::analyzeDir (this=0x9c7c520, dir_=..., flags=...) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/indexscheduler.cpp:450
#15 0x002d2e60 in Nepomuk::IndexScheduler::run (this=0x9c7c520) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/services/strigi/indexscheduler.cpp:338
#16 0x49c1eae4 in QThreadPrivate::start (arg=0x9c7c520) at thread/qthread_unix.cpp:331
#17 0x49205a2e in start_thread (arg=0xb4cffb70) at pthread_create.c:305
#18 0x4911889e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb783f780 (LWP 1783)):
#0  0x0085c416 in __kernel_vsyscall ()
#1  0x49127112 in __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/lowlevellock.S:98
#2  0x490b5182 in _L_lock_10199 () at malloc.c:6486
#3  0x490b34cc in __GI___libc_malloc (bytes=4) at malloc.c:3657
#4  0x49c1805c in qMalloc (size=4) at global/qmalloc.cpp:55
#5  0x49d22be4 in QMetaMethod::invoke (this=0xbfd70208, object=0x9c259e0, connectionType=Qt::QueuedConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1606
#6  0x49e6a5fc in invoke (val9=<optimized out>, val8=<optimized out>, val7=<optimized out>, val6=<optimized out>, val5=<optimized out>, val4=<optimized out>, val3=<optimized out>, val2=<optimized out>, val1=<optimized out>, val0=<optimized out>, connectionType=Qt::QueuedConnection, object=0x9c259e0, this=0xbfd70208) at ../../src/corelib/kernel/qmetaobject.h:120
#7  qDBusUpdateDispatchStatus (data=0x9c259e0, connection=<optimized out>, new_status=<optimized out>) at qdbusintegrator.cpp:375
#8  qDBusUpdateDispatchStatus (connection=0x9c28178, new_status=DBUS_DISPATCH_DATA_REMAINS, data=0x9c259e0) at qdbusintegrator.cpp:359
#9  0x49618f3b in _dbus_connection_update_dispatch_status_and_unlock (connection=0x9c28178, new_status=DBUS_DISPATCH_DATA_REMAINS) at dbus-connection.c:4313
#10 0x49619f49 in _dbus_connection_handle_watch (watch=0x9c27df8, condition=1, data=0x9c28178) at dbus-connection.c:1509
#11 0x49634a49 in dbus_watch_handle (watch=0x9c27df8, flags=1) at dbus-watch.c:683
#12 0x49e6f3e8 in q_dbus_watch_handle (flags=1, watch=<optimized out>) at qdbus_symbols_p.h:183
#13 QDBusConnectionPrivate::socketRead (this=0x9c259e0, fd=8) at qdbusintegrator.cpp:1143
#14 0x49eb39d5 in QDBusConnectionPrivate::qt_metacall (this=0x9c259e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd70428) at .moc/release-shared/moc_qdbusconnection_p.cpp:99
#15 0x49d2127e in metacall (argv=0xbfd70428, idx=8, cl=QMetaObject::InvokeMetaMethod, object=0x9c259e0) at kernel/qmetaobject.cpp:237
#16 QMetaObject::metacall (object=0x9c259e0, cl=QMetaObject::InvokeMetaMethod, idx=8, argv=0xbfd70428) at kernel/qmetaobject.cpp:232
#17 0x49d2f19a in QMetaObject::activate (sender=0x9c27c20, m=0x49e4f9f8, local_signal_index=0, argv=0xbfd70428) at kernel/qobject.cpp:3278
#18 0x49d7f276 in QSocketNotifier::activated (this=0x9c27c20, _t1=8) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#19 0x49d37527 in QSocketNotifier::event (this=0x9c27c20, e=0xbfd70874) at kernel/qsocketnotifier.cpp:317
#20 0x4a60b144 in notify_helper (e=0xbfd70874, receiver=0x9c27c20, this=0x9bab220) at kernel/qapplication.cpp:4481
#21 QApplicationPrivate::notify_helper (this=0x9bab220, receiver=0x9c27c20, e=0xbfd70874) at kernel/qapplication.cpp:4453
#22 0x4a610583 in QApplication::notify (this=0xbfd70874, receiver=0x9c27c20, e=0xbfd70874) at kernel/qapplication.cpp:4228
#23 0x4b2b9a32 in KApplication::notify (this=0xbfd70c54, receiver=0x9c27c20, event=0xbfd70874) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#24 0x49d1aace in QCoreApplication::notifyInternal (this=0xbfd70c54, receiver=0x9c27c20, event=0xbfd70874) at kernel/qcoreapplication.cpp:787
#25 0x49d487f8 in sendEvent (event=0xbfd70874, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#26 socketNotifierSourceDispatch (source=0x9bad698) at kernel/qeventdispatcher_glib.cpp:110
#27 0x492bf5bf in g_main_dispatch (context=0x9bace70) at gmain.c:2441
#28 g_main_context_dispatch (context=0x9bace70) at gmain.c:3014
#29 0x492bfd30 in g_main_context_iterate (context=0x9bace70, block=1227680384, dispatch=1, self=0x9baa540) at gmain.c:3092
#30 0x492c006f in g_main_context_iteration (context=0x9bace70, may_block=1) at gmain.c:3155
#31 0x49d49108 in QEventDispatcherGlib::processEvents (this=0x9b91990, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#32 0x4a6bfc1b in QGuiEventDispatcherGlib::processEvents (this=0x9b91990, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#33 0x49d19e0e in QEventLoop::processEvents (this=0xbfd70ac4, flags=...) at kernel/qeventloop.cpp:149
#34 0x49d1a061 in QEventLoop::exec (this=0xbfd70ac4, flags=...) at kernel/qeventloop.cpp:201
#35 0x49d1e7bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x4a608f45 in QApplication::exec () at kernel/qapplication.cpp:3755
#37 0x0804ae01 in main (argc=2, argv=0xbfd70df4) at /usr/src/debug/kdebase-runtime-4.6.5/nepomuk/servicestub/main.cpp:167

This bug may be a duplicate of or related to bug 291396.

Possible duplicates by query: bug 292022, bug 291567, bug 291451, bug 291396, bug 290847.

Reported using DrKonqi
Comment 1 David Homoney 2012-01-27 15:53:16 UTC
Created attachment 68239 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed:

I walked away to take a leak after just minutes before submitting a bug and here it crashed again. Otherwise system seems fine.

-- Backtrace (Reduced):
#8  0x00007f9410d77d7b in __libc_message (do_abort=2, fmt=0x7f9410e60400 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#9  0x00007f9410d83a8f in malloc_printerr (av=<value optimized out>, p=0x27e8f40) at malloc.c:6283
#10 _int_free (av=<value optimized out>, p=0x27e8f40) at malloc.c:4795
#11 0x00007f9410d878e3 in __libc_free (mem=<value optimized out>) at malloc.c:3738
#12 0x00007f9413216c2e in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x24b08a0) at kernel/qcoreapplication.cpp:1388
Comment 2 David Homoney 2012-02-21 17:43:44 UTC
Created attachment 68984 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed: I had locked my screen and walked away to pee and came back to this crash report. This crashes more than the stock market.

-- Backtrace (Reduced):
#8  0x00007feb20a49d7b in __libc_message (do_abort=2, fmt=0x7feb20b32400 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#9  0x00007feb20a55a8f in malloc_printerr (av=<value optimized out>, p=0x7feb00003300) at malloc.c:6283
#10 _int_free (av=<value optimized out>, p=0x7feb00003300) at malloc.c:4795
#11 0x00007feb20a598e3 in __libc_free (mem=<value optimized out>) at malloc.c:3738
#12 0x00007feb22b3e84c in ~QByteArray (message=<value optimized out>, error=0x7fffea5e3f20) at ../../include/QtCore/../../src/corelib/tools/qbytearray.h:383
Comment 3 Vishesh Handa 2012-11-02 03:44:54 UTC
Fixed in KDE 4.9

We no longer use the Dbus model for communication.