Bug 293674 - Muon software centre failed to start
Summary: Muon software centre failed to start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 293675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-08 19:55 UTC by brian.blackhurst
Modified: 2012-02-08 21:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brian.blackhurst 2012-02-08 19:55:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I have recently installed Kubuntu from a Live CD. I was about to have a look at some mw software I might wish to install, I clicked on the button Muon Software Centre the initial page started up remained for about 5secs and disappeared, to be replaced by the Bug Report.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76e4930 (LWP 2444))]

Thread 2 (Thread 0xb444eb70 (LWP 2450)):
#0  0x0085cd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00d207d5 in do_gettime (frac=0xb444e020, sec=0xb444e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00df34b6 in QTimerInfoList::updateCurrentTime (this=0x9311db4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00df380a in QTimerInfoList::timerWait (this=0x9311db4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00df2053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb444e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00df20ed in timerSourcePrepare (source=0x9311d80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x014c088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x014c1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x014c1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00df2b37 in QEventDispatcherGlib::processEvents (this=0x911fe38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00dc31dd in QEventLoop::processEvents (this=0xb444e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00dc3421 in QEventLoop::exec (this=0xb444e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00cc690b in QThread::exec (this=0x91f4ea8) at thread/qthread.cpp:498
#14 0x00da3e2d in QInotifyFileSystemWatcherEngine::run (this=0x91f4ea8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00cc97b3 in QThreadPrivate::start (arg=0x91f4ea8) at thread/qthread_unix.cpp:331
#16 0x00c30d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x007a90ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76e4930 (LWP 2444)):
[KCrash Handler]
#7  0x00d1de11 in QtPrivate::QStringList_contains (that=0xbfc51404, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc51404) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x91b7da0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x91b7da0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc51624) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00dcab7d in metacall (argv=0xbfc51624, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x91b7da0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x91b7da0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc51624) at kernel/qmetaobject.cpp:232
#13 0x00dd9a6a in QMetaObject::activate (sender=0x908dfb0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x908dfb0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x908dfb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc51768) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00dcab7d in metacall (argv=0xbfc51768, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x908dfb0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x908dfb0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc51768) at kernel/qmetaobject.cpp:232
#18 0x00dd9a6a in QMetaObject::activate (sender=0x91b7da0, m=0x80950c0, local_signal_index=0, argv=0xbfc51768) at kernel/qobject.cpp:3278
#19 0x001287c5 in MuonMainWindow::backendReady (this=0x91b7da0, _t1=0x91b6568) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00128933 in MuonMainWindow::initObject (this=0x91b7da0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x91b7da0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x91b7da0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc51894) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00dcab7d in metacall (argv=0xbfc51894, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x91b7da0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x91b7da0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc51894) at kernel/qmetaobject.cpp:232
#25 0x00dd9a6a in QMetaObject::activate (sender=0x9222840, m=0xefa238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00de1375 in QSingleShotTimer::timeout (this=0x9222840) at .moc/release-shared/qtimer.moc:82
#27 0x00de142c in QSingleShotTimer::timerEvent (this=0x9222840) at kernel/qtimer.cpp:308
#28 0x00ddc994 in QObject::event (this=0x9222840, e=0xbfc51c8c) at kernel/qobject.cpp:1181
#29 0x03620d84 in notify_helper (e=0xbfc51c8c, receiver=0x9222840, this=0x909c218) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x909c218, receiver=0x9222840, e=0xbfc51c8c) at kernel/qapplication.cpp:4458
#31 0x03626133 in QApplication::notify (this=0xbfc51c8c, receiver=0x9222840, e=0xbfc51c8c) at kernel/qapplication.cpp:3886
#32 0x01150971 in KApplication::notify (this=0xbfc51fa0, receiver=0x9222840, event=0xbfc51c8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00dc419e in QCoreApplication::notifyInternal (this=0xbfc51fa0, receiver=0x9222840, event=0xbfc51c8c) at kernel/qcoreapplication.cpp:787
#34 0x00df4c10 in sendEvent (event=0xbfc51c8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x909990c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00df2122 in timerSourceDispatch (source=0x90998d8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x014c125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x014c1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x014c1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00df2ada in QEventDispatcherGlib::processEvents (this=0x907a238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x036d8e7a in QGuiEventDispatcherGlib::processEvents (this=0x907a238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00dc31dd in QEventLoop::processEvents (this=0xbfc51f04, flags=...) at kernel/qeventloop.cpp:149
#43 0x00dc3421 in QEventLoop::exec (this=0xbfc51f04, flags=...) at kernel/qeventloop.cpp:201
#44 0x00dc819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0361e924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293642, bug 293629, bug 293597, bug 293593, bug 293554.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-02-08 21:09:52 UTC
*** Bug 293675 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2012-02-08 21:39:24 UTC

*** This bug has been marked as a duplicate of bug 291262 ***