Bug 293629 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 12:34 UTC by jonny amrques
Modified: 2012-02-08 14:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-02-08 12:34:08 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
every time  appcenter (muon) crash when I try open.
I'm sing pack admin

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8217f86780 (LWP 4774))]

Thread 2 (Thread 0x7f8203a65700 (LWP 4775)):
#0  0x00007f8214b50773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f82113c5f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f82113c6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8216d0ef3e in QEventDispatcherGlib::processEvents (this=0xb75410, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8216ce2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8216ce2ef7 in QEventLoop::exec (this=0x7f8203a64dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8216bfa27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f8216cc5cbf in QInotifyFileSystemWatcherEngine::run (this=0xca79c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8216bfcd05 in QThreadPrivate::start (arg=0xca79c0) at thread/qthread_unix.cpp:331
#9  0x00007f8211ea7efc in start_thread (arg=0x7f8203a65700) at pthread_create.c:304
#10 0x00007f8214b5c89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8217f86780 (LWP 4774)):
[KCrash Handler]
#6  0x00007f8216c4aa5e in QtPrivate::QStringList_contains (that=0x7fffe866db00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe866db00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xc36f60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xc36f60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe866e0d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f8216cf6eba in QMetaObject::activate (sender=0xc8fb70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xc8fb70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe866e230) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f8216cf6eba in QMetaObject::activate (sender=0xc36f60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe866e230) at kernel/qobject.cpp:3278
#13 0x00007f8217b6ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xcc43c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f8217b6cf8e in MuonMainWindow::initObject (this=0xc36f60) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xc36f60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xc36f60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe866e300) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f8216cf6eba in QMetaObject::activate (sender=0xc90ca0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f8216cfef7f in QSingleShotTimer::timerEvent (this=0xc90ca0) at kernel/qtimer.cpp:308
#19 0x00007f8216cfa789 in QObject::event (this=0xc90ca0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f821531d474 in notify_helper (e=0x7fffe866e870, receiver=0xc90ca0, this=0xb168f0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xb168f0, receiver=0xc90ca0, e=0x7fffe866e870) at kernel/qapplication.cpp:4458
#22 0x00007f82153222e1 in QApplication::notify (this=0x7fffe866eb70, receiver=0xc90ca0, e=0x7fffe866e870) at kernel/qapplication.cpp:4365
#23 0x00007f8216502466 in KApplication::notify (this=0x7fffe866eb70, receiver=0xc90ca0, event=0x7fffe866e870) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f8216ce3afc in QCoreApplication::notifyInternal (this=0x7fffe866eb70, receiver=0xc90ca0, event=0x7fffe866e870) at kernel/qcoreapplication.cpp:787
#25 0x00007f8216d10d62 in sendEvent (event=0x7fffe866e870, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xb14bc0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f8216d0e514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f82113c5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f82113c6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f82113c6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f8216d0eed6 in QEventDispatcherGlib::processEvents (this=0xaee6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f82153c510e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f8216ce2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f8216ce2ef7 in QEventLoop::exec (this=0x7fffe866eb00, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f8216ce7789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffe866ede8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293597, bug 293593, bug 293554, bug 293532, bug 293515.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-08 14:46:52 UTC

*** This bug has been marked as a duplicate of bug 291262 ***