Bug 293593 - Logitheque Muon crashed
Summary: Logitheque Muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 02:12 UTC by jonny amrques
Modified: 2012-02-08 05:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-02-08 02:12:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I just tryed open muon and it just don't open. I believe taht if I update the system this problem will be fix

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7f1f359780 (LWP 1742))]

Thread 2 (Thread 0x7f7f0ae34700 (LWP 1743)):
#0  0x00007f7f1bf1f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7f18794f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7f18795429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7f1e0ddf3e in QEventDispatcherGlib::processEvents (this=0x1f05210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7f1e0b1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7f1e0b1ef7 in QEventLoop::exec (this=0x7f7f0ae33dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7f1dfc927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f7f1e094cbf in QInotifyFileSystemWatcherEngine::run (this=0x1efd160) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7f1dfcbd05 in QThreadPrivate::start (arg=0x1efd160) at thread/qthread_unix.cpp:331
#9  0x00007f7f19276efc in start_thread (arg=0x7f7f0ae34700) at pthread_create.c:304
#10 0x00007f7f1bf2b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7f1f359780 (LWP 1742)):
[KCrash Handler]
#6  0x00007f7f1e019a5e in QtPrivate::QStringList_contains (that=0x7fffcf1cdd70, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffcf1cdd70) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2028400) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2028400, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcf1ce340) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f7f1e0c5eba in QMetaObject::activate (sender=0x2095aa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2095aa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcf1ce4a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f7f1e0c5eba in QMetaObject::activate (sender=0x2028400, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffcf1ce4a0) at kernel/qobject.cpp:3278
#13 0x00007f7f1ef3be7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x20280e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f7f1ef3bf8e in MuonMainWindow::initObject (this=0x2028400) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2028400) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2028400, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcf1ce570) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f7f1e0c5eba in QMetaObject::activate (sender=0x20b5030, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f7f1e0cdf7f in QSingleShotTimer::timerEvent (this=0x20b5030) at kernel/qtimer.cpp:308
#19 0x00007f7f1e0c9789 in QObject::event (this=0x20b5030, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f7f1c6ec474 in notify_helper (e=0x7fffcf1ceae0, receiver=0x20b5030, this=0x1f0e810) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1f0e810, receiver=0x20b5030, e=0x7fffcf1ceae0) at kernel/qapplication.cpp:4458
#22 0x00007f7f1c6f12e1 in QApplication::notify (this=0x7fffcf1cede0, receiver=0x20b5030, e=0x7fffcf1ceae0) at kernel/qapplication.cpp:4365
#23 0x00007f7f1d8d1466 in KApplication::notify (this=0x7fffcf1cede0, receiver=0x20b5030, event=0x7fffcf1ceae0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f7f1e0b2afc in QCoreApplication::notifyInternal (this=0x7fffcf1cede0, receiver=0x20b5030, event=0x7fffcf1ceae0) at kernel/qcoreapplication.cpp:787
#25 0x00007f7f1e0dfd62 in sendEvent (event=0x7fffcf1ceae0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1f0b9a0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f7f1e0dd514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f7f18794a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f7f18795258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f7f18795429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f7f1e0dded6 in QEventDispatcherGlib::processEvents (this=0x1ee66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f7f1c79410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f7f1e0b1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f7f1e0b1ef7 in QEventLoop::exec (this=0x7fffcf1ced70, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f7f1e0b6789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffcf1cf058) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293554, bug 293532, bug 293515, bug 293514, bug 293513.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-08 05:38:28 UTC

*** This bug has been marked as a duplicate of bug 291262 ***