Bug 293532 - Muon Software Center crash
Summary: Muon Software Center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 14:49 UTC by csmathematician
Modified: 2012-02-07 14:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description csmathematician 2012-02-07 14:49:00 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
The Muon software crashes everytime I try start it. It craches also on a fresh new Kubuntu 11.10 installation. It crashes also, when I start it from Konsole with no parameters.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon szoftverközpont (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7806930 (LWP 3183))]

Thread 2 (Thread 0xb59bcb70 (LWP 3184)):
#0  0x003f2d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00a197d5 in do_gettime (frac=0xb59bc020, sec=0xb59bc018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00aec4b6 in QTimerInfoList::updateCurrentTime (this=0x89a5fb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00aec80a in QTimerInfoList::timerWait (this=0x89a5fb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00aeb053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb59bc12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00aeb0ed in timerSourcePrepare (source=0x89a5f80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x079ef88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x079f0637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x079f0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00aebb37 in QEventDispatcherGlib::processEvents (this=0x89a7ca0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00abc1dd in QEventLoop::processEvents (this=0xb59bc2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00abc421 in QEventLoop::exec (this=0xb59bc2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x009bf90b in QThread::exec (this=0x8948f30) at thread/qthread.cpp:498
#14 0x00a9ce2d in QInotifyFileSystemWatcherEngine::run (this=0x8948f30) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x009c27b3 in QThreadPrivate::start (arg=0x8948f30) at thread/qthread_unix.cpp:331
#16 0x003c5d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x007e60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7806930 (LWP 3183)):
[KCrash Handler]
#7  0x00a16e11 in QtPrivate::QStringList_contains (that=0xbfbb22d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfbb22d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8943950) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8943950, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb24f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00ac3b7d in metacall (argv=0xbfbb24f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8943950) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8943950, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfbb24f4) at kernel/qmetaobject.cpp:232
#13 0x00ad2a6a in QMetaObject::activate (sender=0x89926d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x89926d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x89926d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb2638) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00ac3b7d in metacall (argv=0xbfbb2638, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x89926d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x89926d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfbb2638) at kernel/qmetaobject.cpp:232
#18 0x00ad2a6a in QMetaObject::activate (sender=0x8943950, m=0x80950c0, local_signal_index=0, argv=0xbfbb2638) at kernel/qobject.cpp:3278
#19 0x0043a7c5 in MuonMainWindow::backendReady (this=0x8943950, _t1=0x89485a0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0043a933 in MuonMainWindow::initObject (this=0x8943950) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8943950) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8943950, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb2764) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00ac3b7d in metacall (argv=0xbfbb2764, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8943950) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8943950, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfbb2764) at kernel/qmetaobject.cpp:232
#25 0x00ad2a6a in QMetaObject::activate (sender=0x89879d8, m=0xbf3238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00ada375 in QSingleShotTimer::timeout (this=0x89879d8) at .moc/release-shared/qtimer.moc:82
#27 0x00ada42c in QSingleShotTimer::timerEvent (this=0x89879d8) at kernel/qtimer.cpp:308
#28 0x00ad5994 in QObject::event (this=0x89879d8, e=0xbfbb2b5c) at kernel/qobject.cpp:1181
#29 0x03384d84 in notify_helper (e=0xbfbb2b5c, receiver=0x89879d8, this=0x88444e8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x88444e8, receiver=0x89879d8, e=0xbfbb2b5c) at kernel/qapplication.cpp:4458
#31 0x0338a133 in QApplication::notify (this=0xbfbb2b5c, receiver=0x89879d8, e=0xbfbb2b5c) at kernel/qapplication.cpp:3886
#32 0x0108c971 in KApplication::notify (this=0xbfbb2e70, receiver=0x89879d8, event=0xbfbb2b5c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00abd19e in QCoreApplication::notifyInternal (this=0xbfbb2e70, receiver=0x89879d8, event=0xbfbb2b5c) at kernel/qcoreapplication.cpp:787
#34 0x00aedc10 in sendEvent (event=0xbfbb2b5c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x884b874) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00aeb122 in timerSourceDispatch (source=0x884b840) at kernel/qeventdispatcher_glib.cpp:184
#37 0x079f025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x079f0990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x079f0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00aebada in QEventDispatcherGlib::processEvents (this=0x8827238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0343ce7a in QGuiEventDispatcherGlib::processEvents (this=0x8827238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00abc1dd in QEventLoop::processEvents (this=0xbfbb2dd4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00abc421 in QEventLoop::exec (this=0xbfbb2dd4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00ac119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03382924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293515, bug 293514, bug 293513, bug 293505, bug 293504.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-07 14:50:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***