Bug 293513 - muon software center doesnt want to run
Summary: muon software center doesnt want to run
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 09:44 UTC by Fabijan
Modified: 2012-02-07 16:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.75 KB, text/plain)
2012-02-07 16:48 UTC, jan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabijan 2012-02-07 09:44:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

After i click on msc app is starting but it crashes at the same moment,it doesnt want to run

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb475e930 (LWP 12080))]

Thread 2 (Thread 0xb22e8b70 (LWP 12081)):
#0  0xb52abd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb71877d5 in do_gettime (frac=0xb22e8020, sec=0xb22e8018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb725a4b6 in QTimerInfoList::updateCurrentTime (this=0x83e429c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb725a80a in QTimerInfoList::timerWait (this=0x83e429c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb7259053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb22e812c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb72590ed in timerSourcePrepare (source=0x83e4268, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb51f188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb51f2637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb51f2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb7259b37 in QEventDispatcherGlib::processEvents (this=0x83e7a58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb722a1dd in QEventLoop::processEvents (this=0xb22e82b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb722a421 in QEventLoop::exec (this=0xb22e82b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb712d90b in QThread::exec (this=0x838db10) at thread/qthread.cpp:498
#14 0xb720ae2d in QInotifyFileSystemWatcherEngine::run (this=0x838db10) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb71307b3 in QThreadPrivate::start (arg=0x838db10) at thread/qthread_unix.cpp:331
#16 0xb52d8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5d250ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb475e930 (LWP 12080)):
[KCrash Handler]
#7  0xb7184e11 in QtPrivate::QStringList_contains (that=0xbffb2514, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffb2514) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8379a70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8379a70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb2734) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7231b7d in metacall (argv=0xbffb2734, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8379a70) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8379a70, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffb2734) at kernel/qmetaobject.cpp:232
#13 0xb7240a6a in QMetaObject::activate (sender=0x83c89d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x83c89d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x83c89d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb2878) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7231b7d in metacall (argv=0xbffb2878, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x83c89d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x83c89d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffb2878) at kernel/qmetaobject.cpp:232
#18 0xb7240a6a in QMetaObject::activate (sender=0x8379a70, m=0x80950c0, local_signal_index=0, argv=0xbffb2878) at kernel/qobject.cpp:3278
#19 0xb76a17c5 in MuonMainWindow::backendReady (this=0x8379a70, _t1=0x83b4e70) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76a1933 in MuonMainWindow::initObject (this=0x8379a70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8379a70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8379a70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb29a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7231b7d in metacall (argv=0xbffb29a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8379a70) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8379a70, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffb29a4) at kernel/qmetaobject.cpp:232
#25 0xb7240a6a in QMetaObject::activate (sender=0x83d3de0, m=0xb7361238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7248375 in QSingleShotTimer::timeout (this=0x83d3de0) at .moc/release-shared/qtimer.moc:82
#27 0xb724842c in QSingleShotTimer::timerEvent (this=0x83d3de0) at kernel/qtimer.cpp:308
#28 0xb7243994 in QObject::event (this=0x83d3de0, e=0xbffb2d9c) at kernel/qobject.cpp:1181
#29 0xb6011d84 in notify_helper (e=0xbffb2d9c, receiver=0x83d3de0, this=0x828b820) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x828b820, receiver=0x83d3de0, e=0xbffb2d9c) at kernel/qapplication.cpp:4458
#31 0xb6017133 in QApplication::notify (this=0xbffb2d9c, receiver=0x83d3de0, e=0xbffb2d9c) at kernel/qapplication.cpp:3886
#32 0xb6e30971 in KApplication::notify (this=0xbffb30b0, receiver=0x83d3de0, event=0xbffb2d9c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb722b19e in QCoreApplication::notifyInternal (this=0xbffb30b0, receiver=0x83d3de0, event=0xbffb2d9c) at kernel/qcoreapplication.cpp:787
#34 0xb725bc10 in sendEvent (event=0xbffb2d9c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x828cfb4) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7259122 in timerSourceDispatch (source=0x828cf80) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb51f225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb51f2990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb51f2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7259ada in QEventDispatcherGlib::processEvents (this=0x826f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb60c9e7a in QGuiEventDispatcherGlib::processEvents (this=0x826f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb722a1dd in QEventLoop::processEvents (this=0xbffb3014, flags=...) at kernel/qeventloop.cpp:149
#43 0xb722a421 in QEventLoop::exec (this=0xbffb3014, flags=...) at kernel/qeventloop.cpp:201
#44 0xb722f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb600f924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293505, bug 293504, bug 293503, bug 293451, bug 293422.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-07 09:46:35 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 jan 2012-02-07 16:48:46 UTC
Created attachment 68596 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: I clicked on the Muon Software Center icon

- Unusual behavior I noticed: The software center loaded but crashed, with an error message.

-- Backtrace (Reduced):
#7  0xb717de11 in QtPrivate::QStringList_contains (that=0xbf8792c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8792c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x974d700) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x974d700, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8794e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb722ab7d in metacall (argv=0xbf8794e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x974d700) at kernel/qmetaobject.cpp:237