Bug 293245 - package manager crashed, now it wont open.
Summary: package manager crashed, now it wont open.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 21:14 UTC by klovell
Modified: 2012-02-04 03:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klovell 2012-02-03 21:14:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was doing an update directly after installation when it crashed.  only made it to 50%.  I believe the kmouse(??) package was being updated at the time.  The computer was completely hung at 50% for 3 hours so I pulled the plug and that started all my troubles.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb48ad930 (LWP 4859))]

Thread 2 (Thread 0xb23ceb70 (LWP 4864)):
#0  0xb533fe8c in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb534156d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb5341c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb73a8b37 in QEventDispatcherGlib::processEvents (this=0xa113950, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0xb73791dd in QEventLoop::processEvents (this=0xb23ce2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0xb7379421 in QEventLoop::exec (this=0xb23ce2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0xb727c90b in QThread::exec (this=0xa053f48) at thread/qthread.cpp:498
#7  0xb7359e2d in QInotifyFileSystemWatcherEngine::run (this=0xa053f48) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb727f7b3 in QThreadPrivate::start (arg=0xa053f48) at thread/qthread_unix.cpp:331
#9  0xb5427d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0xb5e740ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb48ad930 (LWP 4859)):
[KCrash Handler]
#7  0xb72d3e11 in QtPrivate::QStringList_contains (that=0xbfd64534, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd64534) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9fae540) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9fae540, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd64754) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7380b7d in metacall (argv=0xbfd64754, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9fae540) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9fae540, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd64754) at kernel/qmetaobject.cpp:232
#13 0xb738fa6a in QMetaObject::activate (sender=0xa00b940, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa00b940) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa00b940, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd64898) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7380b7d in metacall (argv=0xbfd64898, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa00b940) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa00b940, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd64898) at kernel/qmetaobject.cpp:232
#18 0xb738fa6a in QMetaObject::activate (sender=0x9fae540, m=0x80950c0, local_signal_index=0, argv=0xbfd64898) at kernel/qobject.cpp:3278
#19 0xb77f07c5 in MuonMainWindow::backendReady (this=0x9fae540, _t1=0xa021278) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb77f0933 in MuonMainWindow::initObject (this=0x9fae540) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9fae540) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9fae540, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd649c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7380b7d in metacall (argv=0xbfd649c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9fae540) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9fae540, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd649c4) at kernel/qmetaobject.cpp:232
#25 0xb738fa6a in QMetaObject::activate (sender=0xa0269a8, m=0xb74b0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7397375 in QSingleShotTimer::timeout (this=0xa0269a8) at .moc/release-shared/qtimer.moc:82
#27 0xb739742c in QSingleShotTimer::timerEvent (this=0xa0269a8) at kernel/qtimer.cpp:308
#28 0xb7392994 in QObject::event (this=0xa0269a8, e=0xbfd64dbc) at kernel/qobject.cpp:1181
#29 0xb6160d84 in notify_helper (e=0xbfd64dbc, receiver=0xa0269a8, this=0x9ebf768) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9ebf768, receiver=0xa0269a8, e=0xbfd64dbc) at kernel/qapplication.cpp:4458
#31 0xb6166133 in QApplication::notify (this=0xbfd64dbc, receiver=0xa0269a8, e=0xbfd64dbc) at kernel/qapplication.cpp:3886
#32 0xb6f7f971 in KApplication::notify (this=0xbfd650d0, receiver=0xa0269a8, event=0xbfd64dbc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb737a19e in QCoreApplication::notifyInternal (this=0xbfd650d0, receiver=0xa0269a8, event=0xbfd64dbc) at kernel/qcoreapplication.cpp:787
#34 0xb73aac10 in sendEvent (event=0xbfd64dbc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9eba8ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb73a8122 in timerSourceDispatch (source=0x9eba8b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb534125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb5341990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5341c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb73a8ada in QEventDispatcherGlib::processEvents (this=0x9e9b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb6218e7a in QGuiEventDispatcherGlib::processEvents (this=0x9e9b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb73791dd in QEventLoop::processEvents (this=0xbfd65034, flags=...) at kernel/qeventloop.cpp:149
#43 0xb7379421 in QEventLoop::exec (this=0xbfd65034, flags=...) at kernel/qeventloop.cpp:201
#44 0xb737e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb615e924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293238, bug 293222, bug 293221, bug 293170, bug 293153.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-04 03:33:06 UTC

*** This bug has been marked as a duplicate of bug 291262 ***