Bug 292017 - kmail 4.8 rc2
Summary: kmail 4.8 rc2
Status: RESOLVED DUPLICATE of bug 281402
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Dispatcher Agent (show other bugs)
Version: 4.7
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 06:57 UTC by ultrabla
Modified: 2012-02-06 21:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ultrabla 2012-01-20 06:57:52 UTC
Application: akonadi_maildispatcher_agent (4.7)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
tried to send email.
i know that there are several bugs related to this but all these bugs have a statement that it is supposed to be fixed in 4.7.4
since i am using 4.8 rc2........

-- Backtrace:
Application: Agent zur Nachrichten-Auslieferung (akonadi_maildispatcher_agent), signal: Segmentation fault
[KCrash Handler]
#6  detach (this=0x80) at /usr/include/qt4/QtCore/qhash.h:299
#7  operator[] (akey=..., this=0x80) at /usr/include/qt4/QtCore/qhash.h:738
#8  KIO::ProtoQueue::removeJob (this=0x0, job=<optimized out>) at ../../kio/kio/scheduler.cpp:483
#9  0x00007f07454b9017 in KIO::SchedulerPrivate::assignJobToSlave (this=<optimized out>, slave=0x26fef20, job=0x26d15d0) at ../../kio/kio/scheduler.cpp:1274
#10 0x00007f0747dc00cc in MailTransport::SmtpJob::startSmtpJob (this=0x27b1de0) at ../../mailtransport/smtpjob.cpp:244
#11 0x00007f0747dc1027 in MailTransport::SmtpJob::doStart (this=0x27b1de0) at ../../mailtransport/smtpjob.cpp:133
#12 0x00007f0747dbce8c in MailTransport::TransportJob::start (this=0x27b1de0) at ../../mailtransport/transportjob.cpp:129
#13 0x00000000004165de in SendJob::Private::doTraditionalTransport (this=0x285fd30) at ../../../agents/maildispatcher/sendjob.cpp:205
#14 0x0000000000416f3e in SendJob::Private::doTransport (this=0x285fd30) at ../../../agents/maildispatcher/sendjob.cpp:132
#15 0x000000000041785e in SendJob::qt_metacall (this=0x26d19c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x266b990) at ./sendjob.moc:85
#16 0x00007f0748b3fa5e in QObject::event (this=0x26d19c0, e=<optimized out>) at kernel/qobject.cpp:1217
#17 0x00007f0746821424 in notify_helper (e=0x26d60c0, receiver=0x26d19c0, this=0x256d090) at kernel/qapplication.cpp:4486
#18 QApplicationPrivate::notify_helper (this=0x256d090, receiver=0x26d19c0, e=0x26d60c0) at kernel/qapplication.cpp:4458
#19 0x00007f0746826291 in QApplication::notify (this=0x7fff4d29b560, receiver=0x26d19c0, e=0x26d60c0) at kernel/qapplication.cpp:4365
#20 0x00007f0747535ae6 in KApplication::notify (this=0x7fff4d29b560, receiver=0x26d19c0, event=0x26d60c0) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f0748b28afc in QCoreApplication::notifyInternal (this=0x7fff4d29b560, receiver=0x26d19c0, event=0x26d60c0) at kernel/qcoreapplication.cpp:787
#22 0x00007f0748b2c51f in sendEvent (event=0x26d60c0, receiver=0x26d19c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x254b0a0) at kernel/qcoreapplication.cpp:1428
#24 0x00007f0748b53a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#26 0x00007f0744136a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f0744137258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f0744137429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f0748b53ed6 in QEventDispatcherGlib::processEvents (this=0x254cbb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f07468c907e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f0748b27cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f0748b27ef7 in QEventLoop::exec (this=0x7fff4d29b4e0, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f0748b2c789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#34 0x00007f0749124816 in Akonadi::AgentBase::init (r=0x271e140) at ../../akonadi/agentbase.cpp:564
#35 0x000000000040bec3 in Akonadi::AgentBase::init<MailDispatcherAgent> (argc=<optimized out>, argv=<optimized out>) at /usr/include/KDE/Akonadi/../../akonadi/agentbase.h:342
#36 0x00007f0745d8a30d in __libc_start_main (main=0x408f50 <main(int, char**)>, argc=3, ubp_av=0x7fff4d29b678, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4d29b668) at libc-start.c:226
#37 0x0000000000409015 in _start ()

Possible duplicates by query: bug 284850, bug 284847, bug 282889, bug 281402.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-02-06 21:11:36 UTC

*** This bug has been marked as a duplicate of bug 281402 ***