Bug 284847 - Akonadi crashed when I tried to send a mail
Summary: Akonadi crashed when I tried to send a mail
Status: RESOLVED DUPLICATE of bug 281402
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Dispatcher Agent (show other bugs)
Version: 4.7
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-24 07:47 UTC by David Nemeskey
Modified: 2011-11-17 22:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.07 KB, text/plain)
2011-11-02 10:09 UTC, Rolf Eike Beer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Nemeskey 2011-10-24 07:47:16 UTC
Application: akonadi_maildispatcher_agent (4.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I wrote a short test mail, pushed the "Send" button, and now I'm writing this report.

- Custom settings of the application:
Not much I am aware of. What was strange, is that my smtp password is saved in kwallet, yet kmail2 asked for it nevertheless.

-- Backtrace:
Application: Mail Dispatcher Agent (akonadi_maildispatcher_agent), signal: Segmentation fault
[KCrash Handler]
#6  detach (this=0x80) at /usr/include/qt4/QtCore/qhash.h:299
#7  operator[] (akey=..., this=0x80) at /usr/include/qt4/QtCore/qhash.h:738
#8  KIO::ProtoQueue::removeJob (this=0x0, job=0x83ae00) at ../../kio/kio/scheduler.cpp:483
#9  0x00007ff2a1f8e367 in KIO::SchedulerPrivate::assignJobToSlave (this=<optimized out>, slave=0xba0080, job=0x83ae00) at ../../kio/kio/scheduler.cpp:1274
#10 0x00007ff2a489509f in MailTransport::SmtpJob::startSmtpJob (this=0x8196b0) at ../../mailtransport/smtpjob.cpp:239
#11 0x00007ff2a4896062 in MailTransport::SmtpJob::doStart (this=0x8196b0) at ../../mailtransport/smtpjob.cpp:129
#12 0x00007ff2a4891ddc in MailTransport::TransportJob::start (this=0x8196b0) at ../../mailtransport/transportjob.cpp:129
#13 0x000000000041563f in SendJob::Private::doTraditionalTransport (this=0x81f470) at ../../../agents/maildispatcher/sendjob.cpp:197
#14 0x0000000000415f8e in SendJob::Private::doTransport (this=0x81f470) at ../../../agents/maildispatcher/sendjob.cpp:130
#15 0x00000000004168ae in SendJob::qt_metacall (this=0x88ac10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x846470) at ./sendjob.moc:85
#16 0x00007ff2a5614a5e in QObject::event (this=0x88ac10, e=<optimized out>) at kernel/qobject.cpp:1217
#17 0x00007ff2a32f6424 in notify_helper (e=0x826bc0, receiver=0x88ac10, this=0x67f4f0) at kernel/qapplication.cpp:4486
#18 QApplicationPrivate::notify_helper (this=0x67f4f0, receiver=0x88ac10, e=0x826bc0) at kernel/qapplication.cpp:4458
#19 0x00007ff2a32fb291 in QApplication::notify (this=0x7fffc1190130, receiver=0x88ac10, e=0x826bc0) at kernel/qapplication.cpp:4365
#20 0x00007ff2a400a126 in KApplication::notify (this=0x7fffc1190130, receiver=0x88ac10, event=0x826bc0) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007ff2a55fdafc in QCoreApplication::notifyInternal (this=0x7fffc1190130, receiver=0x88ac10, event=0x826bc0) at kernel/qcoreapplication.cpp:787
#22 0x00007ff2a560151f in sendEvent (event=0x826bc0, receiver=0x88ac10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x65e0a0) at kernel/qcoreapplication.cpp:1428
#24 0x00007ff2a5628a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#26 0x00007ff2a0c0fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ff2a0c10258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ff2a0c10429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff2a5628ed6 in QEventDispatcherGlib::processEvents (this=0x65fbb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007ff2a339e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007ff2a55fccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007ff2a55fcef7 in QEventLoop::exec (this=0x7fffc118ead0, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007ff2a41292c1 in KWallet::Wallet::openWallet (name=..., w=0, ot=KWallet::Wallet::Synchronous) at ../../kdeui/util/kwallet.cpp:304
#34 0x00007ff2a488e573 in MailTransport::TransportManager::wallet (this=0x7fecc0) at ../../mailtransport/transportmanager.cpp:604
#35 0x00007ff2a4885cfd in MailTransport::Transport::readPassword (this=0x820860) at ../../mailtransport/transport.cpp:309
#36 0x00007ff2a4886450 in MailTransport::Transport::qt_metacall (this=0x820860, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=<optimized out>) at ./transport.moc:72
#37 0x00007ff2a5614a5e in QObject::event (this=0x820860, e=<optimized out>) at kernel/qobject.cpp:1217
#38 0x00007ff2a32f6424 in notify_helper (e=0x82bdc0, receiver=0x820860, this=0x67f4f0) at kernel/qapplication.cpp:4486
#39 QApplicationPrivate::notify_helper (this=0x67f4f0, receiver=0x820860, e=0x82bdc0) at kernel/qapplication.cpp:4458
#40 0x00007ff2a32fb291 in QApplication::notify (this=0x7fffc1190130, receiver=0x820860, e=0x82bdc0) at kernel/qapplication.cpp:4365
#41 0x00007ff2a400a126 in KApplication::notify (this=0x7fffc1190130, receiver=0x820860, event=0x82bdc0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007ff2a55fdafc in QCoreApplication::notifyInternal (this=0x7fffc1190130, receiver=0x820860, event=0x82bdc0) at kernel/qcoreapplication.cpp:787
#43 0x00007ff2a560151f in sendEvent (event=0x82bdc0, receiver=0x820860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x65e0a0) at kernel/qcoreapplication.cpp:1428
#45 0x00007ff2a5628a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#46 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#47 0x00007ff2a0c0fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007ff2a0c10258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007ff2a0c10429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007ff2a5628ed6 in QEventDispatcherGlib::processEvents (this=0x65fbb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#51 0x00007ff2a339e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x00007ff2a55fccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#53 0x00007ff2a55fcef7 in QEventLoop::exec (this=0x7fffc118f610, flags=...) at kernel/qeventloop.cpp:201
#54 0x00007ff2a41292c1 in KWallet::Wallet::openWallet (name=..., w=0, ot=KWallet::Wallet::Synchronous) at ../../kdeui/util/kwallet.cpp:304
#55 0x00007ff2a488e573 in MailTransport::TransportManager::wallet (this=0x7fecc0) at ../../mailtransport/transportmanager.cpp:604
#56 0x00007ff2a4885cfd in MailTransport::Transport::readPassword (this=0x812e60) at ../../mailtransport/transport.cpp:309
#57 0x00007ff2a4886450 in MailTransport::Transport::qt_metacall (this=0x812e60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=<optimized out>) at ./transport.moc:72
#58 0x00007ff2a5614a5e in QObject::event (this=0x812e60, e=<optimized out>) at kernel/qobject.cpp:1217
#59 0x00007ff2a32f6424 in notify_helper (e=0x8175c0, receiver=0x812e60, this=0x67f4f0) at kernel/qapplication.cpp:4486
#60 QApplicationPrivate::notify_helper (this=0x67f4f0, receiver=0x812e60, e=0x8175c0) at kernel/qapplication.cpp:4458
#61 0x00007ff2a32fb291 in QApplication::notify (this=0x7fffc1190130, receiver=0x812e60, e=0x8175c0) at kernel/qapplication.cpp:4365
#62 0x00007ff2a400a126 in KApplication::notify (this=0x7fffc1190130, receiver=0x812e60, event=0x8175c0) at ../../kdeui/kernel/kapplication.cpp:311
#63 0x00007ff2a55fdafc in QCoreApplication::notifyInternal (this=0x7fffc1190130, receiver=0x812e60, event=0x8175c0) at kernel/qcoreapplication.cpp:787
#64 0x00007ff2a560151f in sendEvent (event=0x8175c0, receiver=0x812e60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x65e0a0) at kernel/qcoreapplication.cpp:1428
#66 0x00007ff2a5628a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#67 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#68 0x00007ff2a0c0fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007ff2a0c10258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007ff2a0c10429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#71 0x00007ff2a5628ed6 in QEventDispatcherGlib::processEvents (this=0x65fbb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#72 0x00007ff2a339e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#73 0x00007ff2a55fccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#74 0x00007ff2a55fcef7 in QEventLoop::exec (this=0x7fffc11900b0, flags=...) at kernel/qeventloop.cpp:201
#75 0x00007ff2a5601789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#76 0x00007ff2a5bf3406 in Akonadi::AgentBase::init (r=0x7aef90) at ../../akonadi/agentbase.cpp:554
#77 0x000000000040be03 in Akonadi::AgentBase::init<MailDispatcherAgent> (argc=<optimized out>, argv=<optimized out>) at /usr/include/KDE/Akonadi/../../akonadi/agentbase.h:342
#78 0x00007ff2a285f30d in __libc_start_main (main=0x408e90 <main(int, char**)>, argc=3, ubp_av=0x7fffc1190248, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc1190238) at libc-start.c:226
#79 0x0000000000408f55 in _start ()

This bug may be a duplicate of or related to bug 281402.

Possible duplicates by query: bug 282889, bug 281402.

Reported using DrKonqi
Comment 1 Rolf Eike Beer 2011-11-02 10:09:53 UTC
Created attachment 65152 [details]
New crash information added by DrKonqi

akonadi_maildispatcher_agent (4.7) on KDE Platform 4.7.2 (4.7.2) "release 9" using Qt 4.7.4

I tried to send a mail when this crash happened. I was not asked for a password, the wallet was still open.

-- Backtrace (Reduced):
#8  0xb6e04614 in MailTransport::TransportManager::wallet (this=0x8182668) at /usr/src/debug/kdepimlibs-4.7.2/mailtransport/transportmanager.cpp:588
#9  0xb6e04b95 in MailTransport::Transport::readPassword (this=0x82568b8) at /usr/src/debug/kdepimlibs-4.7.2/mailtransport/transport.cpp:309
#10 0xb6e059f6 in MailTransport::Transport::qt_metacall (this=0x82568b8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x8279080)
    at /usr/src/debug/kdepimlibs-4.7.2/build/mailtransport/transport.moc:72
[...]
#13 0xb738363f in QObject::event (this=0x82568b8, e=0x819e2a0) at kernel/qobject.cpp:1226
#14 0xb5fcf624 in QApplicationPrivate::notify_helper (this=0x808ab60, receiver=0x82568b8, e=0x819e2a0) at kernel/qapplication.cpp:4481
Comment 2 Christophe Giboudeaux 2011-11-17 22:47:48 UTC

*** This bug has been marked as a duplicate of bug 281402 ***