Bug 284850 - Error on sending an email
Summary: Error on sending an email
Status: RESOLVED DUPLICATE of bug 281402
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Dispatcher Agent (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-24 08:31 UTC by mhitzelberger
Modified: 2011-11-17 22:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mhitzelberger 2011-10-24 08:31:32 UTC
Application: akonadi_maildispatcher_agent (4.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 2.6.37.6-0.7-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Tried to send an email, when pressing the 'send'-button in the message-window I got an error message

The crash can be reproduced some of the time.

-- Backtrace:
Application: Agent zur Nachrichten-Auslieferung (akonadi_maildispatcher_agent), signal: Segmentation fault
[KCrash Handler]
#6  detach (this=0x0, job=<value optimized out>) at /usr/include/QtCore/qhash.h:299
#7  operator[] (this=0x0, job=<value optimized out>) at /usr/include/QtCore/qhash.h:738
#8  KIO::ProtoQueue::removeJob (this=0x0, job=<value optimized out>) at /usr/src/debug/kdelibs-4.7.2/kio/kio/scheduler.cpp:483
#9  0x00007f7a01d2e66c in KIO::SchedulerPrivate::assignJobToSlave (this=<value optimized out>, slave=0x7dab80, job=0x8b4940) at /usr/src/debug/kdelibs-4.7.2/kio/kio/scheduler.cpp:1274
#10 0x00007f7a045d0061 in MailTransport::SmtpJob::startSmtpJob (this=0x7e08b0) at /usr/src/debug/kdepimlibs-4.7.2/mailtransport/smtpjob.cpp:239
#11 0x00007f7a045d0ec7 in MailTransport::SmtpJob::doStart (this=0x7e08b0) at /usr/src/debug/kdepimlibs-4.7.2/mailtransport/smtpjob.cpp:129
#12 0x00007f7a045b9634 in MailTransport::TransportJob::start (this=0x7e08b0) at /usr/src/debug/kdepimlibs-4.7.2/mailtransport/transportjob.cpp:129
#13 0x0000000000415a33 in ?? ()
#14 0x00000000004165b9 in ?? ()
#15 0x0000000000416d9e in ?? ()
#16 0x00007f7a053367aa in QObject::event (this=0x7e7a80, e=<value optimized out>) at kernel/qobject.cpp:1226
#17 0x00007f7a03023264 in QApplicationPrivate::notify_helper (this=0x64cf50, receiver=0x7e7a80, e=0x8762c0) at kernel/qapplication.cpp:4481
#18 0x00007f7a0302b81a in QApplication::notify (this=<value optimized out>, receiver=0x7e7a80, e=0x8762c0) at kernel/qapplication.cpp:4360
#19 0x00007f7a03d3aae6 in KApplication::notify (this=0x7fff59418e80, receiver=0x7e7a80, event=0x8762c0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#20 0x00007f7a053227cc in QCoreApplication::notifyInternal (this=0x7fff59418e80, receiver=0x7e7a80, event=0x8762c0) at kernel/qcoreapplication.cpp:787
#21 0x00007f7a05325fc5 in sendEvent (receiver=0x0, event_type=0, data=0x62f190) at kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x62f190) at kernel/qcoreapplication.cpp:1428
#23 0x00007f7a0534d443 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007f7a009afbd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#26 0x00007f7a009b03b0 in ?? () from /lib64/libglib-2.0.so.0
#27 0x00007f7a009b0650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#28 0x00007f7a0534d5df in QEventDispatcherGlib::processEvents (this=0x62e9a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007f7a030c938e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f7a05321c22 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f7a05321e35 in QEventLoop::exec (this=0x7fff59418df0, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007f7a0532627b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#33 0x00007f7a059188d7 in Akonadi::AgentBase::init (r=0x6e52d0) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/agentbase.cpp:554
#34 0x000000000040b00a in _start ()

This bug may be a duplicate of or related to bug 284847.

Possible duplicates by query: bug 284847, bug 282889, bug 281402.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-17 22:47:37 UTC

*** This bug has been marked as a duplicate of bug 281402 ***