Bug 289767 - Crash after changing settings
Summary: Crash after changing settings
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-25 07:27 UTC by m.wege
Modified: 2012-02-08 15:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.35 KB, text/plain)
2012-02-08 15:15 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2011-12-25 07:27:02 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.90 (4.8 Beta2 (4.7.90)
Qt Version: 4.7.4
Operating System: Linux 3.2.0-5-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I had just changed settings of the IMAP-Server (turned of the Cached IMAP and folder abonements), then the crash occured. But I am not sure if it is related to that. The email checking had been hanging for a while at the same point.

-- Backtrace:
Application: Wege vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc58e191780 (LWP 19389))]

Thread 6 (Thread 0x7fc58856f700 (LWP 19393)):
#0  0x00000030c1cd5773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000030c5044f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00000030ca597f3e in QEventDispatcherGlib::processEvents (this=0x1b769f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00000030ca56bef7 in QEventLoop::exec (this=0x7fc58856edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00000030ca48327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00000030ca54ecbf in QInotifyFileSystemWatcherEngine::run (this=0x1b7ea60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00000030ca485d05 in QThreadPrivate::start (arg=0x1b7ea60) at thread/qthread_unix.cpp:331
#9  0x00000030c2407efc in start_thread (arg=0x7fc58856f700) at pthread_create.c:304
#10 0x00000030c1ce189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fc57ffff700 (LWP 19467)):
#0  QTimerInfoList::repairTimersIfNeeded (this=0x1fd5bb0) at kernel/qeventdispatcher_unix.cpp:394
#1  0x00000030ca598a51 in QTimerInfoList::timerWait (this=0x1fd5bb0, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#2  0x00000030ca59744c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fc57fffec4c) at kernel/qeventdispatcher_glib.cpp:136
#3  0x00000030ca5974f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#4  0x00000030c5043ff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00000030c5044dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00000030ca597f3e in QEventDispatcherGlib::processEvents (this=0x212ca70, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00000030ca56bef7 in QEventLoop::exec (this=0x7fc57fffede0, flags=...) at kernel/qeventloop.cpp:201
#10 0x00000030ca48327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#11 0x000000366ac3ac13 in KIMAP::SessionThread::run (this=0x19d2fe0) at ../../kimap/sessionthread.cpp:171
#12 0x00000030ca485d05 in QThreadPrivate::start (arg=0x19d2fe0) at thread/qthread_unix.cpp:331
#13 0x00000030c2407efc in start_thread (arg=0x7fc57ffff700) at pthread_create.c:304
#14 0x00000030c1ce189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fc586b83700 (LWP 19777)):
#0  0x00000030c240b1fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1fed818) at pthread_mutex_unlock.c:290
#2  0x00000030c504472e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00000030c5044f82 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00000030ca597f3e in QEventDispatcherGlib::processEvents (this=0x1fecff0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000030ca56bef7 in QEventLoop::exec (this=0x7fc586b82de0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00000030ca48327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x000000366ac3ac13 in KIMAP::SessionThread::run (this=0x225f1f0) at ../../kimap/sessionthread.cpp:171
#10 0x00000030ca485d05 in QThreadPrivate::start (arg=0x225f1f0) at thread/qthread_unix.cpp:331
#11 0x00000030c2407efc in start_thread (arg=0x7fc586b83700) at pthread_create.c:304
#12 0x00000030c1ce189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fc57f7fe700 (LWP 19778)):
#0  0x00000030c1cd5773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000030c5044f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00000030ca597f3e in QEventDispatcherGlib::processEvents (this=0x1c3e9d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00000030ca56bef7 in QEventLoop::exec (this=0x7fc57f7fdde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00000030ca48327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x000000366ac3ac13 in KIMAP::SessionThread::run (this=0x3484d40) at ../../kimap/sessionthread.cpp:171
#8  0x00000030ca485d05 in QThreadPrivate::start (arg=0x3484d40) at thread/qthread_unix.cpp:331
#9  0x00000030c2407efc in start_thread (arg=0x7fc57f7fe700) at pthread_create.c:304
#10 0x00000030c1ce189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc57e57d700 (LWP 19784)):
#0  0x00000030c240b1fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1fc1998) at pthread_mutex_unlock.c:290
#2  0x00000030c5043fe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00000030c5044dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00000030ca597f3e in QEventDispatcherGlib::processEvents (this=0x22a7c20, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000030ca56bef7 in QEventLoop::exec (this=0x7fc57e57cde0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00000030ca48327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x000000366ac3ac13 in KIMAP::SessionThread::run (this=0x2092ba0) at ../../kimap/sessionthread.cpp:171
#10 0x00000030ca485d05 in QThreadPrivate::start (arg=0x2092ba0) at thread/qthread_unix.cpp:331
#11 0x00000030c2407efc in start_thread (arg=0x7fc57e57d700) at pthread_create.c:304
#12 0x00000030c1ce189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc58e191780 (LWP 19389)):
[KCrash Handler]
#6  0x00000030ca57f712 in QObject::disconnect (sender=0x33af160, signal=0x22aafa9 "connectionLost()", receiver=0x1b51940, method=0x510ff69 "onEarlyConnectionLost()") at kernel/qobject.cpp:2728
#7  0x0000000000453971 in SessionPool::killSession (this=0x1b51940, session=0x33af160, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#8  0x0000000000453f35 in SessionPool::disconnect (this=0x1b51940, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#9  0x0000000000416873 in ImapResource::doSetOnline (this=0x1ad87e0, online=false) at ../../../resources/imap/imapresource.cpp:422
#10 0x00000036630839c8 in Akonadi::AgentBase::setOnline (this=0x1ad87e0, state=false) at ../../akonadi/agentbase.cpp:631
#11 0x0000000000416b38 in ImapResource::reconnect (this=0x1ad87e0) at ../../../resources/imap/imapresource.cpp:446
#12 0x00000036631cda55 in configure (windowId=<optimized out>, this=0x1ad5b70) at controladaptor.cpp:51
#13 Akonadi__ControlAdaptor::qt_metacall (this=0x1ad5b70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff07e846e0) at controladaptor.moc:102
#14 0x00000030cc6230e9 in QDBusConnectionPrivate::deliverCall (this=0x199df00, object=0x1ad5b70, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:942
#15 0x00000030cc62425c in QDBusConnectionPrivate::activateCall (this=0x199df00, object=0x1ad5b70, flags=273, msg=...) at qdbusintegrator.cpp:852
#16 0x00000030cc624b22 in QDBusConnectionPrivate::activateObject (this=0x199df00, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1410
#17 0x00000030cc624bf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x50e4720) at qdbusintegrator.cpp:1524
#18 0x00000030ca583a5e in QObject::event (this=0x1ad87e0, e=<optimized out>) at kernel/qobject.cpp:1217
#19 0x0000003456ffc424 in notify_helper (e=0x50e4720, receiver=0x1ad87e0, this=0x1930d50) at kernel/qapplication.cpp:4486
#20 QApplicationPrivate::notify_helper (this=0x1930d50, receiver=0x1ad87e0, e=0x50e4720) at kernel/qapplication.cpp:4458
#21 0x0000003457001291 in QApplication::notify (this=0x7fff07e851c0, receiver=0x1ad87e0, e=0x50e4720) at kernel/qapplication.cpp:4365
#22 0x0000003660431466 in KApplication::notify (this=0x7fff07e851c0, receiver=0x1ad87e0, event=0x50e4720) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00000030ca56cafc in QCoreApplication::notifyInternal (this=0x7fff07e851c0, receiver=0x1ad87e0, event=0x50e4720) at kernel/qcoreapplication.cpp:787
#24 0x00000030ca57051f in sendEvent (event=0x50e4720, receiver=0x1ad87e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x190b800) at kernel/qcoreapplication.cpp:1428
#26 0x00000030ca597a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#27 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#28 0x00000030c5044a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00000030c5045258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00000030c5045429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00000030ca597ed6 in QEventDispatcherGlib::processEvents (this=0x190d210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00000034570a407e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00000030ca56bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00000030ca56bef7 in QEventLoop::exec (this=0x7fff07e85140, flags=...) at kernel/qeventloop.cpp:201
#35 0x00000030ca570789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x0000003663155976 in Akonadi::ResourceBase::init (r=0x1ad87e0) at ../../akonadi/resourcebase.cpp:405
#37 0x000000000041a6d6 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#38 0x00000030c1c2130d in __libc_start_main (main=0x415000 <main(int, char**)>, argc=3, ubp_av=0x7fff07e852d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff07e852c8) at libc-start.c:226
#39 0x00000000004151b5 in _start ()

This bug may be a duplicate of or related to bug 288268.

Possible duplicates by query: bug 289052, bug 288515, bug 288268.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-25 13:13:22 UTC

*** This bug has been marked as a duplicate of bug 288268 ***
Comment 2 Christian 2012-02-08 15:15:53 UTC
Created attachment 68623 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.7) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: I have changed only the time setting how often Kontact checks the mailbox from 10 to 12 minutes.

-- Backtrace (Reduced):
#6  0x00007f65a7294712 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x0000000000453931 in SessionPool::killSession (this=0x22979d0, session=0x22db220, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#8  0x0000000000453ef5 in SessionPool::disconnect (this=0x22979d0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#9  0x00000000004168c3 in ImapResource::doSetOnline (this=0x21ae410, online=false) at ../../../resources/imap/imapresource.cpp:421
#10 0x00007f65a78acee8 in Akonadi::AgentBase::setOnline(bool) () from /usr/lib/libakonadi-kde.so.4