Bug 288515 - IMAP agent crashed
Summary: IMAP agent crashed
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Chakra Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-09 01:52 UTC by korga001
Modified: 2011-12-09 09:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description korga001 2011-12-09 01:52:23 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.90 (4.8 Beta2 (4.7.90)
Qt Version: 4.7.4
Operating System: Linux 3.1-CHAKRA i686
Distribution: "Chakra Linux"

-- Information about the crash:
The IMAP agent crashed after I resumed from suspend
- Custom settings of the application:
My internet connection is very poor, so it gets disconnected from time to time. After a few reconnect I can't use KMail to view emails which are not in cache, and I don't se new mails neither.

-- Backtrace:
Application: Google Mail of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4b38710 (LWP 1179))]

Thread 2 (Thread 0xb3874b70 (LWP 1236)):
#0  0xb7841424 in __kernel_vsyscall ()
#1  0xb58ad1ae in poll () from /lib/libc.so.6
#2  0xb56841ab in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb5673c4f in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb5673fc4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb743c957 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb740d73d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb740d981 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb73112cb in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb66e69b0 in KIMAP::SessionThread::run (this=0x97856b0) at /chakra/desktop-unstable/kdepimlibs/src/kdepimlibs-4.7.90/kimap/sessionthread.cpp:171
#10 0xb7314123 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb5776cf7 in start_thread () from /lib/libpthread.so.0
#12 0xb58b786e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4b38710 (LWP 1179)):
[KCrash Handler]
#7  0xb7423031 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/libQtCore.so.4
#8  0x0809a6e7 in SessionPool::killSession (this=0x97693b8, session=0x9914568, termination=SessionPool::LogoutSession) at /chakra/desktop-unstable/kdepim-runtime/src/kdepim-runtime-4.7.90/resources/imap/sessionpool.cpp:177
#9  0x0809ad10 in SessionPool::disconnect (this=0x97693b8, termination=SessionPool::LogoutSession) at /chakra/desktop-unstable/kdepim-runtime/src/kdepim-runtime-4.7.90/resources/imap/sessionpool.cpp:119
#10 0x0805b48b in ImapResource::doSetOnline (this=0x97378d0, online=false) at /chakra/desktop-unstable/kdepim-runtime/src/kdepim-runtime-4.7.90/resources/imap/imapresource.cpp:422
#11 0xb762b1e5 in Akonadi::AgentBase::setOnline (this=0x97378d0, state=false) at /chakra/desktop-unstable/kdepimlibs/src/kdepimlibs-4.7.90/akonadi/agentbase.cpp:631
#12 0xb762b3b6 in Akonadi::AgentBasePrivate::slotNetworkStatusChange (this=0x975c960, stat=Solid::Networking::Unconnected) at /chakra/desktop-unstable/kdepimlibs/src/kdepimlibs-4.7.90/akonadi/agentbase.cpp:496
#13 0xb762c670 in Akonadi::AgentBase::qt_metacall (this=0x97378d0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xbfad43d8) at /chakra/desktop-unstable/kdepimlibs/src/build/akonadi/agentbase.moc:127
#14 0xb7713062 in Akonadi::ResourceBase::qt_metacall (this=0x97378d0, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbfad43d8) at /chakra/desktop-unstable/kdepimlibs/src/build/akonadi/moc_resourcebase.cpp:125
#15 0x0805ef17 in ImapResource::qt_metacall (this=0x97378d0, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbfad43d8) at /chakra/desktop-unstable/kdepim-runtime/src/build/resources/imap/imapresource.moc:112
#16 0xb7414acd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#17 0xb74238aa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb61faab5 in Solid::Networking::Notifier::statusChanged (this=0x9768f28, _t1=Solid::Networking::Unconnected) at /chakra/desktop-unstable/kdelibs/src/build/solid/solid/networking.moc:90
#19 0xb61fac60 in Solid::NetworkingPrivate::serviceStatusChanged (this=0x9768f28, status=1) at /chakra/desktop-unstable/kdelibs/src/kdelibs-4.7.90/solid/solid/networking.cpp:115
#20 0xb61fb2e5 in Solid::NetworkingPrivate::qt_metacall (this=0x9768f28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfad4528) at /chakra/desktop-unstable/kdelibs/src/build/solid/solid/networking_p.moc:89
#21 0xb7414acd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb74238aa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6269e45 in OrgKdeSolidNetworkingClientInterface::statusChanged (this=0x9778ee0, _t1=1) at /chakra/desktop-unstable/kdelibs/src/build/solid/solid/org_kde_solid_networking_client.moc:118
#24 0xb6269ed5 in OrgKdeSolidNetworkingClientInterface::qt_metacall (this=0x9778ee0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfad4624) at /chakra/desktop-unstable/kdelibs/src/build/solid/solid/org_kde_solid_networking_client.moc:81
#25 0xb75620d5 in ?? () from /usr/lib/libQtDBus.so.4
#26 0xb756c286 in ?? () from /usr/lib/libQtDBus.so.4
#27 0xb7426992 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#28 0xb697e764 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb6983b13 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#30 0xb5f570b1 in KApplication::notify (this=0xbfad4dd0, receiver=0x9778ee0, event=0x990c460) at /chakra/desktop-unstable/kdelibs/src/kdelibs-4.7.90/kdeui/kernel/kapplication.cpp:311
#31 0xb740e6fe in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#32 0xb7411ee3 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#33 0xb741203c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#34 0xb743c4c4 in ?? () from /usr/lib/libQtCore.so.4
#35 0xb5673532 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb5673d10 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb5673fc4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb743c8fa in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6a31a7a in ?? () from /usr/lib/libQtGui.so.4
#40 0xb740d73d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb740d981 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb74120ed in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0xb697c5d4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0xb770d541 in Akonadi::ResourceBase::init (r=0x97378d0) at /chakra/desktop-unstable/kdepimlibs/src/kdepimlibs-4.7.90/akonadi/resourcebase.cpp:405
#45 0x0805f557 in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0xbfad4ea4) at /usr/include/akonadi/resourcebase.h:188
#46 0x080599ab in main (argc=3, argv=0xbfad4ea4) at /chakra/desktop-unstable/kdepim-runtime/src/kdepim-runtime-4.7.90/resources/imap/imapresource.cpp:600

This bug may be a duplicate of or related to bug 288268.

Possible duplicates by query: bug 288268.

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-12-09 07:12:09 UTC
duplicate of bug 288268
Comment 2 Christophe Giboudeaux 2011-12-09 09:56:05 UTC

*** This bug has been marked as a duplicate of bug 288268 ***