Bug 289398 - apper cannot update unsigned packages
Summary: apper cannot update unsigned packages
Status: RESOLVED FIXED
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
: 293848 296995 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-20 00:53 UTC by Nick Coghlan
Modified: 2012-06-11 12:30 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.7.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Coghlan 2011-12-20 00:53:31 UTC
Version:           unspecified (using KDE 4.7.3) 
OS:                Linux

I use a few unsigned packages from alternate repos. However, whenever packages from these repos require updating, apper seems to get stuck in the following loop:
1. Progress bar displays "Waiting for service to start" (0%)
2. "Installing unsigned software" warning dialog pops up
3. I hit "Yes"
4. Progress bar moves to "Checking for libraries currently in use"
5. Progress bar moves to "Running task" (0%)
6. Return to Step 1

(If there aren't any other packages to be updated, it pretty much skips directly from Step 3 back to Step 1)

Reproducible: Always

Steps to Reproduce:
1. Have unsigned packages awaiting update
2. Try to use Apper to update them

Actual Results:  
The interaction loop described in the Details section

Expected Results:  
All packages updated after I hit "Yes" in the warning dialog

The simple workaround is to use the command line whenever unsigned packages need updating: "sudo yum upgrade"
Comment 1 Martin Kho 2012-01-14 15:05:40 UTC
Hi,

I've seen a difference between unsigned updates (via apper update icon) and unsigned new packages.

(1) In case of updates I also get the above error (missing authorisation dialog).

(2) When installing a new package I first get a dialog telling that I need 'root' permissions, then I get the message that the package is unsigned. After pressing the 'Yes' button an 'auhtorisation dialog for untrusted sources' pops up and I can install the new package. 

Btw: In Fedora 17 (aka Rawhide) all packages are unsigned.

Martin Kho
Comment 2 Daniel Nicoletti 2012-02-17 00:47:31 UTC
I guess this is fixed in the git version, can you please try since openSUSE reported a similar bug..
Comment 3 Daniel Nicoletti 2012-04-03 00:37:25 UTC
*** Bug 296995 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Nicoletti 2012-04-03 00:37:32 UTC
*** Bug 293848 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Nicoletti 2012-04-03 00:39:21 UTC
Git commit 26fc51cc073ef75f8468c3ac88f86f16edd922b1 by Daniel Nicoletti.
Committed on 03/04/2012 at 02:38.
Pushed by dantti into branch 'master'.

Fix updating that requires installing/updating packages from untrusted sources

M  +0    -1    Sentinel/UpdateIcon.cpp
M  +2    -5    libapper/PkTransaction.cpp

http://commits.kde.org/apper/26fc51cc073ef75f8468c3ac88f86f16edd922b1
Comment 6 Martin Kho 2012-06-11 12:30:03 UTC
Hi Daniel,

Now that I'm 'using' Fedora rawhide (aka fc18) - packages are not signed - I can confirm that this issue is solved, at least for me. 

Thanks for the great work!

Martin Kho