Bug 293848 - Apper mistakenly flagging unsigned packages - won't allow installation
Summary: Apper mistakenly flagging unsigned packages - won't allow installation
Status: RESOLVED DUPLICATE of bug 289398
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-11 17:12 UTC by Thorsteinn A. Malmjursson
Modified: 2012-04-03 00:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsteinn A. Malmjursson 2012-02-11 17:12:26 UTC
Version:           unspecified (using KDE 4.7.4) 
OS:                Linux

Apper is complaining during updates that packages are unsigned - the process allows you to click a yes/no box to proceed, but when you click "yes", it simply loops, starts the whole process, and asks you the same question again and again, every time you click yes. It only goes away, when you say no.
 
The fact that it's complaining about the unsigned packages wouldn't normally be a problem - except that none of the packages I was trying to install (27 updates) were unsigned.  
 
I know this because I promptly processed the same set of updates via a cli using  apt-get update  and apt-get upgrade, and they all went through without complaint.  
 
Would someone please be kind enough to look into why apper is mistakenly flagging packages as unsigned, when they are properly signed?


Reproducible: Didn't try

Steps to Reproduce:
Please see additional information

Actual Results:  
Please see additional information

Expected Results:  
Please see additional information

I did not attempt to reproduce as I processed the updates via CLI after apper failed to do so.
Comment 1 Milos Jakubicek 2012-03-01 13:16:50 UTC
Hello,

I can confirm the bug, it is entirely reproducible with latest Apper version 0.7.1. Installing unsigned packages (e.g. from a private repository) is just impossible and blocks installing other packages as well. Please fix.
Comment 2 Daniel Nicoletti 2012-03-01 13:39:44 UTC
can you please test with pkcon :D
It's been a while I don't have unsigned repos so I don't see this..
Comment 3 Milos Jakubicek 2012-03-01 14:21:55 UTC
Just tried with pkcon, it works fine -- pkcon asks once whether I want to install an untrusted package and after confirming that does the job. So it looks like it will be indeed an Apper bug :)
Comment 4 Daniel Nicoletti 2012-03-01 14:25:56 UTC
thanks I'll try to simulatwe that and see if I can fix
Comment 5 Justin Lynn Reid 2012-03-28 23:22:58 UTC
I can confirm this bug too, and thanks for the advice on sudo-apt get update and sudo-apt get upgrade so that I can update Kubuntu. I've added a bug report on this issue as well.
Comment 6 Daniel Nicoletti 2012-04-02 23:50:17 UTC
Ok, I've just added an untrusted repo, and asked to install a package from there,
it prompted me with the untrusted thing and then started to download...
Can someone explains to me how to reproduce this?
(which repo did you use and so on?)
Thanks
Comment 7 Daniel Nicoletti 2012-04-03 00:37:32 UTC

*** This bug has been marked as a duplicate of bug 289398 ***