Bug 289310 - Kontact crashed during mail account configuration
Summary: Kontact crashed during mail account configuration
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: libakonadi (show other bugs)
Version: 4.9
Platform: Ubuntu Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 307732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-18 20:28 UTC by Richard M. McCord
Modified: 2017-01-07 21:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard M. McCord 2011-12-18 20:28:52 UTC
Application: kontact (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Linux Mint 12 Lisa

-- Information about the crash:
- What I was doing when the application crashed:
I had just pressed Enter after adding "plus." to the Yahoo SMTP record (we have the Plus package).

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9f0522f7a0 (LWP 2946))]

Thread 4 (Thread 0x7f9eeb241700 (LWP 2947)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f01a8ac2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f9f01a8ad59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f9efce89efc in start_thread (arg=0x7f9eeb241700) at pthread_create.c:304
#4  0x00007f9f0279889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9eeaa40700 (LWP 2948)):
#0  0x00007f9efce8d1fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0xe872c8) at pthread_mutex_unlock.c:290
#2  0x00007f9efc3bb900 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9efc3bc258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9efc3bc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9f03bd3f3e in QEventDispatcherGlib::processEvents (this=0xe871d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f9f03ba7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f9f03ba7ef7 in QEventLoop::exec (this=0x7f9eeaa3fde0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f9f03abf27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f9f03ac1d05 in QThreadPrivate::start (arg=0xe86980) at thread/qthread_unix.cpp:331
#10 0x00007f9efce89efc in start_thread (arg=0x7f9eeaa40700) at pthread_create.c:304
#11 0x00007f9f0279889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9e9b14b700 (LWP 2987)):
#0  0x00007f9f0278c773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9efc3bbf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9efc3bc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f03bd3f3e in QEventDispatcherGlib::processEvents (this=0x126ad80, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9f03ba7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9f03ba7ef7 in QEventLoop::exec (this=0x7f9e9b14adb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9f03abf27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9f03b8acbf in QInotifyFileSystemWatcherEngine::run (this=0x132bf40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9f03ac1d05 in QThreadPrivate::start (arg=0x132bf40) at thread/qthread_unix.cpp:331
#9  0x00007f9efce89efc in start_thread (arg=0x7f9e9b14b700) at pthread_create.c:304
#10 0x00007f9f0279889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9f0522f7a0 (LWP 2946)):
[KCrash Handler]
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x134ec20, source_parent=..., parent_mapping=0x237b2b0, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=false) at itemviews/qsortfilterproxymodel.cpp:946
#7  0x00007f9f034ed094 in QSortFilterProxyModelPrivate::source_items_inserted (this=0x134ec20, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:743
#8  0x00007f9f034ed57f in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x134ec20, source_parent=<optimized out>, start=<optimized out>, end=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:1278
#9  0x00007f9f034ef4f4 in QSortFilterProxyModel::qt_metacall (this=0x1290600, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0x7fff59757800) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#10 0x00007f9eff613390 in Akonadi::StatisticsProxyModel::qt_metacall (this=0x1290600, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59757800) at ./statisticsproxymodel.moc:72
#11 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x1361470, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff59757800) at kernel/qobject.cpp:3278
#12 0x00007f9f03c048d4 in QAbstractItemModel::rowsInserted (this=<optimized out>, _t1=<optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#13 0x00007f9f03ba322e in QAbstractItemModel::endInsertRows (this=0x1361470) at kernel/qabstractitemmodel.cpp:2412
#14 0x00007f9f034e9137 in QSortFilterProxyModelPrivate::insert_source_items (this=0x1360ff0, source_to_proxy=..., proxy_to_source=..., source_items=<optimized out>, source_parent=<optimized out>, orient=Qt::Vertical, emit_signal=true) at itemviews/qsortfilterproxymodel.cpp:693
#15 0x00007f9f034ed263 in QSortFilterProxyModelPrivate::source_items_inserted (this=0x1360ff0, source_parent=..., start=<optimized out>, end=<optimized out>, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:804
#16 0x00007f9f034ed57f in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x1360ff0, source_parent=<optimized out>, start=<optimized out>, end=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:1278
#17 0x00007f9f034ef4f4 in QSortFilterProxyModel::qt_metacall (this=0x1361470, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0x7fff59757b60) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#18 0x00007f9f0459db90 in KRecursiveFilterProxyModel::qt_metacall (this=0x1361470, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59757b60) at ./krecursivefilterproxymodel.moc:78
#19 0x00007f9f03bb04ae in QMetaMethod::invoke (this=0x7fff59757d40, object=0x1361470, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1597
#20 0x00007f9f03bb2690 in QMetaObject::invokeMethod (obj=0x1361470, member=<optimized out>, type=Qt::DirectConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#21 0x00007f9f0459d42e in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::DirectConnection, member=0x7f9f0474f708 "_q_sourceRowsInserted", obj=0x1361470) at /usr/include/qt4/QtCore/qobjectdefs.h:410
#22 invokeRowsInserted (end=0, start=0, source_parent=..., this=0x1291760) at ../../kdeui/itemviews/krecursivefilterproxymodel.cpp:66
#23 KRecursiveFilterProxyModelPrivate::sourceRowsInserted (this=0x1291760, source_parent=..., start=<optimized out>, end=0) at ../../kdeui/itemviews/krecursivefilterproxymodel.cpp:190
#24 0x00007f9f0459dc36 in KRecursiveFilterProxyModel::qt_metacall (this=0x1361470, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59758230) at ./krecursivefilterproxymodel.moc:85
#25 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x1254b50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff59758230) at kernel/qobject.cpp:3278
#26 0x00007f9f03c048d4 in QAbstractItemModel::rowsInserted (this=<optimized out>, _t1=<optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#27 0x00007f9f03ba322e in QAbstractItemModel::endInsertRows (this=0x1254b50) at kernel/qabstractitemmodel.cpp:2412
#28 0x00007f9f034e9137 in QSortFilterProxyModelPrivate::insert_source_items (this=0x12d9e70, source_to_proxy=..., proxy_to_source=..., source_items=<optimized out>, source_parent=<optimized out>, orient=Qt::Vertical, emit_signal=true) at itemviews/qsortfilterproxymodel.cpp:693
#29 0x00007f9f034ed263 in QSortFilterProxyModelPrivate::source_items_inserted (this=0x12d9e70, source_parent=..., start=<optimized out>, end=<optimized out>, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:804
#30 0x00007f9f034ed57f in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x12d9e70, source_parent=<optimized out>, start=<optimized out>, end=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:1278
#31 0x00007f9f034ef4f4 in QSortFilterProxyModel::qt_metacall (this=0x1254b50, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0x7fff59758560) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#32 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x11ed850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff59758560) at kernel/qobject.cpp:3278
#33 0x00007f9f03c048d4 in QAbstractItemModel::rowsInserted (this=<optimized out>, _t1=<optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#34 0x00007f9f03ba322e in QAbstractItemModel::endInsertRows (this=0x11ed850) at kernel/qabstractitemmodel.cpp:2412
#35 0x00007f9eff57eb27 in Akonadi::EntityTreeModelPrivate::insertCollection (this=0x12cd790, collection=..., parent=...) at ../../akonadi/entitytreemodel_p.cpp:699
#36 0x00007f9eff5833d5 in Akonadi::EntityTreeModelPrivate::monitoredCollectionAdded (this=0x12cd790, collection=..., parent=...) at ../../akonadi/entitytreemodel_p.cpp:734
#37 0x00007f9eff57390a in Akonadi::EntityTreeModel::qt_metacall (this=0x11ed850, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59758810) at ./entitytreemodel.moc:161
#38 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x11cfd60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff59758810) at kernel/qobject.cpp:3278
#39 0x00007f9eff5bcc4a in Akonadi::Monitor::collectionAdded (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at ./monitor.moc:211
#40 0x00007f9eff5c092e in Akonadi::MonitorPrivate::emitCollectionNotification (this=0x12c1650, msg=..., col=<optimized out>, par=<optimized out>, dest=<optimized out>) at ../../akonadi/monitor_p.cpp:590
#41 0x00007f9eff5c250a in Akonadi::MonitorPrivate::emitNotification (this=0x12c1650, msg=...) at ../../akonadi/monitor_p.cpp:281
#42 0x00007f9eff5274f1 in Akonadi::ChangeRecorderPrivate::emitNotification (this=0x12c1650, msg=<optimized out>) at ../../akonadi/changerecorder_p.h:60
#43 0x00007f9eff5c2246 in Akonadi::MonitorPrivate::flushPipeline (this=0x12c1650) at ../../akonadi/monitor_p.cpp:425
#44 0x00007f9eff5c26f9 in Akonadi::MonitorPrivate::dataAvailable (this=0x12c1650) at ../../akonadi/monitor_p.cpp:434
#45 0x00007f9eff5bcf85 in Akonadi::Monitor::qt_metacall (this=0x11cfd60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59758ca0) at ./monitor.moc:156
#46 0x00007f9eff525a48 in Akonadi::ChangeRecorder::qt_metacall (this=0x11cfd60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=<optimized out>) at ./changerecorder.moc:72
#47 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x12d8fd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#48 0x00007f9eff5c488d in Akonadi::EntityCache<Akonadi::Collection, Akonadi::CollectionFetchJob, Akonadi::CollectionFetchScope>::fetchResult (this=0x12d8fd0, job=<optimized out>) at ../../akonadi/entitycache_p.h:190
#49 0x00007f9eff56ce33 in Akonadi::EntityCacheBase::qt_metacall (this=0x12d8fd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff59758e80) at ./entitycache_p.moc:77
#50 0x00007f9f03bbbeba in QMetaObject::activate (sender=0x1807690, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff59758e80) at kernel/qobject.cpp:3278
#51 0x00007f9f0400e5b2 in KJob::result (this=<optimized out>, _t1=0x1807690) at ./kjob.moc:194
#52 0x00007f9f0400e5f0 in KJob::emitResult (this=0x1807690) at ../../kdecore/jobs/kjob.cpp:312
#53 0x00007f9eff5b9f4d in Akonadi::Job::qt_metacall (this=0x1807690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2577500) at ./job.moc:91
#54 0x00007f9eff536605 in Akonadi::CollectionFetchJob::qt_metacall (this=0x1807690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2577500) at ./collectionfetchjob.moc:75
#55 0x00007f9f03bbfa5e in QObject::event (this=0x1807690, e=<optimized out>) at kernel/qobject.cpp:1217
#56 0x00007f9f02f59424 in notify_helper (e=0x2c63480, receiver=0x1807690, this=0xe76a60) at kernel/qapplication.cpp:4486
#57 QApplicationPrivate::notify_helper (this=0xe76a60, receiver=0x1807690, e=0x2c63480) at kernel/qapplication.cpp:4458
#58 0x00007f9f02f5e291 in QApplication::notify (this=0x7fff597596f0, receiver=0x1807690, e=0x2c63480) at kernel/qapplication.cpp:4365
#59 0x00007f9f045de126 in KApplication::notify (this=0x7fff597596f0, receiver=0x1807690, event=0x2c63480) at ../../kdeui/kernel/kapplication.cpp:311
#60 0x00007f9f03ba8afc in QCoreApplication::notifyInternal (this=0x7fff597596f0, receiver=0x1807690, event=0x2c63480) at kernel/qcoreapplication.cpp:787
#61 0x00007f9f03bac51f in sendEvent (event=0x2c63480, receiver=0x1807690) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xe498e0) at kernel/qcoreapplication.cpp:1428
#63 0x00007f9f03bd3a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#65 0x00007f9efc3bba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#66 0x00007f9efc3bc258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#67 0x00007f9efc3bc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#68 0x00007f9f03bd3ed6 in QEventDispatcherGlib::processEvents (this=0xe4afd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#69 0x00007f9f0300107e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x00007f9f03ba7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#71 0x00007f9f03ba7ef7 in QEventLoop::exec (this=0x7fff59759680, flags=...) at kernel/qeventloop.cpp:201
#72 0x00007f9f03bac789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#73 0x0000000000403629 in main (argc=1, argv=0x7fff59759d18) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 287537, bug 277822, bug 276643, bug 276449.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-10-04 11:32:45 UTC
*** Bug 307732 has been marked as a duplicate of this bug. ***
Comment 2 Denis Kurz 2016-09-24 20:37:46 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 3 Denis Kurz 2017-01-07 21:43:03 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.