Bug 276643 - Zanshin and Kontact/KOrganizer crash when trying to edit category or name of ToDo (in either)
Summary: Zanshin and Kontact/KOrganizer crash when trying to edit category or name of ...
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: libakonadi (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-27 21:30 UTC by Matija Šuklje
Modified: 2012-01-18 01:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
console output (15.95 KB, application/octet-stream)
2011-06-28 08:31 UTC, Matija Šuklje
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matija Šuklje 2011-06-27 21:30:14 UTC
Application: zanshin (0.2)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.37-gentoo-r4 x86_64
Distribution: "Gentoo Base System release 2.0.2"

-- Information about the crash:
- What I was doing when the application crashed:

Sometimes when I edit either the name of a ToDo or its category, Zanshin's process eats up 100% of my CPU and more often then not crashes afterwards.

- Unusual behavior I noticed:

Usually if Kontact is running as well, it crashes about in the same minute.

- More info:

I pulled code from Git and compiled it myself yesterday (26-06-2011).

The crash can be reproduced some of the time.

-- Backtrace:
Application: Zanshin Todo (zanshin), signal: Segmentation fault
[KCrash Handler]
#6  iterator (this=0x96b070, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=false) at itemviews/qsortfilterproxymodel.cpp:946
#7  insert (this=0x96b070, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=false) at ../../include/QtCore/../../src/corelib/tools/qhash.h:766
#8  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x96b070, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=false) at itemviews/qsortfilterproxymodel.cpp:946
#9  0x00007fea4177be63 in QSortFilterProxyModelPrivate::source_items_inserted (this=0x96b070, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:743
#10 0x00007fea4177c3ef in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x94ec10, source_parent=..., start=9827792, end=11811504) at itemviews/qsortfilterproxymodel.cpp:1278
#11 0x00007fea4177e30c in QSortFilterProxyModel::qt_metacall (this=0x95f600, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24dbd210) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:135
#12 0x000000000041d590 in TodoMetadataModel::qt_metacall (this=0x94ec10, _c=15677360, _id=9827792, _a=0xb43ab0) at /home/hook/tmp_builds/zanshin/build/src/moc_todometadatamodel.cpp:72
#13 0x00007fea40307a1f in QMetaObject::activate (sender=0x95f5d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xb43ab0) at kernel/qobject.cpp:3278
#14 0x00007fea403527c4 in QAbstractItemModel::rowsInserted (this=0x94ec10, _t1=<value optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#15 0x00007fea402ea9b7 in QAbstractItemModel::endInsertRows (this=0x95f5d0) at kernel/qabstractitemmodel.cpp:2412
#16 0x00007fea42070670 in Akonadi::EntityTreeModelPrivate::monitoredItemLinked (this=<value optimized out>, item=..., collection=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/entitytreemodel_p.cpp:1033
#17 0x00007fea42061c75 in Akonadi::EntityTreeModel::qt_metacall (this=0x95f5d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24dbd4d0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/entitytreemodel.moc:161
#18 0x000000000041e700 in TodoModel::qt_metacall (this=0x94ec10, _c=15677360, _id=9827792, _a=0xb43ab0) at /home/hook/tmp_builds/zanshin/build/src/moc_todomodel.cpp:78
#19 0x00007fea40307a1f in QMetaObject::activate (sender=0x9667f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xb43ab0) at kernel/qobject.cpp:3278
#20 0x00007fea420b55ea in Akonadi::Monitor::itemLinked (this=0x94ec10, _t1=<value optimized out>, _t2=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/monitor.moc:197
#21 0x00007fea420b85b7 in Akonadi::MonitorPrivate::emitItemNotification (this=0x95f4a0, msg=..., item=<value optimized out>, collection=<value optimized out>, collectionDest=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:462
#22 0x00007fea420b9bc3 in Akonadi::MonitorPrivate::emitNotification (this=0x95f4a0, msg=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:270
#23 0x00007fea4201e921 in Akonadi::ChangeRecorderPrivate::emitNotification(Akonadi::NotificationMessage const&) () from /usr/lib64/libakonadi-kde.so.4
#24 0x00007fea420b916a in Akonadi::MonitorPrivate::dataAvailable (this=0x95f4a0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:287
#25 0x00007fea420b5745 in Akonadi::Monitor::qt_metacall (this=0x9667f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24dbda70) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/monitor.moc:156
#26 0x00007fea4201e608 in Akonadi::ChangeRecorder::qt_metacall (this=0x94ec10, _c=15677360, _id=9827792, _a=0xb43ab0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/changerecorder.moc:72
#27 0x00007fea40307a1f in QMetaObject::activate (sender=0x95f500, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xb43ab0) at kernel/qobject.cpp:3278
#28 0x00007fea4201f317 in Akonadi::EntityCache<Akonadi::Collection, Akonadi::CollectionFetchJob, Akonadi::CollectionFetchScope>::fetchResult(KJob*) () from /usr/lib64/libakonadi-kde.so.4
#29 0x00007fea4205ac63 in Akonadi::EntityCacheBase::qt_metacall (this=0x95f500, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24dbdc80) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/entitycache_p.moc:77
#30 0x00007fea40307a1f in QMetaObject::activate (sender=0xe10ef0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xb43ab0) at kernel/qobject.cpp:3278
#31 0x00007fea409dd932 in KJob::result (this=0x94ec10, _t1=0xe10ef0) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3_build/kdecore/kjob.moc:194
#32 0x00007fea409ddbd0 in KJob::emitResult (this=0xe10ef0) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdecore/jobs/kjob.cpp:312
#33 0x00007fea420abf39 in delayedEmitResult (this=0xe10ef0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xea6860) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/job.cpp:144
#34 Akonadi::Job::qt_metacall (this=0xe10ef0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xea6860) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/job.moc:91
#35 0x00007fea4202c7a5 in Akonadi::CollectionFetchJob::qt_metacall (this=0x94ec10, _c=15677360, _id=9827792, _a=0xb43ab0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/collectionfetchjob.moc:73
#36 0x00007fea40301ace in QObject::event (this=0xe10ef0, e=0x94ec10) at kernel/qobject.cpp:1217
#37 0x00007fea411bf8dc in QApplicationPrivate::notify_helper (this=0x809210, receiver=0xe10ef0, e=0xf0c230) at kernel/qapplication.cpp:4462
#38 0x00007fea411c4d7d in QApplication::notify (this=0x7fff24dbe770, receiver=0xe10ef0, e=0xf0c230) at kernel/qapplication.cpp:4341
#39 0x00007fea42617276 in KApplication::notify (this=0x7fff24dbe770, receiver=0xe10ef0, event=0xf0c230) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#40 0x00007fea402efd3b in QCoreApplication::notifyInternal (this=0x7fff24dbe770, receiver=0xe10ef0, event=0xf0c230) at kernel/qcoreapplication.cpp:731
#41 0x00007fea402f2cc1 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x7eb350) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x7eb350) at kernel/qcoreapplication.cpp:1372
#43 0x00007fea4031c2e3 in sendPostedEvents (s=0x80b9c0) at kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x80b9c0) at kernel/qeventdispatcher_glib.cpp:277
#45 0x00007fea3c50ffa1 in g_main_dispatch (context=0x80b8e0) at gmain.c:2440
#46 g_main_context_dispatch (context=0x80b8e0) at gmain.c:3013
#47 0x00007fea3c514638 in g_main_context_iterate (context=0x80b8e0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3091
#48 0x00007fea3c5147ec in g_main_context_iteration (context=0x80b8e0, may_block=1) at gmain.c:3154
#49 0x00007fea4031be23 in QEventDispatcherGlib::processEvents (this=0x7eaf50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#50 0x00007fea41271cbe in QGuiEventDispatcherGlib::processEvents (this=0x94ec10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007fea402eea92 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#52 0x00007fea402eee74 in QEventLoop::exec (this=0x7fff24dbe6b0, flags=) at kernel/qeventloop.cpp:201
#53 0x00007fea402f2eeb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#54 0x000000000041f7d3 in main (argc=<value optimized out>, argv=<value optimized out>) at /home/hook/tmp_builds/zanshin/src/main.cpp:108

Reported using DrKonqi
Comment 1 Matija Šuklje 2011-06-27 21:36:07 UTC
Also I noticed that a few seconds before it crashes all the resources in the list go blank (text and icon disappears, but they still take the space), while (some of) the Projects stay.
Comment 2 Matija Šuklje 2011-06-28 06:02:36 UTC
I managed to crash it in the same manner again by just manually syncinc Nepomuk Tags (for KMail) in Akonadi Console.

This crashed both KOntact immediately and Zenshin as described above.
Comment 3 Matija Šuklje 2011-06-28 08:31:23 UTC
Created attachment 61398 [details]
console output

Console output from start to crash.
Comment 4 Matija Šuklje 2011-06-28 09:00:18 UTC
I can reproduce the same in Kontact/KOrganizer 4.6.0.
Comment 5 Kevin Ottens 2011-07-07 22:15:24 UTC
For the record, from your description it sounds like something not specific to Zanshin (as you experience similar issues with korganizer apparently). When korganizer crashes, that would be useful to have its backtrace as well.

Also your backtrace seems incomplete, it stops at frame 6 would be useful to have a complete one, I guess you're not running a debug build right now.

Last but not least, I've been unable to reproduce that behavior so far. It sounds like we miss a piece of the puzzle at the moment to go further.

If you get korganizer backtrace, and more complete zanshin backtrace, or more precise information to reproduce reliably, please let us know.
Comment 6 Matija Šuklje 2011-07-08 14:51:54 UTC
I'll try to get a better backtrace soon and upload it.
Comment 7 Matija Šuklje 2011-07-08 22:34:34 UTC
OK, I here's how I can replicate the issue using Kontact (Zanshin is running as well):

1) edited an existing ToDo in Kontact and added a category to it (it didn't have one before)
*** at this point the resources disappeared from the resource list in Kontact's calendar view ***
2) repeated step 1) a few times;
*** at this point Zanshin crashed, but not relevant for what I was testing ***
3) refreshed my IMAP folders in KMail (could be unrelated);
4) edited an existing ToDo in Kontact and changed its title;
*** at this point Kontact stopped being responsive and started to consume 100% of CPU***
5) waited for an hour or so;
6) put it out of its misery by killing Kontact.


Managed to replicate it as well by running just Kontact and:
1) edited some titles of ToDos;
2) changed the category of some ToDos;
3) deleted two ToDos;
*** Kontact starts eating up 100% CPU now ***
4) waited for 10 minutes or so;
5) killed Kontact with SIGSEGV to get a backtrace

Note: in the first example I edited only the Kolab resource and in the second example only a local resource. Also in the second example I didn't look when the resource list got garbled.

So, it seems it's not a Zanshin(-only) thing, but could be a lower level problem. I don't know what causes it yet though :\
Comment 8 Matija Šuklje 2011-07-08 22:36:25 UTC
Kontact's backtrace from example no. 2 in comment #7:

Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa45c39b760 (LWP 12813))]

Thread 2 (Thread 0x7fa444c3b700 (LWP 12816)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa458df288d in WTF::TCMalloc_PageHeap::scavengerThread (this=<value optimized out>) at wtf/FastMalloc.cpp:2378
#2  0x00007fa458df2999 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fa4595a6f34) at wtf/FastMalloc.cpp:1497
#3  0x00007fa454791c1a in start_thread (arg=<value optimized out>) at pthread_create.c:301
#4  0x00007fa4598e6eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fa45c39b760 (LWP 12813)):
[KCrash Handler]
#6  0x00007fa45b712d13 in QHash<QPersistentModelIndex, int>::findNode (this=0x33daee0, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#7  0x00007fa45b712e38 in QHash<QPersistentModelIndex, int>::remove (this=0x33daee0, akey=...) at /usr/include/qt4/QtCore/qhash.h:789
#8  0x00007fa45b731bea in eraseRight (this=0x33dae90, start=<value optimized out>, end=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/itemviews/kbihash_p.h:216
#9  KSelectionProxyModelPrivate::removeFirstChildMappings (this=0x33dae90, start=<value optimized out>, end=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/itemviews/kselectionproxymodel.cpp:1538
#10 0x00007fa45b738550 in KSelectionProxyModelPrivate::endRemoveRows (this=0x33dae90, sourceParent=<value optimized out>, proxyStart=<value optimized out>, proxyEnd=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/itemviews/kselectionproxymodel.cpp:1176
#11 0x00007fa45b7386cd in KSelectionProxyModelPrivate::sourceRowsRemoved (this=0x33dae90, parent=..., start=176, end=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/itemviews/kselectionproxymodel.cpp:1209
#12 0x00007fa45b73f0fe in KSelectionProxyModel::qt_metacall (this=0x33dad60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff609e79a0) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3_build/kdeui/moc_kselectionproxymodel.cpp:126
#13 0x00007fa45a013a1f in QMetaObject::activate (sender=0x3395e20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x27fd850) at kernel/qobject.cpp:3278
#14 0x00007fa45a05e724 in QAbstractItemModel::rowsRemoved (this=0x33daee0, _t1=<value optimized out>, _t2=176, _t3=176) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#15 0x00007fa459ff5817 in QAbstractItemModel::endRemoveRows (this=0x3395e20) at kernel/qabstractitemmodel.cpp:2466
#16 0x00007fa456bd8252 in Akonadi::EntityTreeModelPrivate::monitoredItemRemoved (this=<value optimized out>, item=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/entitytreemodel_p.cpp:930
#17 0x00007fa456bccc14 in Akonadi::EntityTreeModel::qt_metacall (this=0x3395e20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff609e7c80) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/entitytreemodel.moc:158
#18 0x00007fa45a013a1f in QMetaObject::activate (sender=0x33947b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x27fd850) at kernel/qobject.cpp:3278
#19 0x00007fa456c20615 in Akonadi::Monitor::itemRemoved (this=0x33daee0, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/monitor.moc:190
#20 0x00007fa456c23584 in Akonadi::MonitorPrivate::emitItemNotification (this=0x33947d0, msg=..., item=<value optimized out>, collection=<value optimized out>, collectionDest=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:457
#21 0x00007fa456c24bc3 in Akonadi::MonitorPrivate::emitNotification (this=0x33947d0, msg=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:270
#22 0x00007fa456b89921 in Akonadi::ChangeRecorderPrivate::emitNotification(Akonadi::NotificationMessage const&) () from /usr/lib64/libakonadi-kde.so.4
#23 0x00007fa456c2408d in Akonadi::MonitorPrivate::dispatchNotifications (this=0x33947d0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:212
#24 0x00007fa456c26878 in Akonadi::MonitorPrivate::slotNotify (this=0x33947d0, msgs=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3/akonadi/monitor_p.cpp:378
#25 0x00007fa456b8cb82 in Akonadi::ChangeRecorderPrivate::slotNotify(QList<Akonadi::NotificationMessage> const&) () from /usr/lib64/libakonadi-kde.so.4
#26 0x00007fa456c209d5 in Akonadi::Monitor::qt_metacall (this=0x33947b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff609e82c0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/monitor.moc:155
#27 0x00007fa456b89608 in Akonadi::ChangeRecorder::qt_metacall (this=0x33daee0, _c=41932880, _id=9, _a=0x27fd850) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/changerecorder.moc:72
#28 0x00007fa45a013a1f in QMetaObject::activate (sender=0x3395490, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x27fd850) at kernel/qobject.cpp:3278
#29 0x00007fa456c94f82 in OrgFreedesktopAkonadiNotificationSourceInterface::notify (this=0x33daee0, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/notificationsourceinterface.moc:91
#30 0x00007fa456c950b6 in OrgFreedesktopAkonadiNotificationSourceInterface::qt_metacall (this=0x3395490, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff609e83d0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.3/work/kdepimlibs-4.6.3_build/akonadi/notificationsourceinterface.moc:77
#31 0x00007fa456f3c8d9 in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#32 0x00007fa456f4660f in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#33 0x00007fa45a00dace in QObject::event (this=0x3395490, e=0x33daee0) at kernel/qobject.cpp:1217
#34 0x00007fa45a9f58dc in QApplicationPrivate::notify_helper (this=0x17e9ea0, receiver=0x3395490, e=0x550a3b0) at kernel/qapplication.cpp:4462
#35 0x00007fa45a9fad7d in QApplication::notify (this=0x7fff609e9080, receiver=0x3395490, e=0x550a3b0) at kernel/qapplication.cpp:4341
#36 0x00007fa45b74f276 in KApplication::notify (this=0x7fff609e9080, receiver=0x3395490, event=0x550a3b0) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#37 0x00007fa459ffbd3b in QCoreApplication::notifyInternal (this=0x7fff609e9080, receiver=0x3395490, event=0x550a3b0) at kernel/qcoreapplication.cpp:731
#38 0x00007fa459ffecc1 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x17c1380) at kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x17c1380) at kernel/qcoreapplication.cpp:1372
#40 0x00007fa45a0282e3 in sendPostedEvents (s=0x17ebdc0) at kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x17ebdc0) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007fa454238fa1 in g_main_dispatch (context=0x17ebce0) at gmain.c:2440
#43 g_main_context_dispatch (context=0x17ebce0) at gmain.c:3013
#44 0x00007fa45423d638 in g_main_context_iterate (context=0x17ebce0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3091
#45 0x00007fa45423d7ec in g_main_context_iteration (context=0x17ebce0, may_block=1) at gmain.c:3154
#46 0x00007fa45a027e23 in QEventDispatcherGlib::processEvents (this=0x17c0f80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#47 0x00007fa45aaa7cbe in QGuiEventDispatcherGlib::processEvents (this=0x33daee0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007fa459ffaa92 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#49 0x00007fa459ffae74 in QEventLoop::exec (this=0x7fff609e8fc0, flags=) at kernel/qeventloop.cpp:201
#50 0x00007fa459ffeeeb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#51 0x0000000000404149 in main (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/kontact-4.6.0/work/kontact-4.6.0/kontact/src/main.cpp:218
Comment 9 Kevin Ottens 2011-07-09 10:41:41 UTC
As a first approximation it looks like an issue in libakonadi, could be in the selection proxy model though.
Comment 10 Matija Šuklje 2011-08-02 19:50:35 UTC
Upgraded to:
 * Zanshin 0.2_beta2
 * KDE 4.7.0
 * KDEPIM 4.7.0 (of course)
 * akonadi-server 1.6.0

...and now the bug seems to be gone. I'm resolving it as FIXED and will reopen it if I manage to somehow trigger it.
Comment 11 Matija Šuklje 2012-01-18 01:31:27 UTC
Possible related bugs: bug 291829, bug 276451