Bug 277822 - Kontact crashes when selecting calendar
Summary: Kontact crashes when selecting calendar
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: libakonadi (show other bugs)
Version: 4.7
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 287537 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-15 07:52 UTC by Georg Greve
Modified: 2017-01-07 21:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Greve 2011-07-15 07:52:35 UTC
Application: kontact (4.7 rc2)
KDE Platform Version: 4.6.95 (4.7 RC2)
Qt Version: 4.8.0
Operating System: Linux 2.6.38.8-35.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

I selected the calendar.

Calendar starts to build up the view, but Kontact crashes before it gets very far.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f2df9f98860 (LWP 2726))]

Thread 2 (Thread 0x7f2deeef8700 (LWP 2727)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003fa497fa6c in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x0000003fa497fb99 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x0000003a21607af1 in start_thread (arg=0x7f2deeef8700) at pthread_create.c:305
#4  0x0000003a20edfb7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f2df9f98860 (LWP 2726)):
[KCrash Handler]
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x41e3140, source_parent=..., parent_mapping=0x59d6530, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=false) at itemviews/qsortfilterproxymodel.cpp:948
#7  0x0000003f9c5613f4 in QSortFilterProxyModelPrivate::source_items_inserted (this=0x41e3140, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:745
#8  0x0000003f9c5618ef in QSortFilterProxyModelPrivate::_q_sourceRowsInserted (this=0x41e3140, source_parent=<optimized out>, start=<optimized out>, end=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:1280
#9  0x0000003a2bf88d01 in QMetaObject::activate (sender=0x5a265b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa82e2860) at kernel/qobject.cpp:3574
#10 0x0000003a2bfd47c4 in QAbstractItemModel::rowsInserted (this=<optimized out>, _t1=<optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#11 0x0000003a2bf6f2ed in QAbstractItemModel::endInsertRows (this=0x5a265b0) at kernel/qabstractitemmodel.cpp:2412
#12 0x00000033008fb3c8 in Akonadi::EntityTreeModelPrivate::collectionsFetched (this=0x5ad18b0, collections=<optimized out>) at /usr/src/debug/kdepimlibs-4.6.95/akonadi/entitytreemodel_p.cpp:469
#13 0x00000033008edde7 in Akonadi::EntityTreeModel::qt_metacall (this=0x5a265b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa82e2c80) at /usr/src/debug/kdepimlibs-4.6.95/x86_64-redhat-linux-gnu/akonadi/entitytreemodel.moc:152
#14 0x0000003a2bf88efd in QMetaObject::activate (sender=0x26f7250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa82e2c80) at kernel/qobject.cpp:3593
#15 0x00000033008b1602 in Akonadi::CollectionFetchJob::collectionsReceived (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/kdepimlibs-4.6.95/x86_64-redhat-linux-gnu/akonadi/collectionfetchjob.moc:95
#16 0x00000033008b1b8b in timeout (this=0x5a00500) at /usr/src/debug/kdepimlibs-4.6.95/akonadi/collectionfetchjob.cpp:76
#17 Akonadi::CollectionFetchJob::qt_metacall (this=<optimized out>, _c=<optimized out>, _id=2, _a=0x7fffa82e2e00) at /usr/src/debug/kdepimlibs-4.6.95/x86_64-redhat-linux-gnu/akonadi/collectionfetchjob.moc:82
#18 0x0000003a2bf88efd in QMetaObject::activate (sender=0x26f7250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa82e2e00) at kernel/qobject.cpp:3593
#19 0x00000032fcd3ede2 in KJob::result (this=<optimized out>, _t1=0x26f7250) at /usr/src/debug/kdelibs-4.6.95/x86_64-redhat-linux-gnu/kdecore/kjob.moc:194
#20 0x00000032fcd3ee20 in KJob::emitResult (this=0x26f7250) at /usr/src/debug/kdelibs-4.6.95/kdecore/jobs/kjob.cpp:312
#21 0x0000003300932dcd in Akonadi::Job::qt_metacall (this=0x26f7250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x41bbae0) at /usr/src/debug/kdepimlibs-4.6.95/x86_64-redhat-linux-gnu/akonadi/job.moc:91
#22 0x00000033008b1a85 in Akonadi::CollectionFetchJob::qt_metacall (this=0x26f7250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x41bbae0) at /usr/src/debug/kdepimlibs-4.6.95/x86_64-redhat-linux-gnu/akonadi/collectionfetchjob.moc:75
#23 0x0000003a2bf8e3d6 in QObject::event (this=0x26f7250, e=<optimized out>) at kernel/qobject.cpp:1194
#24 0x0000003f9bfc41b4 in notify_helper (e=0x40dc960, receiver=0x26f7250, this=0x745b90) at kernel/qapplication.cpp:4495
#25 QApplicationPrivate::notify_helper (this=0x745b90, receiver=0x26f7250, e=0x40dc960) at kernel/qapplication.cpp:4467
#26 0x0000003f9bfc9043 in QApplication::notify (this=0x7fffa82e3810, receiver=0x26f7250, e=0x40dc960) at kernel/qapplication.cpp:4356
#27 0x00000032fd44c066 in KApplication::notify (this=0x7fffa82e3810, receiver=0x26f7250, event=0x40dc960) at /usr/src/debug/kdelibs-4.6.95/kdeui/kernel/kapplication.cpp:311
#28 0x0000003a2bf7508c in QCoreApplication::notifyInternal (this=0x7fffa82e3810, receiver=0x26f7250, event=0x40dc960) at kernel/qcoreapplication.cpp:833
#29 0x0000003a2bf7864c in sendEvent (event=0x40dc960, receiver=0x26f7250) at kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x716f30) at kernel/qcoreapplication.cpp:1470
#31 0x0000003a2bfa3683 in sendPostedEvents () at kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=0x74bdc0) at kernel/qeventdispatcher_glib.cpp:279
#33 0x0000003a23e427ed in g_main_dispatch (context=0x74b0e0) at gmain.c:2441
#34 g_main_context_dispatch (context=0x74b0e0) at gmain.c:3014
#35 0x0000003a23e42fc8 in g_main_context_iterate (context=0x74b0e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#36 0x0000003a23e4325c in g_main_context_iteration (context=0x74b0e0, may_block=1) at gmain.c:3155
#37 0x0000003a2bfa3aaf in QEventDispatcherGlib::processEvents (this=0x7183f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#38 0x0000003f9c066a3e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#39 0x0000003a2bf741c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x0000003a2bf74417 in QEventLoop::exec (this=0x7fffa82e37a0, flags=...) at kernel/qeventloop.cpp:204
#41 0x0000003a2bf78947 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1105
#42 0x00000000004037b9 in ?? ()
#43 0x0000003a20e2139d in __libc_start_main (main=0x402cd0, argc=1, ubp_av=0x7fffa82e3e38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa82e3e28) at libc-start.c:226
#44 0x0000000000403d11 in _start ()

Possible duplicates by query: bug 276643, bug 276449, bug 246923.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-11-29 13:54:51 UTC
*** Bug 287537 has been marked as a duplicate of this bug. ***
Comment 2 Denis Kurz 2016-09-24 20:31:03 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 3 Denis Kurz 2017-01-07 21:50:57 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.