Bug 286977 - Dolphin crashed after cancelling an undo
Summary: Dolphin crashed after cancelling an undo
Status: RESOLVED DUPLICATE of bug 222540
Alias: None
Product: kio
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 315068 327056 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-19 06:56 UTC by Mandy Slaughter
Modified: 2014-05-04 15:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mandy Slaughter 2011-11-19 06:56:07 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I moved 4 files (~175MB each) from one folder on another computer on my local network to another folder on the same computer. After the move had completed, I used ctrl+z to undo the move; this caused Dolphin to become very slow to respond so I cancelled the process from the Notifications and Jobs menu. After a few moments, Dolphin crashed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f78aacf2780 (LWP 4797))]

Thread 3 (Thread 0x7f789840e700 (LWP 4798)):
#0  idleTimerSourcePrepare (source=<optimized out>, timeout=0x7f789840dc3c) at kernel/qeventdispatcher_glib.cpp:207
#1  0x00007f78a2cf6ff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f78a2cf7dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f78a2cf8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f78a6a0ff3e in QEventDispatcherGlib::processEvents (this=0xa804a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f78a69e3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f78a69e3ef7 in QEventLoop::exec (this=0x7f789840ddd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f78a68fb27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f78a69c6cbf in QInotifyFileSystemWatcherEngine::run (this=0xa36200) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f78a68fdd05 in QThreadPrivate::start (arg=0xa36200) at thread/qthread_unix.cpp:331
#10 0x00007f78a31c9efc in start_thread (arg=0x7f789840e700) at pthread_create.c:304
#11 0x00007f78aa5d289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f78953c3700 (LWP 4801)):
#0  0x00007f78aa5c6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f78a2cf7f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f78a2cf8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f78a6a0ff3e in QEventDispatcherGlib::processEvents (this=0xc34450, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f78a69e3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f78a69e3ef7 in QEventLoop::exec (this=0x7f78953c2dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f78a68fb27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f78a69c6cbf in QInotifyFileSystemWatcherEngine::run (this=0xf4c790) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f78a68fdd05 in QThreadPrivate::start (arg=0xf4c790) at thread/qthread_unix.cpp:331
#9  0x00007f78a31c9efc in start_thread (arg=0x7f78953c3700) at pthread_create.c:304
#10 0x00007f78aa5d289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f78aacf2780 (LWP 4797)):
[KCrash Handler]
#6  isSignalConnected (signal_index=6, this=0x0) at kernel/qobject_p.h:221
#7  QMetaObject::activate (sender=0x11a8250, m=<optimized out>, local_signal_index=4, argv=0x7fff36d3a860) at kernel/qobject.cpp:3201
#8  0x00007f78a6e4a6e1 in KJob::description (this=<optimized out>, _t1=0x11a8250, _t2=<optimized out>, _t3=<optimized out>, _t4=<optimized out>) at ./kjob.moc:201
#9  0x00007f78a85fea38 in emitMoving (dest=..., src=..., this=0x11a8250) at ../../kio/kio/fileundomanager.cpp:121
#10 KIO::FileUndoManagerPrivate::stepMovingFiles (this=0x9efdd0) at ../../kio/kio/fileundomanager.cpp:540
#11 0x00007f78a8600ec4 in KIO::FileUndoManagerPrivate::undoStep (this=0x9efdd0) at ../../kio/kio/fileundomanager.cpp:463
#12 0x00007f78a8601093 in KIO::FileUndoManagerPrivate::slotResult (this=0x9efdd0, job=<optimized out>) at ../../kio/kio/fileundomanager.cpp:445
#13 0x00007f78a860143c in KIO::FileUndoManagerPrivate::qt_metacall (this=0x9efdd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff36d3aed0) at ./fileundomanager_p.moc:160
#14 0x00007f78a69f7eba in QMetaObject::activate (sender=0x13e9780, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff36d3aed0) at kernel/qobject.cpp:3278
#15 0x00007f78a6e4a5b2 in KJob::result (this=<optimized out>, _t1=0x13e9780) at ./kjob.moc:194
#16 0x00007f78a6e4a5f0 in KJob::emitResult (this=0x13e9780) at ../../kdecore/jobs/kjob.cpp:312
#17 0x00007f78a861ba4a in KIO::FileCopyJob::slotResult (this=0x13e9780, job=0xea3780) at ../../kio/kio/job.cpp:2440
#18 0x00007f78a861b7f0 in KIO::FileCopyJob::qt_metacall (this=0x13e9780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff36d3b040) at ./jobclasses.moc:724
#19 0x00007f78a69f7eba in QMetaObject::activate (sender=0xea3780, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff36d3b040) at kernel/qobject.cpp:3278
#20 0x00007f78a6e4a5b2 in KJob::result (this=<optimized out>, _t1=0xea3780) at ./kjob.moc:194
#21 0x00007f78a6e4a5f0 in KJob::emitResult (this=0xea3780) at ../../kdecore/jobs/kjob.cpp:312
#22 0x00007f78a86142c4 in KIO::SimpleJob::slotFinished (this=0xea3780) at ../../kio/kio/job.cpp:494
#23 0x00007f78a8617a01 in KIO::SimpleJob::qt_metacall (this=0xea3780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff36d3b200) at ./jobclasses.moc:171
#24 0x00007f78a69f7eba in QMetaObject::activate (sender=0x1034410, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#25 0x00007f78a86c09c1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#26 0x00007f78a86bd875 in KIO::SlaveInterface::dispatch (this=0x1034410) at ../../kio/kio/slaveinterface.cpp:88
#27 0x00007f78a86b0ace in KIO::Slave::gotInput (this=0x1034410) at ../../kio/kio/slave.cpp:344
#28 0x00007f78a86b122c in KIO::Slave::qt_metacall (this=0x1034410, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff36d3b630) at ./slave.moc:82
#29 0x00007f78a69f7eba in QMetaObject::activate (sender=0x146f450, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#30 0x00007f78a85e53a7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#31 KIO::ConnectionPrivate::dequeue (this=0x12719b0) at ../../kio/kio/connection.cpp:71
#32 0x00007f78a85e544d in KIO::Connection::qt_metacall (this=0x146f450, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x12c2d40) at ./connection.moc:79
#33 0x00007f78a69fba5e in QObject::event (this=0x146f450, e=<optimized out>) at kernel/qobject.cpp:1217
#34 0x00007f78a73e5424 in notify_helper (e=0x12f5af0, receiver=0x146f450, this=0x8b0c90) at kernel/qapplication.cpp:4486
#35 QApplicationPrivate::notify_helper (this=0x8b0c90, receiver=0x146f450, e=0x12f5af0) at kernel/qapplication.cpp:4458
#36 0x00007f78a73ea291 in QApplication::notify (this=0x7fff36d3bee0, receiver=0x146f450, e=0x12f5af0) at kernel/qapplication.cpp:4365
#37 0x00007f78a80f9126 in KApplication::notify (this=0x7fff36d3bee0, receiver=0x146f450, event=0x12f5af0) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007f78a69e4afc in QCoreApplication::notifyInternal (this=0x7fff36d3bee0, receiver=0x146f450, event=0x12f5af0) at kernel/qcoreapplication.cpp:787
#39 0x00007f78a69e851f in sendEvent (event=0x12f5af0, receiver=0x146f450) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x892350) at kernel/qcoreapplication.cpp:1428
#41 0x00007f78a6a0fa73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#43 0x00007f78a2cf7a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f78a2cf8258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f78a2cf8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f78a6a0fed6 in QEventDispatcherGlib::processEvents (this=0x893a00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#47 0x00007f78a748d07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007f78a69e3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#49 0x00007f78a69e3ef7 in QEventLoop::exec (this=0x7fff36d3be70, flags=...) at kernel/qeventloop.cpp:201
#50 0x00007f78a69e8789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#51 0x00007f78aa8db269 in kdemain (argc=6, argv=0x7fff36d3c3c8) at ../../../dolphin/src/main.cpp:85
#52 0x00007f78aa51230d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=6, ubp_av=0x7fff36d3c3c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff36d3c3b8) at libc-start.c:226
#53 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-24 12:44:29 UTC
Duplicate of/related to bug 222540.
Comment 2 Frank Reininghaus 2013-02-13 14:18:02 UTC
*** Bug 315068 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2013-11-03 00:43:47 UTC
*** Bug 327056 has been marked as a duplicate of this bug. ***
Comment 4 Dawit Alemayehu 2014-05-04 15:06:13 UTC

*** This bug has been marked as a duplicate of bug 222540 ***