Bug 222540 - dolphin crashed after canceling a undo-action
Summary: dolphin crashed after canceling a undo-action
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: general (show other bugs)
Version: 5.40.0
Platform: Unlisted Binaries Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 234913 247996 271644 286721 286977 311388 387842 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-13 14:22 UTC by Per (phobie)
Modified: 2021-07-20 04:33 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.42 KB, text/plain)
2013-12-27 12:06 UTC, Per (phobie)
Details
New crash information added by DrKonqi (7.85 KB, text/plain)
2014-05-21 21:35 UTC, Dominique
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Per (phobie) 2010-01-13 14:22:15 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-3.slh.1-sidux-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
I moved a bigger file from a local ext3 partition to a samba-share mounted via autofs. After the job had finished I clicked Edit->Undo in dolphin. Waited some seconds and clicked on the stop-icon in te kde-notify (knotify?) area. Dolphin crashed and the notify-area has been emptied out. However the undo-action succeeded silently in background.

I was able to reproduce the crash by moving a other file from one local ext3 partition to an other. So this is not related to network/smb/autofs.

BTW the undo-move-action shows no progress in the progress-bar of the notify-area!

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5823e73750 (LWP 3354))]

Thread 2 (Thread 0x7f580cc08910 (LWP 4931)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f5811e0fdd1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f581c0c173a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f58201036dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5823e73750 (LWP 3354)):
[KCrash Handler]
#5  KJob::emitResult (this=0x17d4c20) at ../../kdecore/jobs/kjob.cpp:300
#6  0x00007f582389a110 in KIO::UndoJob::emitResult (this=0xf37990) at ../../kio/kio/fileundomanager.cpp:125
#7  KIO::FileUndoManagerPrivate::stepRemovingDirectories (this=0xf37990) at ../../kio/kio/fileundomanager.cpp:591
#8  0x00007f582389afe0 in KIO::FileUndoManagerPrivate::undoStep (this=0xf37990) at ../../kio/kio/fileundomanager.cpp:462
#9  0x00007f582389b21d in KIO::FileUndoManagerPrivate::slotResult (this=0xf37990, job=0x18526a0) at ../../kio/kio/fileundomanager.cpp:438
#10 0x00007f582389b5bc in KIO::FileUndoManagerPrivate::qt_metacall (this=0xf37990, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb95ec4f0) at ./fileundomanager_p.moc:148
#11 0x00007f5820802df2 in QMetaObject::activate (sender=0x18526a0, from_signal_index=<value optimized out>, to_signal_index=7, argv=0x20e60) at kernel/qobject.cpp:3112
#12 0x00007f5821a5d1b2 in KJob::result (this=0x17d4c20, _t1=0x18526a0) at ./kjob.moc:188
#13 0x00007f5821a5d52f in KJob::emitResult (this=0x18526a0) at ../../kdecore/jobs/kjob.cpp:304
#14 0x00007f58238b8d6b in KIO::FileCopyJob::slotResult (this=0x18526a0, job=0x1719880) at ../../kio/kio/job.cpp:2202
#15 0x00007f58238b94a0 in KIO::FileCopyJob::qt_metacall (this=0x18526a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb95ec680) at ./jobclasses.moc:673
#16 0x00007f5820802df2 in QMetaObject::activate (sender=0x1719880, from_signal_index=<value optimized out>, to_signal_index=7, argv=0x20e60) at kernel/qobject.cpp:3112
#17 0x00007f5821a5d1b2 in KJob::result (this=0x17d4c20, _t1=0x1719880) at ./kjob.moc:188
#18 0x00007f5821a5d52f in KJob::emitResult (this=0x1719880) at ../../kdecore/jobs/kjob.cpp:304
#19 0x00007f58238b0c33 in KIO::SimpleJob::slotFinished (this=0x1719880) at ../../kio/kio/job.cpp:477
#20 0x00007f58238af6f1 in KIO::SimpleJob::qt_metacall (this=0x1719880, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb95ec8a0) at ./jobclasses.moc:159
#21 0x00007f5820802df2 in QMetaObject::activate (sender=0x19364c0, from_signal_index=<value optimized out>, to_signal_index=8, argv=0x20e60) at kernel/qobject.cpp:3112
#22 0x00007f5823972921 in KIO::SlaveInterface::dispatch (this=0x19364c0, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#23 0x00007f582396f1d3 in KIO::SlaveInterface::dispatch (this=0x19364c0) at ../../kio/kio/slaveinterface.cpp:91
#24 0x00007f582396210d in KIO::Slave::gotInput (this=0x19364c0) at ../../kio/kio/slave.cpp:322
#25 0x00007f582396422c in KIO::Slave::qt_metacall (this=0x19364c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb95ecc50) at ./slave.moc:76
#26 0x00007f5820802df2 in QMetaObject::activate (sender=0x17ad950, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x20e60) at kernel/qobject.cpp:3112
#27 0x00007f582387dfb7 in KIO::ConnectionPrivate::dequeue (this=0x17b67c0) at ../../kio/kio/connection.cpp:82
#28 0x00007f582387e0dd in KIO::Connection::qt_metacall (this=0x17ad950, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1778d30) at ./connection.moc:73
#29 0x00007f58207fd6c8 in QObject::event (this=0x17ad950, e=0x18fa080) at kernel/qobject.cpp:1110
#30 0x00007f5820cbc01d in QApplicationPrivate::notify_helper (this=0xf4e640, receiver=0x17ad950, e=0x18fa080) at kernel/qapplication.cpp:4065
#31 0x00007f5820cc407a in QApplication::notify (this=0x7fffb95ed6a0, receiver=0x17ad950, e=0x18fa080) at kernel/qapplication.cpp:4030
#32 0x00007f5822015e06 in KApplication::notify (this=0x7fffb95ed6a0, receiver=0x17ad950, event=0x18fa080) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007f58207edc9c in QCoreApplication::notifyInternal (this=0x7fffb95ed6a0, receiver=0x17ad950, event=0x18fa080) at kernel/qcoreapplication.cpp:610
#34 0x00007f58207ee8e4 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0xf1e950) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xf1e950) at kernel/qcoreapplication.cpp:1247
#36 0x00007f58208167d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#38 0x00007f581c3128fe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x00007f581c3162b8 in ?? () from /lib/libglib-2.0.so.0
#40 0x00007f581c3163e0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x00007f582081639c in QEventDispatcherGlib::processEvents (this=0xf1e160, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#42 0x00007f5820d52f1f in QGuiEventDispatcherGlib::processEvents (this=0x17d4c20, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#43 0x00007f58207ec562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f58207ec934 in QEventLoop::exec (this=0x7fffb95ed5f0, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007f58207eeba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#46 0x00000000004394b5 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-15 23:50:16 UTC
*** Bug 247996 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2011-09-22 12:25:13 UTC
*** Bug 271644 has been marked as a duplicate of this bug. ***
Comment 3 Frank Reininghaus 2012-12-09 09:16:22 UTC
*** Bug 311388 has been marked as a duplicate of this bug. ***
Comment 4 Frank Reininghaus 2012-12-09 09:17:01 UTC
*** Bug 286721 has been marked as a duplicate of this bug. ***
Comment 5 Dawit Alemayehu 2013-07-07 11:41:19 UTC
*** Bug 234913 has been marked as a duplicate of this bug. ***
Comment 6 Dawit Alemayehu 2013-12-25 18:50:32 UTC
Can someone please confirm if you get the same crash in KDE 4.11.4 or higher?
Comment 7 Per (phobie) 2013-12-27 12:06:39 UTC
Created attachment 84292 [details]
New crash information added by DrKonqi

dolphin (4.11.3) on KDE Platform 4.11.3 using Qt 4.8.4

Still exists in 4.11.3.
Attached a new backtrace.
...

-- Backtrace (Reduced):
#7  0x00007f6a87575231 in KJob::description (this=this@entry=0x31b5cb0, _t1=_t1@entry=0x31b5cb0, _t2=..., _t3=..., _t4=...) at ./kjob.moc:215
#8  0x00007f6a88f2b617 in emitMoving (dest=..., src=..., this=<optimized out>) at ../../kio/kio/fileundomanager.cpp:122
#9  KIO::FileUndoManagerPrivate::stepMovingFiles (this=this@entry=0x16031d0) at ../../kio/kio/fileundomanager.cpp:542
#10 0x00007f6a88f2c82c in KIO::FileUndoManagerPrivate::undoStep (this=this@entry=0x16031d0) at ../../kio/kio/fileundomanager.cpp:464
#11 0x00007f6a88f2d246 in KIO::FileUndoManagerPrivate::slotResult (this=0x16031d0, job=<optimized out>) at ../../kio/kio/fileundomanager.cpp:446
Comment 8 Dawit Alemayehu 2014-05-04 15:06:13 UTC
*** Bug 286977 has been marked as a duplicate of this bug. ***
Comment 9 Dominique 2014-05-21 21:35:54 UTC
Created attachment 86753 [details]
New crash information added by DrKonqi

konqueror (4.8.5 (4.8.5)) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

I accidentally undid a file move back to an SFTP server, stopped the operation, attempted to relog, then crashed.

-- Backtrace (Reduced):
#7  KJob::emitResult (this=0x89f9868) at ../../kdecore/jobs/kjob.cpp:309
#8  0xb70027d3 in emitResult (this=<optimized out>) at ../../kio/kio/fileundomanager.cpp:125
#9  KIO::FileUndoManagerPrivate::stepRemovingDirectories (this=0x8674970) at ../../kio/kio/fileundomanager.cpp:598
#10 0xb7003818 in KIO::FileUndoManagerPrivate::undoStep (this=0x8674970) at ../../kio/kio/fileundomanager.cpp:469
#11 0xb70039dc in KIO::FileUndoManagerPrivate::slotResult (this=0x8674970, job=0xabd77f8) at ../../kio/kio/fileundomanager.cpp:445
Comment 10 Pascal d'Hermilly 2014-08-11 11:30:43 UTC
Application: dolphin (4.13.2)
KDE Platform Version: 4.13.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-32-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I cancelled an undo move where it was moveing files back over the sftp protocol to my local disk.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fde1a1987c0 (LWP 20062))]

Thread 4 (Thread 0x7fddfc157700 (LWP 20063)):
#0  0x00007fde19a5873d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fde10a0ac20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fde109c9b14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fde109c9f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fde109ca0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fde15ac97be in QEventDispatcherGlib::processEvents (this=0x7fddf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007fde15a9b0af in QEventLoop::processEvents (this=this@entry=0x7fddfc156de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fde15a9b3a5 in QEventLoop::exec (this=this@entry=0x7fddfc156de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fde15997c5f in QThread::exec (this=this@entry=0x147a470) at thread/qthread.cpp:537
#9  0x00007fde15a7c823 in QInotifyFileSystemWatcherEngine::run (this=0x147a470) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fde1599a32f in QThreadPrivate::start (arg=0x147a470) at thread/qthread_unix.cpp:349
#11 0x00007fde10ea9182 in start_thread (arg=0x7fddfc157700) at pthread_create.c:312
#12 0x00007fde19a6738d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fddfb7f7700 (LWP 20064)):
#0  0x00007fde19a5a03d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fde109c9fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fde109ca0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fde15ac97be in QEventDispatcherGlib::processEvents (this=0x7fddec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007fde15a9b0af in QEventLoop::processEvents (this=this@entry=0x7fddfb7f6e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fde15a9b3a5 in QEventLoop::exec (this=this@entry=0x7fddfb7f6e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fde15997c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007fde1599a32f in QThreadPrivate::start (arg=0x13ad490) at thread/qthread_unix.cpp:349
#8  0x00007fde10ea9182 in start_thread (arg=0x7fddfb7f7700) at pthread_create.c:312
#9  0x00007fde19a6738d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fddfa958700 (LWP 20065)):
#0  0x00007fde19a5a03d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fde109c9fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fde109ca0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fde15ac97be in QEventDispatcherGlib::processEvents (this=0x7fddf00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007fde15a9b0af in QEventLoop::processEvents (this=this@entry=0x7fddfa957de0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fde15a9b3a5 in QEventLoop::exec (this=this@entry=0x7fddfa957de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fde15997c5f in QThread::exec (this=this@entry=0x177c430) at thread/qthread.cpp:537
#7  0x00007fde15a7c823 in QInotifyFileSystemWatcherEngine::run (this=0x177c430) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fde1599a32f in QThreadPrivate::start (arg=0x177c430) at thread/qthread_unix.cpp:349
#9  0x00007fde10ea9182 in start_thread (arg=0x7fddfa958700) at pthread_create.c:312
#10 0x00007fde19a6738d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fde1a1987c0 (LWP 20062)):
[KCrash Handler]
#6  0x00007fde15ab0607 in isSignalConnected (signal_index=6, this=0x6000015) at kernel/qobject_p.h:237
#7  QMetaObject::activate (sender=sender@entry=0x27258f0, m=m@entry=0x7fde162b6600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff50c41ec0) at kernel/qobject.cpp:3444
#8  0x00007fde15f26801 in KJob::description (this=this@entry=0x27258f0, _t1=_t1@entry=0x27258f0, _t2=..., _t3=..., _t4=...) at ./kjob.moc:214
#9  0x00007fde178ddf67 in emitMoving (dest=..., src=..., this=<optimized out>) at ../../kio/kio/fileundomanager.cpp:122
#10 KIO::FileUndoManagerPrivate::stepMovingFiles (this=this@entry=0x1397060) at ../../kio/kio/fileundomanager.cpp:546
#11 0x00007fde178df17c in KIO::FileUndoManagerPrivate::undoStep (this=this@entry=0x1397060) at ../../kio/kio/fileundomanager.cpp:468
#12 0x00007fde178dfb96 in KIO::FileUndoManagerPrivate::slotResult (this=0x1397060, job=<optimized out>) at ../../kio/kio/fileundomanager.cpp:450
#13 0x00007fde178dff1c in KIO::FileUndoManagerPrivate::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./fileundomanager_p.moc:150
#14 0x00007fde15ab087a in QMetaObject::activate (sender=sender@entry=0x28dabc0, m=m@entry=0x7fde162b6600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff50c42220) at kernel/qobject.cpp:3539
#15 0x00007fde15f266d2 in KJob::result (this=this@entry=0x28dabc0, _t1=_t1@entry=0x28dabc0) at ./kjob.moc:207
#16 0x00007fde15f26710 in KJob::emitResult (this=this@entry=0x28dabc0) at ../../kdecore/jobs/kjob.cpp:318
#17 0x00007fde178f7fef in KIO::FileCopyJob::slotResult (this=0x28dabc0, job=0x182c3f0) at ../../kio/kio/job.cpp:2470
#18 0x00007fde15ab087a in QMetaObject::activate (sender=sender@entry=0x182c3f0, m=m@entry=0x7fde162b6600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff50c42390) at kernel/qobject.cpp:3539
#19 0x00007fde15f266d2 in KJob::result (this=this@entry=0x182c3f0, _t1=_t1@entry=0x182c3f0) at ./kjob.moc:207
#20 0x00007fde15f26710 in KJob::emitResult (this=this@entry=0x182c3f0) at ../../kdecore/jobs/kjob.cpp:318
#21 0x00007fde178f439a in KIO::SimpleJob::slotFinished (this=0x182c3f0) at ../../kio/kio/job.cpp:496
#22 0x00007fde15ab087a in QMetaObject::activate (sender=0x1c66d80, m=m@entry=0x7fde17c9d580 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#23 0x00007fde179924e3 in KIO::SlaveInterface::finished (this=<optimized out>) at ./slaveinterface.moc:184
#24 0x00007fde17993a26 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:176
#25 0x00007fde1799151e in KIO::SlaveInterface::dispatch (this=0x1c66d80) at ../../kio/kio/slaveinterface.cpp:92
#26 0x00007fde17986196 in KIO::Slave::gotInput (this=0x1c66d80) at ../../kio/kio/slave.cpp:344
#27 0x00007fde15ab087a in QMetaObject::activate (sender=0x1c667a0, m=m@entry=0x7fde17c96aa0 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#28 0x00007fde178c1b40 in KIO::Connection::readyRead (this=<optimized out>) at ./connection.moc:105
#29 0x00007fde178c2231 in KIO::ConnectionPrivate::dequeue (this=0x19848b0) at ../../kio/kio/connection.cpp:82
#30 0x00007fde15ab4c1e in QObject::event (this=0x1c667a0, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007fde1648ee2c in QApplicationPrivate::notify_helper (this=this@entry=0x1206850, receiver=receiver@entry=0x1c667a0, e=e@entry=0x295e910) at kernel/qapplication.cpp:4567
#32 0x00007fde164954a0 in QApplication::notify (this=this@entry=0x7fff50c43000, receiver=receiver@entry=0x1c667a0, e=e@entry=0x295e910) at kernel/qapplication.cpp:4353
#33 0x00007fde17199d1a in KApplication::notify (this=0x7fff50c43000, receiver=0x1c667a0, event=0x295e910) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fde15a9c4dd in QCoreApplication::notifyInternal (this=0x7fff50c43000, receiver=receiver@entry=0x1c667a0, event=event@entry=0x295e910) at kernel/qcoreapplication.cpp:953
#35 0x00007fde15a9fb3d in sendEvent (event=0x295e910, receiver=0x1c667a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x11d3120) at kernel/qcoreapplication.cpp:1577
#37 0x00007fde15a9ffe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#38 0x00007fde15ac9f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x1212580) at kernel/qeventdispatcher_glib.cpp:287
#40 0x00007fde109c9e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fde109ca048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fde109ca0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fde15ac97a1 in QEventDispatcherGlib::processEvents (this=0x11d4a00, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#44 0x00007fde16530bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fde15a9b0af in QEventLoop::processEvents (this=this@entry=0x7fff50c42ed0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fde15a9b3a5 in QEventLoop::exec (this=this@entry=0x7fff50c42ed0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fde15aa0b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#48 0x00007fde19d825e7 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#49 0x00007fde1998dec5 in __libc_start_main (main=0x4006d0, argc=5, argv=0x7fff50c43138, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff50c43128) at libc-start.c:287
#50 0x00000000004006fe in _start ()

Possible duplicates by query: bug 327056.

Rapportér til https://bugs.kde.org/
Comment 11 Julian Steinmann 2018-06-29 19:37:55 UTC
*** Bug 387842 has been marked as a duplicate of this bug. ***
Comment 12 Julian Steinmann 2018-06-29 19:39:41 UTC
This crash does apparently still exist (bug 387842 has a practically identical backtrace & uses frameworks v5.40.0), so I will move this to the correct place over at frameworks-kio.
Comment 13 Justin Zobel 2021-06-20 08:38:52 UTC
As this crash is quite old now, can you please confirm if this crash still occurs on a current version?

This bug has been set to "NEEDSINFO/WAITINGFORINFO", if you are able to update the bug report please mark it as reported when you add the new information, thank you.
Comment 14 Bug Janitor Service 2021-07-05 04:33:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 15 Bug Janitor Service 2021-07-20 04:33:36 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!