Bug 327056 - Dolphin crash after aborting "undo move" operation
Summary: Dolphin crash after aborting "undo move" operation
Status: RESOLVED DUPLICATE of bug 286977
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-02 21:31 UTC by Martin Holec
Modified: 2013-11-03 00:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holec 2013-11-02 21:31:32 UTC
Application: dolphin (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.5
Operating System: Linux 3.11.6-200.fc19.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

1. Move files between two partitions.
2. Select: Edit - Undo: Move
3. Abort move operation using notification area.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f7b8f32c8c0 (LWP 3864))]

Thread 2 (Thread 0x7f7b8385a700 (LWP 3872)):
#0  0x0000003009e86fa6 in g_mutex_get_impl (mutex=0x7f7b740009c0) at gthread-posix.c:132
#1  0x0000003009e87249 in g_mutex_lock (mutex=mutex@entry=0x7f7b740009c0) at gthread-posix.c:210
#2  0x0000003009e477a9 in g_main_context_prepare (context=context@entry=0x7f7b740009c0, priority=priority@entry=0x7f7b83859ba8) at gmain.c:3330
#3  0x0000003009e48013 in g_main_context_iterate (context=context@entry=0x7f7b740009c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3681
#4  0x0000003009e481fc in g_main_context_iteration (context=0x7f7b740009c0, may_block=1) at gmain.c:3762
#5  0x0000003e347a7166 in QEventDispatcherGlib::processEvents (this=0x7f7b740008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x0000003e34778ecf in QEventLoop::processEvents (this=this@entry=0x7f7b83859ce0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0000003e347791c5 in QEventLoop::exec (this=this@entry=0x7f7b83859ce0, flags=...) at kernel/qeventloop.cpp:204
#8  0x0000003e3467866f in QThread::exec (this=this@entry=0x146d940) at thread/qthread.cpp:536
#9  0x0000003e3475a733 in QInotifyFileSystemWatcherEngine::run (this=0x146d940) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x0000003e3467ad0f in QThreadPrivate::start (arg=0x146d940) at thread/qthread_unix.cpp:338
#11 0x0000003008a07c53 in start_thread (arg=0x7f7b8385a700) at pthread_create.c:308
#12 0x00000030082f5e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f7b8f32c8c0 (LWP 3864)):
[KCrash Handler]
#6  0x0000003e3478dd07 in isSignalConnected (signal_index=6, this=0x0) at kernel/qobject_p.h:237
#7  QMetaObject::activate (sender=sender@entry=0x302aca0, m=m@entry=0x36c88c25c0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff0074a1a0) at kernel/qobject.cpp:3452
#8  0x00000036c8532121 in KJob::description (this=this@entry=0x302aca0, _t1=_t1@entry=0x302aca0, _t2=..., _t3=..., _t4=...) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kdecore/kjob.moc:214
#9  0x00000036cb2e7fcf in emitMoving (dest=..., src=..., this=<optimized out>) at /usr/src/debug/kdelibs-4.11.2/kio/kio/fileundomanager.cpp:122
#10 KIO::FileUndoManagerPrivate::stepMovingFiles (this=this@entry=0x11343d0) at /usr/src/debug/kdelibs-4.11.2/kio/kio/fileundomanager.cpp:542
#11 0x00000036cb2e91dc in KIO::FileUndoManagerPrivate::undoStep (this=this@entry=0x11343d0) at /usr/src/debug/kdelibs-4.11.2/kio/kio/fileundomanager.cpp:464
#12 0x00000036cb2e9c06 in KIO::FileUndoManagerPrivate::slotResult (this=0x11343d0, job=<optimized out>) at /usr/src/debug/kdelibs-4.11.2/kio/kio/fileundomanager.cpp:446
#13 0x00000036cb2e9f8c in KIO::FileUndoManagerPrivate::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kio/fileundomanager_p.moc:150
#14 0x0000003e3478df78 in QMetaObject::activate (sender=sender@entry=0x249f5a0, m=m@entry=0x36c88c25c0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff0074a500) at kernel/qobject.cpp:3547
#15 0x00000036c8531ff2 in KJob::result (this=this@entry=0x249f5a0, _t1=_t1@entry=0x249f5a0) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kdecore/kjob.moc:207
#16 0x00000036c8532030 in KJob::emitResult (this=this@entry=0x249f5a0) at /usr/src/debug/kdelibs-4.11.2/kdecore/jobs/kjob.cpp:318
#17 0x00000036cb3023af in KIO::FileCopyJob::slotResult (this=0x249f5a0, job=0x3175380) at /usr/src/debug/kdelibs-4.11.2/kio/kio/job.cpp:2473
#18 0x0000003e3478df78 in QMetaObject::activate (sender=sender@entry=0x3175380, m=m@entry=0x36c88c25c0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff0074a670) at kernel/qobject.cpp:3547
#19 0x00000036c8531ff2 in KJob::result (this=this@entry=0x3175380, _t1=_t1@entry=0x3175380) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kdecore/kjob.moc:207
#20 0x00000036c8532030 in KJob::emitResult (this=this@entry=0x3175380) at /usr/src/debug/kdelibs-4.11.2/kdecore/jobs/kjob.cpp:318
#21 0x00000036cb2fe80a in KIO::SimpleJob::slotFinished (this=0x3175380) at /usr/src/debug/kdelibs-4.11.2/kio/kio/job.cpp:496
#22 0x0000003e3478df78 in QMetaObject::activate (sender=0x300d020, m=m@entry=0x36cb6a74a0 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3547
#23 0x00000036cb39c353 in KIO::SlaveInterface::finished (this=<optimized out>) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kio/slaveinterface.moc:184
#24 0x00000036cb39d896 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at /usr/src/debug/kdelibs-4.11.2/kio/kio/slaveinterface.cpp:176
#25 0x00000036cb39b38e in KIO::SlaveInterface::dispatch (this=0x300d020) at /usr/src/debug/kdelibs-4.11.2/kio/kio/slaveinterface.cpp:92
#26 0x00000036cb38fff6 in KIO::Slave::gotInput (this=0x300d020) at /usr/src/debug/kdelibs-4.11.2/kio/kio/slave.cpp:344
#27 0x0000003e3478df78 in QMetaObject::activate (sender=0x19c0a10, m=m@entry=0x36cb6a09c0 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3547
#28 0x00000036cb2cbc60 in KIO::Connection::readyRead (this=<optimized out>) at /usr/src/debug/kdelibs-4.11.2/x86_64-redhat-linux-gnu/kio/connection.moc:105
#29 0x00000036cb2cc351 in KIO::ConnectionPrivate::dequeue (this=0x2702540) at /usr/src/debug/kdelibs-4.11.2/kio/kio/connection.cpp:82
#30 0x0000003e3479232e in QObject::event (this=0x19c0a10, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x0000003e34dc84dc in QApplicationPrivate::notify_helper (this=this@entry=0xfef9c0, receiver=receiver@entry=0x19c0a10, e=e@entry=0x3684c30) at kernel/qapplication.cpp:4562
#32 0x0000003e34dceaa0 in QApplication::notify (this=this@entry=0x7fff0074b2f0, receiver=receiver@entry=0x19c0a10, e=e@entry=0x3684c30) at kernel/qapplication.cpp:4348
#33 0x00000036c8c3fe9a in KApplication::notify (this=0x7fff0074b2f0, receiver=0x19c0a10, event=0x3684c30) at /usr/src/debug/kdelibs-4.11.2/kdeui/kernel/kapplication.cpp:311
#34 0x0000003e3477a26d in QCoreApplication::notifyInternal (this=0x7fff0074b2f0, receiver=receiver@entry=0x19c0a10, event=event@entry=0x3684c30) at kernel/qcoreapplication.cpp:949
#35 0x0000003e3477d1df in sendEvent (event=0x3684c30, receiver=0x19c0a10) at kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xfae1c0) at kernel/qcoreapplication.cpp:1573
#37 0x0000003e3477d683 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#38 0x0000003e347a7883 in sendPostedEvents () at kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=s@entry=0xfe3c40) at kernel/qeventdispatcher_glib.cpp:280
#40 0x0000003009e47e06 in g_main_dispatch (context=0xff0140) at gmain.c:3054
#41 g_main_context_dispatch (context=context@entry=0xff0140) at gmain.c:3630
#42 0x0000003009e48158 in g_main_context_iterate (context=context@entry=0xff0140, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3701
#43 0x0000003009e481fc in g_main_context_iteration (context=0xff0140, may_block=1) at gmain.c:3762
#44 0x0000003e347a7145 in QEventDispatcherGlib::processEvents (this=0xfafaa0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#45 0x0000003e34e64fc6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#46 0x0000003e34778ecf in QEventLoop::processEvents (this=this@entry=0x7fff0074b1c0, flags=...) at kernel/qeventloop.cpp:149
#47 0x0000003e347791c5 in QEventLoop::exec (this=this@entry=0x7fff0074b1c0, flags=...) at kernel/qeventloop.cpp:204
#48 0x0000003e3477e45b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#49 0x0000003e34dc6c9c in QApplication::exec () at kernel/qapplication.cpp:3823
#50 0x00000036d0451447 in kdemain (argc=6, argv=0x7fff0074b428) at /usr/src/debug/kde-baseapps-4.11.2/dolphin/src/main.cpp:93
#51 0x0000003008221b75 in __libc_start_main (main=0x4008a0 <main(int, char**)>, argc=6, ubp_av=0x7fff0074b428, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0074b418) at libc-start.c:274
#52 0x00000000004008d1 in _start ()

Possible duplicates by query: bug 315068.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-11-03 00:43:47 UTC

*** This bug has been marked as a duplicate of bug 286977 ***