Bug 286893 - Rename inline option present but commented-out
Summary: Rename inline option present but commented-out
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 1.99
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 289674 297652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-18 00:09 UTC by Frederik Schwarzer
Modified: 2012-12-10 12:34 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Schwarzer 2011-11-18 00:09:26 UTC
Version:           1.99 (using Devel) 
OS:                Linux

Hi,

the rename inline function is there in the config dialog but commented-out in the source code. views/dolphinview.cpp:594

Regards

Reproducible: Didn't try

Steps to Reproduce:
Enable the option, the dialog opens ...


Expected Results:  
Either the option can be removed or the code fixed. (yes, I was forced to write something here ... ;))
Comment 1 Peter Penz 2011-11-18 08:59:50 UTC
For the 4.8 release I most probably won't be able to implement a "rename-inline" functionality for the new view-engine and will remove the option temporary from the dialog. The plan is to implement the "rename-inline" functionality for 4.9 in a way that "rename inline" will be default and no option is necessary at all.
Comment 2 Peter Penz 2011-11-19 06:12:56 UTC
Git commit 79bb28ec3a8150ed4984f0cd4ee5425bf8d9aac1 by Peter Penz.
Committed on 19/11/2011 at 07:04.
Pushed by ppenz into branch 'master'.

Remove "Rename inline" option

The new view-engine currently does not support inline-renaming
and because of more important pending issues this cannot be
implemented for the 4.8 release of KDE applications.

The plan for 4.9 is to implement inline-renaming again and
to make it "so good" (tm) that it is always turned on (-> there is
no need anymore for an option to disable it ;-)

CCBUG: 286893

M  +0    -4    dolphin/src/settings/dolphin_generalsettings.kcfg
M  +0    -8    dolphin/src/settings/general/behaviorsettingspage.cpp
M  +0    -1    dolphin/src/settings/general/behaviorsettingspage.h
M  +2    -0    dolphin/src/views/dolphinview.cpp

http://commits.kde.org/kde-baseapps/79bb28ec3a8150ed4984f0cd4ee5425bf8d9aac1
Comment 3 H.H. 2011-12-06 17:51:44 UTC
oh my god. in kde 4.8 there will be no inline-renaming in dolphin? no chance? please try..this is the most often used function for me right after viewing and copy&paste.

I would also see light, if there would be a chance for 4.8.1..
Comment 4 Peter Penz 2011-12-06 18:00:41 UTC
> oh my god. 
[...]

I think the world won't collapse if inline-renaming is temporary unavailable for 4.8 and you need to type the new name into a window ;-) This is no small patch that can be done in a few hours (... if doing it right) and it won't be possible to fix this for 4.8.x

But as said above: The plan is to make it default + the only available way for renaming in 4.9.
Comment 5 Peter Penz 2011-12-23 17:13:33 UTC
*** Bug 289674 has been marked as a duplicate of this bug. ***
Comment 6 H.H. 2012-01-21 16:50:23 UTC
after a while using the renaming dialog with F2 shortcut, it feels quite comfortable..no more problems with line breaks and too little space :-)
Comment 7 Peter Penz 2012-01-21 22:55:53 UTC
Thats nice to hear ;-) I hope I'll be able to merge the benefits of both approaches in 4.9 without their drawbacks...
Comment 8 Jekyll Wu 2012-04-07 13:43:44 UTC
*** Bug 297652 has been marked as a duplicate of this bug. ***
Comment 9 Peter Penz 2012-04-17 16:15:33 UTC
Git commit 8f9f877e4d18011defc3c6191e745cda080000ab by Peter Penz.
Committed on 17/04/2012 at 18:13.
Pushed by ppenz into branch 'master'.

Implement inline-renaming for the new view-engine
FIXED-IN: 4.9.0

M  +1    -0    dolphin/src/CMakeLists.txt
M  +2    -2    dolphin/src/dolphinmainwindow.cpp
M  +1    -0    dolphin/src/kitemviews/kfileitemlistview.cpp
M  +108  -1    dolphin/src/kitemviews/kfileitemlistwidget.cpp
M  +9    -1    dolphin/src/kitemviews/kfileitemlistwidget.h
M  +31   -1    dolphin/src/kitemviews/kitemlistview.cpp
M  +16   -0    dolphin/src/kitemviews/kitemlistview.h
M  +24   -3    dolphin/src/kitemviews/kitemlistwidget.cpp
M  +17   -0    dolphin/src/kitemviews/kitemlistwidget.h
A  +113  -0    dolphin/src/kitemviews/private/kitemlistroleeditor.cpp     [License: GPL (v2+)]
A  +67   -0    dolphin/src/kitemviews/private/kitemlistroleeditor.h     [License: GPL (v2+)]
M  +16   -13   dolphin/src/panels/folders/folderspanel.cpp
M  +1    -0    dolphin/src/panels/folders/folderspanel.h
M  +3    -0    dolphin/src/statusbar/dolphinstatusbar.cpp
M  +33   -24   dolphin/src/views/dolphinview.cpp
M  +2    -0    dolphin/src/views/dolphinview.h
M  +0    -1    dolphin/src/views/dolphinviewactionhandler.cpp

http://commits.kde.org/kde-baseapps/8f9f877e4d18011defc3c6191e745cda080000ab
Comment 10 Burak Aktas 2012-12-06 23:29:00 UTC
> The plan for 4.9 is to implement inline-renaming again and
> to make it "so good" (tm) that it is always turned on (-> there is
> no need anymore for an option to disable it ;-)
> 

What if I want to disable inline-renaming?
Comment 11 Jekyll Wu 2012-12-06 23:32:49 UTC
(In reply to comment #10)
> > The plan for 4.9 is to implement inline-renaming again and
> > to make it "so good" (tm) that it is always turned on (-> there is
> > no need anymore for an option to disable it ;-)
> > 
> 
> What if I want to disable inline-renaming?

You will be able to do that in KDE SC 4.10
Comment 12 Burak Aktas 2012-12-10 12:34:38 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > What if I want to disable inline-renaming?
> 
> You will be able to do that in KDE SC 4.10

I don't understand, why was it removed at all?