Bug 283520 - Amarok crashes when editing album tags
Summary: Amarok crashes when editing album tags
Status: RESOLVED DUPLICATE of bug 282025
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-07 09:07 UTC by zaratep
Modified: 2011-10-07 09:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zaratep 2011-10-07 09:07:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Editing album name of several songs in the same file, with currently unknow values

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7711ad0 (LWP 1313))]

Thread 3 (Thread 0xaefd3b70 (LWP 1317)):
#0  0x00817d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0350bdd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x035d84f2 in updateCurrentTime (this=0xae601174, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xae601174, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x035d6d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaefd30cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x035d6dcd in timerSourcePrepare (source=0xae601140, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x02a6afd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02a6be63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x02a6c524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x035d7577 in QEventDispatcherGlib::processEvents (this=0x9524fc8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x035a9289 in QEventLoop::processEvents (this=0xaefd3280, flags=...) at kernel/qeventloop.cpp:149
#12 0x035a9522 in QEventLoop::exec (this=0xaefd3280, flags=...) at kernel/qeventloop.cpp:201
#13 0x034b32a0 in QThread::exec (this=0x951c088) at thread/qthread.cpp:492
#14 0x0358afdb in QInotifyFileSystemWatcherEngine::run (this=0x951c088) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x034b5da2 in QThreadPrivate::start (arg=0x951c088) at thread/qthread_unix.cpp:320
#16 0x07adae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00a9a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xae5ffb70 (LWP 1318)):
#0  0x00aa8620 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x02a6b712 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x02a6c03a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02a6c524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x035d7577 in QEventDispatcherGlib::processEvents (this=0x9576fa8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x035a9289 in QEventLoop::processEvents (this=0xae5ff280, flags=...) at kernel/qeventloop.cpp:149
#6  0x035a9522 in QEventLoop::exec (this=0xae5ff280, flags=...) at kernel/qeventloop.cpp:201
#7  0x034b32a0 in QThread::exec (this=0x95f8c60) at thread/qthread.cpp:492
#8  0x0358afdb in QInotifyFileSystemWatcherEngine::run (this=0x95f8c60) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x034b5da2 in QThreadPrivate::start (arg=0x95f8c60) at thread/qthread_unix.cpp:320
#10 0x07adae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00a9a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7711ad0 (LWP 1313)):
[KCrash Handler]
#7  0x01050454 in QString (this=0xa5c0061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0xa5c0061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01056352 in KIconLoaderPrivate::makeCacheKey (this=0xa5c004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x0105d398 in KIconLoader::loadIcon (this=0xa06c1c8, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x01054d76 in KIconEngine::pixmap (this=0xa0365a8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x0558d712 in QIcon::pixmap (this=0xa440444, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x002aa969 in Plasma::IconWidgetPrivate::decoration (this=0xa4403a0, option=0x8e51eb0, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x002b121d in Plasma::IconWidget::paint (this=0xa55b360, painter=0xbf9f1a2c, option=0x8e51eb0, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x052eb0dd in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0x05b3647c in _q_paintItem (item=<value optimized out>, painter=0x8e51eb0, option=0x8e51eb0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x05b36782 in _q_paintIntoCache (pix=0xbf9f1efc, item=0xa55b368, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8e51eb0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0x05b4a490 in QGraphicsScenePrivate::drawItemHelper (this=0x8e51d60, item=0xa55b368, painter=0xbf9f36e4, option=0x8e51eb0, widget=0x99ae9d8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0x05b4b152 in QGraphicsScenePrivate::draw (this=0x8e51d60, item=0xa55b368, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, transformPtr=0xbf9f22e0, exposedRegion=0x99a2220, widget=0x99ae9d8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0x05b4be92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8e51d60, item=0xa55b368, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, exposedRegion=0x99a2220, widget=0x99ae9d8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0x05b4af7c in QGraphicsScenePrivate::draw (this=0x8e51d60, item=0x8f8f458, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, transformPtr=0xbf9f2780, exposedRegion=0x99a2220, widget=0x99ae9d8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0x05b4be92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8e51d60, item=0x8f8f458, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, exposedRegion=0x99a2220, widget=0x99ae9d8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0x05b4af7c in QGraphicsScenePrivate::draw (this=0x8e51d60, item=0x8f90fa0, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, transformPtr=0xbf9f2c20, exposedRegion=0x99a2220, widget=0x99ae9d8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0x05b4be92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8e51d60, item=0x8f90fa0, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, exposedRegion=0x99a2220, widget=0x99ae9d8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0x05b4af7c in QGraphicsScenePrivate::draw (this=0x8e51d60, item=0x8e66890, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, transformPtr=0xbf9f30c0, exposedRegion=0x99a2220, widget=0x99ae9d8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0x05b4be92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8e51d60, item=0x8e66890, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, exposedRegion=0x99a2220, widget=0x99ae9d8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0x05b4c696 in QGraphicsScenePrivate::drawItems (this=0x8e51d60, painter=0xbf9f36e4, viewTransform=0xbf9f34cc, exposedRegion=0x99a2220, widget=0x99ae9d8) at graphicsview/qgraphicsscene.cpp:4735
#28 0x05b6b931 in QGraphicsView::paintEvent (this=0x9a49b60, event=0xbf9f3df4) at graphicsview/qgraphicsview.cpp:3469
#29 0x0076a484 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#30 0x0552d18e in QWidget::event (this=0x9a49b60, event=0xbf9f3df4) at kernel/qwidget.cpp:8405
#31 0x059219f3 in QFrame::event (this=0x9a49b60, e=0xbf9f3df4) at widgets/qframe.cpp:557
#32 0x059b0062 in QAbstractScrollArea::viewportEvent (this=0x9a49b60, e=0xbf9f3df4) at widgets/qabstractscrollarea.cpp:1043
#33 0x05b6cdff in QGraphicsView::viewportEvent (this=0x9a49b60, event=0xbf9f3df4) at graphicsview/qgraphicsview.cpp:2864
#34 0x059b2965 in viewportEvent (this=0x994cde8, o=0x99ae9d8, e=0xbf9f3df4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x994cde8, o=0x99ae9d8, e=0xbf9f3df4) at widgets/qabstractscrollarea_p.h:116
#36 0x035aa25a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8d79608, receiver=0x99ae9d8, event=0xbf9f3df4) at kernel/qcoreapplication.cpp:846
#37 0x054d4d00 in QApplicationPrivate::notify_helper (this=0x8d79608, receiver=0x99ae9d8, e=0xbf9f3df4) at kernel/qapplication.cpp:4458
#38 0x054d997b in QApplication::notify (this=0x8d6f788, receiver=0x99ae9d8, e=0xbf9f3df4) at kernel/qapplication.cpp:4427
#39 0x010af3ca in KApplication::notify (this=0x8d6f788, receiver=0x99ae9d8, event=0xbf9f3df4) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x035aa0bb in QCoreApplication::notifyInternal (this=0x8d6f788, receiver=0x99ae9d8, event=0xbf9f3df4) at kernel/qcoreapplication.cpp:731
#41 0x05529f0c in sendSpontaneousEvent (this=0x9987148, pdev=0x9e34a6c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9d210a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x9987148, pdev=0x9e34a6c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9d210a8) at kernel/qwidget.cpp:5492
#43 0x0552ab7c in QWidgetPrivate::paintSiblingsRecursive (this=0x99a1ed0, pdev=0x9e34a6c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9d210a8) at kernel/qwidget.cpp:5699
#44 0x05529c80 in QWidgetPrivate::drawWidget (this=0x99a1ed0, pdev=0x9e34a6c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x9d210a8) at kernel/qwidget.cpp:5545
#45 0x05708398 in QWidgetBackingStore::sync (this=0x9d210a8) at painting/qbackingstore.cpp:1333
#46 0x0551f843 in QWidgetPrivate::syncBackingStore (this=0x99a1ed0) at kernel/qwidget.cpp:1842
#47 0x0552d7e5 in QWidget::event (this=0x9a49b60, event=0xa06c1c8) at kernel/qwidget.cpp:8552
#48 0x059219f3 in QFrame::event (this=0x9a49b60, e=0xa06c1c8) at widgets/qframe.cpp:557
#49 0x059b1dcf in QAbstractScrollArea::event (this=0x9a49b60, e=0xa06c1c8) at widgets/qabstractscrollarea.cpp:996
#50 0x05b60116 in QGraphicsView::event (this=0x9a49b60, event=0xa06c1c8) at graphicsview/qgraphicsview.cpp:2741
#51 0x0076a7c3 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#52 0x054d4d24 in QApplicationPrivate::notify_helper (this=0x8d79608, receiver=0x9a49b60, e=0xa06c1c8) at kernel/qapplication.cpp:4462
#53 0x054d997b in QApplication::notify (this=0x8d6f788, receiver=0x9a49b60, e=0xa06c1c8) at kernel/qapplication.cpp:4427
#54 0x010af3ca in KApplication::notify (this=0x8d6f788, receiver=0x9a49b60, event=0xa06c1c8) at ../../kdeui/kernel/kapplication.cpp:311
#55 0x035aa0bb in QCoreApplication::notifyInternal (this=0x8d6f788, receiver=0x9a49b60, event=0xa06c1c8) at kernel/qcoreapplication.cpp:731
#56 0x035adc79 in sendEvent (receiver=0x9a49b60, event_type=77, data=0x8d21f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9a49b60, event_type=77, data=0x8d21f50) at kernel/qcoreapplication.cpp:1372
#58 0x035ade0d in QCoreApplication::sendPostedEvents (receiver=0x9a49b60, event_type=77) at kernel/qcoreapplication.cpp:1265
#59 0x05b42c46 in dispatchPendingUpdateRequests (this=0x8e51d60) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8e51d60) at graphicsview/qgraphicsscene.cpp:510
#61 0x05b43026 in QGraphicsScene::qt_metacall (this=0x8d790f8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x95a6d10) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#62 0x001eda9a in Plasma::Corona::qt_metacall (this=0x8d790f8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x95a6d10) at ./corona.moc:109
#63 0x0075d20a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#64 0x035b06ba in QMetaObject::metacall (object=0x8d790f8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x95a6d10) at kernel/qmetaobject.cpp:237
#65 0x035bae16 in QMetaCallEvent::placeMetaCall (this=0xa42e8a8, object=0x8d790f8) at kernel/qobject.cpp:535
#66 0x035bf3b7 in QObject::event (this=0x8d790f8, e=0xa42e8a8) at kernel/qobject.cpp:1226
#67 0x05b4fe44 in QGraphicsScene::event (this=0x8d790f8, event=0xa42e8a8) at graphicsview/qgraphicsscene.cpp:3544
#68 0x054d4d24 in QApplicationPrivate::notify_helper (this=0x8d79608, receiver=0x8d790f8, e=0xa42e8a8) at kernel/qapplication.cpp:4462
#69 0x054d98ce in QApplication::notify (this=0x8d6f788, receiver=0x8d790f8, e=0xa42e8a8) at kernel/qapplication.cpp:3862
#70 0x010af3ca in KApplication::notify (this=0x8d6f788, receiver=0x8d790f8, event=0xa42e8a8) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x035aa0bb in QCoreApplication::notifyInternal (this=0x8d6f788, receiver=0x8d790f8, event=0xa42e8a8) at kernel/qcoreapplication.cpp:731
#72 0x035adc79 in sendEvent (receiver=0x0, event_type=0, data=0x8d21f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8d21f50) at kernel/qcoreapplication.cpp:1372
#74 0x035ade0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#75 0x035d73c4 in sendPostedEvents (s=0x8d7ce90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x8d7ce90) at kernel/qeventdispatcher_glib.cpp:277
#77 0x02a6baa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#78 0x02a6c270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#79 0x02a6c524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#80 0x035d753c in QEventDispatcherGlib::processEvents (this=0x8d21aa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#81 0x0558b1e5 in QGuiEventDispatcherGlib::processEvents (this=0x8d21aa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x035a9289 in QEventLoop::processEvents (this=0xbf9f55e4, flags=...) at kernel/qeventloop.cpp:149
#83 0x035a9522 in QEventLoop::exec (this=0xbf9f55e4, flags=...) at kernel/qeventloop.cpp:201
#84 0x035adecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0x054d28e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#86 0x007645a5 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#87 0x080485cb in _start ()

Possible duplicates by query: bug 282991, bug 282520, bug 282043, bug 282025, bug 281847.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-07 09:29:46 UTC

*** This bug has been marked as a duplicate of bug 282025 ***