Bug 282520 - Plasma crashed while killing kded, knotify and kmix
Summary: Plasma crashed while killing kded, knotify and kmix
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 01:01 UTC by arrenlex
Modified: 2011-09-23 14:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arrenlex 2011-09-22 01:01:27 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I had unplugged my USB headphones and needed to kill all applications using ALSA to allow the hardware to be reinitialized.

I killed kded4, knotify4, kmix and plugin-container (flash player) using "kill" and their process IDs.

At this time, the plasma shell crashed.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f269a4407a0 (LWP 2128))]

Thread 3 (Thread 0x7f267d45c700 (LWP 2132)):
#0  0x00007f268f022d87 in __pthread_mutex_unlock_usercnt (mutex=<value optimized out>) at pthread_mutex_unlock.c:41
#1  __pthread_mutex_unlock (mutex=<value optimized out>) at pthread_mutex_unlock.c:290
#2  0x00007f268e71b0f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f268e71b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2696f4b446 in QEventDispatcherGlib::processEvents (this=0x1fec810, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f2696f1f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f2696f1fabc in QEventLoop::exec (this=0x7f267d45bdb0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f2696e36924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f2696f01c2f in QInotifyFileSystemWatcherEngine::run (this=0x1fbfcc0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f2696e39175 in QThreadPrivate::start (arg=0x1fbfcc0) at thread/qthread_unix.cpp:320
#10 0x00007f268f01ed8c in start_thread (arg=0x7f267d45c700) at pthread_create.c:304
#11 0x00007f2699d4a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2671161700 (LWP 2134)):
#0  0x00007f2699d3cf03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f268e71b104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f268e71b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2696f4b446 in QEventDispatcherGlib::processEvents (this=0x2151f70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2696f1f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2696f1fabc in QEventLoop::exec (this=0x7f2671160db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2696e36924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f2696f01c2f in QInotifyFileSystemWatcherEngine::run (this=0x21682b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2696e39175 in QThreadPrivate::start (arg=0x21682b0) at thread/qthread_unix.cpp:320
#9  0x00007f268f01ed8c in start_thread (arg=0x7f2671161700) at pthread_create.c:304
#10 0x00007f2699d4a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f269a4407a0 (LWP 2128)):
[KCrash Handler]
#6  0x00007f2697b7f5d1 in QString (this=0x48, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x48, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f2697b84feb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f2697b8bd03 in KIconLoader::loadIcon (this=0x26cd660, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f2697b83c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f26963894b5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007f269992c099 in Plasma::IconWidgetPrivate::decoration (this=0x2ab3fb0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007f2699931e51 in Plasma::IconWidget::paint (this=0x2ab3a20, painter=0x7ffffa260a50, option=0x1baf448, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007f267f4123e9 in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#15 0x00007f26968cf88d in _q_paintItem (item=<value optimized out>, painter=0x7ffffa260a50, option=0x1baf448, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007f26968cfba0 in _q_paintIntoCache (pix=0x7ffffa260f80, item=0x2ab3a30, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x1baf448, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007f26968e33d8 in QGraphicsScenePrivate::drawItemHelper (this=0x1baf220, item=0x2ab3a30, painter=0x7ffffa262f90, option=0x1baf448, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007f26968e3faa in QGraphicsScenePrivate::draw (this=0x1baf220, item=0x2ab3a30, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, transformPtr=0x7ffffa261640, exposedRegion=0x264ae60, widget=0x265f5f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007f26968e4c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1baf220, item=0x2ab3a30, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, exposedRegion=0x264ae60, widget=0x265f5f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007f26968e3e20 in QGraphicsScenePrivate::draw (this=0x1baf220, item=0x1ec8d40, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, transformPtr=0x7ffffa261c40, exposedRegion=0x264ae60, widget=0x265f5f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007f26968e4c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1baf220, item=0x1ec8d40, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, exposedRegion=0x264ae60, widget=0x265f5f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007f26968e3e20 in QGraphicsScenePrivate::draw (this=0x1baf220, item=0x1ecdd90, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, transformPtr=0x7ffffa262240, exposedRegion=0x264ae60, widget=0x265f5f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007f26968e4c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1baf220, item=0x1ecdd90, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, exposedRegion=0x264ae60, widget=0x265f5f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007f26968e3e20 in QGraphicsScenePrivate::draw (this=0x1baf220, item=0x1dc6d90, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, transformPtr=0x7ffffa262840, exposedRegion=0x264ae60, widget=0x265f5f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007f26968e4c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1baf220, item=0x1dc6d90, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, exposedRegion=0x264ae60, widget=0x265f5f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007f26968e5484 in QGraphicsScenePrivate::drawItems (this=0x1baf220, painter=0x7ffffa262f90, viewTransform=0x7ffffa262d20, exposedRegion=0x264ae60, widget=0x265f5f0) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007f26969022c2 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007f269632ec7a in QWidget::event (this=0x2648fa0, event=0x7ffffa2638b0) at kernel/qwidget.cpp:8405
#29 0x00007f26966e1156 in QFrame::event (this=0x2648fa0, e=0x7ffffa2638b0) at widgets/qframe.cpp:557
#30 0x00007f269690357b in QGraphicsView::viewportEvent (this=0x2648fa0, event=0x7ffffa2638b0) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007f2696f20627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x265f5f0, event=0x7ffffa2638b0) at kernel/qcoreapplication.cpp:846
#32 0x00007f26962dd9c1 in QApplicationPrivate::notify_helper (this=0x1ada420, receiver=0x265f5f0, e=0x7ffffa2638b0) at kernel/qapplication.cpp:4458
#33 0x00007f26962e23ba in QApplication::notify (this=<value optimized out>, receiver=0x265f5f0, e=0x7ffffa2638b0) at kernel/qapplication.cpp:4341
#34 0x00007f2697bd8866 in KApplication::notify (this=0x1acbf80, receiver=0x265f5f0, event=0x7ffffa2638b0) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f2696f2049c in QCoreApplication::notifyInternal (this=0x1acbf80, receiver=0x265f5f0, event=0x7ffffa2638b0) at kernel/qcoreapplication.cpp:731
#36 0x00007f269632bacd in sendSpontaneousEvent (this=0x265fcf0, pdev=0x2660408, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26603a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x265fcf0, pdev=0x2660408, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26603a0) at kernel/qwidget.cpp:5492
#38 0x00007f269632c6e2 in QWidgetPrivate::paintSiblingsRecursive (this=0x264a9d0, pdev=0x2660408, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26603a0) at kernel/qwidget.cpp:5699
#39 0x00007f269632b80c in QWidgetPrivate::drawWidget (this=0x264a9d0, pdev=0x2660408, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x26603a0) at kernel/qwidget.cpp:5545
#40 0x00007f26964f29eb in QWidgetBackingStore::sync (this=0x26603a0) at painting/qbackingstore.cpp:1333
#41 0x00007f2696321f60 in QWidgetPrivate::syncBackingStore (this=0x264a9d0) at kernel/qwidget.cpp:1842
#42 0x00007f269632f194 in QWidget::event (this=0x2648fa0, event=0x2b31750) at kernel/qwidget.cpp:8552
#43 0x00007f26966e1156 in QFrame::event (this=0x2648fa0, e=0x2b31750) at widgets/qframe.cpp:557
#44 0x00007f26967628eb in QAbstractScrollArea::event (this=0x2648fa0, e=0x2b31750) at widgets/qabstractscrollarea.cpp:996
#45 0x00007f269a03bfe6 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#46 0x00007f26962dd9f4 in QApplicationPrivate::notify_helper (this=0x1ada420, receiver=0x2648fa0, e=0x2b31750) at kernel/qapplication.cpp:4462
#47 0x00007f26962e23ba in QApplication::notify (this=<value optimized out>, receiver=0x2648fa0, e=0x2b31750) at kernel/qapplication.cpp:4341
#48 0x00007f2697bd8866 in KApplication::notify (this=0x1acbf80, receiver=0x2648fa0, event=0x2b31750) at ../../kdeui/kernel/kapplication.cpp:311
#49 0x00007f2696f2049c in QCoreApplication::notifyInternal (this=0x1acbf80, receiver=0x2648fa0, event=0x2b31750) at kernel/qcoreapplication.cpp:731
#50 0x00007f2696f23c25 in sendEvent (receiver=0x2648fa0, event_type=77, data=0x1a57b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0x2648fa0, event_type=77, data=0x1a57b60) at kernel/qcoreapplication.cpp:1372
#52 0x00007f26968dbf7a in dispatchPendingUpdateRequests (this=0x1baf220) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x1baf220) at graphicsview/qgraphicsscene.cpp:510
#54 0x00007f26968dc39a in QGraphicsScene::qt_metacall (this=0x1ba9360, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x2c09a00) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x00007f269987fb65 in Plasma::Corona::qt_metacall (this=0x1ba9360, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2c09a00) at ./corona.moc:109
#56 0x00007f269a030065 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#57 0x00007f2696f3449a in QObject::event (this=0x1ba9360, e=<value optimized out>) at kernel/qobject.cpp:1226
#58 0x00007f26968e8c7b in QGraphicsScene::event (this=0x1ba9360, event=0x20da0c0) at graphicsview/qgraphicsscene.cpp:3544
#59 0x00007f26962dd9f4 in QApplicationPrivate::notify_helper (this=0x1ada420, receiver=0x1ba9360, e=0x20da0c0) at kernel/qapplication.cpp:4462
#60 0x00007f26962e23ba in QApplication::notify (this=<value optimized out>, receiver=0x1ba9360, e=0x20da0c0) at kernel/qapplication.cpp:4341
#61 0x00007f2697bd8866 in KApplication::notify (this=0x1acbf80, receiver=0x1ba9360, event=0x20da0c0) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f2696f2049c in QCoreApplication::notifyInternal (this=0x1acbf80, receiver=0x1ba9360, event=0x20da0c0) at kernel/qcoreapplication.cpp:731
#63 0x00007f2696f23c25 in sendEvent (receiver=0x0, event_type=0, data=0x1a57b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a57b60) at kernel/qcoreapplication.cpp:1372
#65 0x00007f2696f4b253 in sendPostedEvents (s=0x1ae2dc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x1ae2dc0) at kernel/qeventdispatcher_glib.cpp:277
#67 0x00007f268e71abcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#68 0x00007f268e71b3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007f268e71b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007f2696f4b3ef in QEventDispatcherGlib::processEvents (this=0x1a57340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#71 0x00007f26963874de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007f2696f1f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#73 0x00007f2696f1fabc in QEventLoop::exec (this=0x7ffffa265850, flags=...) at kernel/qeventloop.cpp:201
#74 0x00007f2696f23ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#75 0x00007f269a036897 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#76 0x00007f2699c82eff in __libc_start_main (main=0x400740 <_start+256>, argc=1, ubp_av=0x7ffffa265c18, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7ffffa265c08) at libc-start.c:226
#77 0x0000000000400669 in _start ()

Possible duplicates by query: bug 282043, bug 282025, bug 281847, bug 281589, bug 281219.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-09-23 14:06:40 UTC

*** This bug has been marked as a duplicate of bug 258706 ***