Bug 282043 - Amarok closed and reported a bug
Summary: Amarok closed and reported a bug
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-14 22:16 UTC by Alvin Eloy Luna Castro
Modified: 2011-09-28 23:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvin Eloy Luna Castro 2011-09-14 22:16:19 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: I was changing the play mode from Random to Artists using Amarok

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa3e53887a0 (LWP 1417))]

Thread 4 (Thread 0x7fa3c1e48700 (LWP 1420)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fa3c1e47ac0 in ?? ()
#2  0x00007fff49a7e7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7fa3c0c75700 (LWP 1421)):
#0  0x00007fa3d965c6a3 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa3d965df21 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa3d965e639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa3e1e8e446 in QEventDispatcherGlib::processEvents (this=0x223b1c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fa3e1e62882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa3e1e62abc in QEventLoop::exec (this=0x7fa3c0c74db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa3e1d79924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fa3e1e44c2f in QInotifyFileSystemWatcherEngine::run (this=0x2238f00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa3e1d7c175 in QThreadPrivate::start (arg=0x2238f00) at thread/qthread_unix.cpp:320
#9  0x00007fa3d9f61d8c in start_thread (arg=0x7fa3c0c75700) at pthread_create.c:304
#10 0x00007fa3e4c8d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa3b7b21700 (LWP 1427)):
#0  0x00007fa3e4c7ff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa3d965e104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa3d965e9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa3b8c38c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fa3d96853e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa3d9f61d8c in start_thread (arg=0x7fa3b7b21700) at pthread_create.c:304
#6  0x00007fa3e4c8d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa3e53887a0 (LWP 1417)):
[KCrash Handler]
#6  0x00007fa3e2ac25df in QString (this=0x2140075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2140075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007fa3e2ac7feb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007fa3e2aced03 in KIconLoader::loadIcon (this=0x2abf340, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007fa3e2ac6c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007fa3e12cc4b5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007fa3e486f099 in Plasma::IconWidgetPrivate::decoration (this=0x2d39850, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007fa3e4874e51 in Plasma::IconWidget::paint (this=0x253e2b0, painter=0x7fff499fb370, option=0x1a8a888, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007fa3cb5153e9 in SystemTray::DBusSystemTrayWidget::paint (this=0x253e2b0, painter=0x7fff499fb370, option=0x1a8a888, widget=<value optimized out>) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00007fa3e181288d in _q_paintItem (item=<value optimized out>, painter=0x7fff499fb370, option=0x1a8a888, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007fa3e1812ba0 in _q_paintIntoCache (pix=0x7fff499fb8a0, item=0x253e2c0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x1a8a888, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007fa3e18263d8 in QGraphicsScenePrivate::drawItemHelper (this=0x1a8a660, item=0x253e2c0, painter=0x7fff499fd8b0, option=0x1a8a888, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007fa3e1826faa in QGraphicsScenePrivate::draw (this=0x1a8a660, item=0x253e2c0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, transformPtr=0x7fff499fbf60, exposedRegion=0x24ef9f0, widget=0x260fb80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007fa3e1827c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1a8a660, item=0x253e2c0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, exposedRegion=0x24ef9f0, widget=0x260fb80, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007fa3e1826e20 in QGraphicsScenePrivate::draw (this=0x1a8a660, item=0x1c17b70, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, transformPtr=0x7fff499fc560, exposedRegion=0x24ef9f0, widget=0x260fb80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007fa3e1827c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1a8a660, item=0x1c17b70, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, exposedRegion=0x24ef9f0, widget=0x260fb80, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007fa3e1826e20 in QGraphicsScenePrivate::draw (this=0x1a8a660, item=0x1bb2eb0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, transformPtr=0x7fff499fcb60, exposedRegion=0x24ef9f0, widget=0x260fb80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007fa3e1827c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1a8a660, item=0x1bb2eb0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, exposedRegion=0x24ef9f0, widget=0x260fb80, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007fa3e1826e20 in QGraphicsScenePrivate::draw (this=0x1a8a660, item=0x1ac26b0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, transformPtr=0x7fff499fd160, exposedRegion=0x24ef9f0, widget=0x260fb80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007fa3e1827c55 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1a8a660, item=0x1ac26b0, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, exposedRegion=0x24ef9f0, widget=0x260fb80, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007fa3e1828484 in QGraphicsScenePrivate::drawItems (this=0x1a8a660, painter=0x7fff499fd8b0, viewTransform=0x7fff499fd640, exposedRegion=0x24ef9f0, widget=0x260fb80) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007fa3e18452c2 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007fa3e1271c7a in QWidget::event (this=0x27e0130, event=0x7fff499fe1d0) at kernel/qwidget.cpp:8405
#29 0x00007fa3e1624156 in QFrame::event (this=0x27e0130, e=0x7fff499fe1d0) at widgets/qframe.cpp:557
#30 0x00007fa3e184657b in QGraphicsView::viewportEvent (this=0x27e0130, event=0x7fff499fe1d0) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007fa3e1e63627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x260fb80, event=0x7fff499fe1d0) at kernel/qcoreapplication.cpp:846
#32 0x00007fa3e12209c1 in QApplicationPrivate::notify_helper (this=0x1997400, receiver=0x260fb80, e=0x7fff499fe1d0) at kernel/qapplication.cpp:4458
#33 0x00007fa3e12253ba in QApplication::notify (this=<value optimized out>, receiver=0x260fb80, e=0x7fff499fe1d0) at kernel/qapplication.cpp:4341
#34 0x00007fa3e2b1b866 in KApplication::notify (this=0x196aef0, receiver=0x260fb80, event=0x7fff499fe1d0) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007fa3e1e6349c in QCoreApplication::notifyInternal (this=0x196aef0, receiver=0x260fb80, event=0x7fff499fe1d0) at kernel/qcoreapplication.cpp:731
#36 0x00007fa3e126eacd in sendSpontaneousEvent (this=0x29c7750, pdev=0x260d7c8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x202b320) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x29c7750, pdev=0x260d7c8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x202b320) at kernel/qwidget.cpp:5492
#38 0x00007fa3e126f6e2 in QWidgetPrivate::paintSiblingsRecursive (this=0x24ef560, pdev=0x260d7c8, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x202b320) at kernel/qwidget.cpp:5699
#39 0x00007fa3e126e80c in QWidgetPrivate::drawWidget (this=0x24ef560, pdev=0x260d7c8, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x202b320) at kernel/qwidget.cpp:5545
#40 0x00007fa3e14359eb in QWidgetBackingStore::sync (this=0x202b320) at painting/qbackingstore.cpp:1333
#41 0x00007fa3e1264f60 in QWidgetPrivate::syncBackingStore (this=0x24ef560) at kernel/qwidget.cpp:1842
#42 0x00007fa3e1272194 in QWidget::event (this=0x27e0130, event=0x2abf340) at kernel/qwidget.cpp:8552
#43 0x00007fa3e1624156 in QFrame::event (this=0x27e0130, e=0x2abf340) at widgets/qframe.cpp:557
#44 0x00007fa3e16a58eb in QAbstractScrollArea::event (this=0x27e0130, e=0x2abf340) at widgets/qabstractscrollarea.cpp:996
#45 0x00007fa3e4f7efe6 in PanelView::event (this=0x27e0130, event=0x2abf340) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#46 0x00007fa3e12209f4 in QApplicationPrivate::notify_helper (this=0x1997400, receiver=0x27e0130, e=0x2abf340) at kernel/qapplication.cpp:4462
#47 0x00007fa3e12253ba in QApplication::notify (this=<value optimized out>, receiver=0x27e0130, e=0x2abf340) at kernel/qapplication.cpp:4341
#48 0x00007fa3e2b1b866 in KApplication::notify (this=0x196aef0, receiver=0x27e0130, event=0x2abf340) at ../../kdeui/kernel/kapplication.cpp:311
#49 0x00007fa3e1e6349c in QCoreApplication::notifyInternal (this=0x196aef0, receiver=0x27e0130, event=0x2abf340) at kernel/qcoreapplication.cpp:731
#50 0x00007fa3e1e66c25 in sendEvent (receiver=0x27e0130, event_type=77, data=0x1919b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0x27e0130, event_type=77, data=0x1919b60) at kernel/qcoreapplication.cpp:1372
#52 0x00007fa3e181ef7a in dispatchPendingUpdateRequests (this=0x1a8a660) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x1a8a660) at graphicsview/qgraphicsscene.cpp:510
#54 0x00007fa3e181f39a in QGraphicsScene::qt_metacall (this=0x19976d0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x2616550) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x00007fa3e47c2b65 in Plasma::Corona::qt_metacall (this=0x19976d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2616550) at ./corona.moc:109
#56 0x00007fa3e4f73065 in DesktopCorona::qt_metacall (this=0x19976d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2616550) at ./desktopcorona.moc:101
#57 0x00007fa3e1e7749a in QObject::event (this=0x19976d0, e=<value optimized out>) at kernel/qobject.cpp:1226
#58 0x00007fa3e182bc7b in QGraphicsScene::event (this=0x19976d0, event=0x2deea70) at graphicsview/qgraphicsscene.cpp:3544
#59 0x00007fa3e12209f4 in QApplicationPrivate::notify_helper (this=0x1997400, receiver=0x19976d0, e=0x2deea70) at kernel/qapplication.cpp:4462
#60 0x00007fa3e12253ba in QApplication::notify (this=<value optimized out>, receiver=0x19976d0, e=0x2deea70) at kernel/qapplication.cpp:4341
#61 0x00007fa3e2b1b866 in KApplication::notify (this=0x196aef0, receiver=0x19976d0, event=0x2deea70) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007fa3e1e6349c in QCoreApplication::notifyInternal (this=0x196aef0, receiver=0x19976d0, event=0x2deea70) at kernel/qcoreapplication.cpp:731
#63 0x00007fa3e1e66c25 in sendEvent (receiver=0x0, event_type=0, data=0x1919b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1919b60) at kernel/qcoreapplication.cpp:1372
#65 0x00007fa3e1e8e253 in sendPostedEvents (s=0x199a690) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x199a690) at kernel/qeventdispatcher_glib.cpp:277
#67 0x00007fa3d965dbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#68 0x00007fa3d965e3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007fa3d965e639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007fa3e1e8e3ef in QEventDispatcherGlib::processEvents (this=0x1919340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#71 0x00007fa3e12ca4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007fa3e1e62882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#73 0x00007fa3e1e62abc in QEventLoop::exec (this=0x7fff49a00170, flags=...) at kernel/qeventloop.cpp:201
#74 0x00007fa3e1e66ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#75 0x00007fa3e4f79897 in kdemain (argc=1, argv=0x7fff49a00538) at ../../../../plasma/desktop/shell/main.cpp:118
#76 0x00007fa3e4bc5eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=1, ubp_av=0x7fff49a00538, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff49a00528) at libc-start.c:226
#77 0x0000000000400669 in _start ()

Possible duplicates by query: bug 282025, bug 281847, bug 281589, bug 281219, bug 281050.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-28 23:11:05 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***