Bug 281230 - Plasma crashed after launched kmplayer
Summary: Plasma crashed after launched kmplayer
Status: RESOLVED DUPLICATE of bug 238556
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Mageia RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-02 21:30 UTC by Dimitrios Glentadakis
Modified: 2011-09-05 02:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitrios Glentadakis 2011-09-02 21:30:05 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.3
Operating System: Linux 2.6.38.8-desktop-4.mga x86_64
Distribution: "Mageia 1"

-- Information about the crash:
- What I was doing when the application crashed:

From kmenu, i typed kmplayer in the search bar and after i click on the entry of kmplayer in the resaults

The crash does not seem to be reproducible.

-- Backtrace:
Application: Κέλυφος επιφάνειας εργασίας (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7da5e5c720 (LWP 2622))]

Thread 6 (Thread 0x7f7d739d4710 (LWP 2645)):
#0  0x00007f7da3502783 in poll () from /lib64/libc.so.6
#1  0x00007f7da0540304 in g_main_context_poll (context=0x7f7d6c0009b0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0x7f7d6c0009b0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3086
#3  0x00007f7da054083d in g_main_context_iteration (context=0x7f7d6c0009b0, may_block=1) at gmain.c:3154
#4  0x00007f7da4af4a06 in QEventDispatcherGlib::processEvents (this=0x7f7d6c0008c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f7da4ac8792 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7da4ac89dc in QEventLoop::exec (this=0x7f7d739d3e20, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f7da49dc924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f7da4aa9ed8 in QInotifyFileSystemWatcherEngine::run (this=0x39ec6a0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f7da49df1c5 in QThreadPrivate::start (arg=0x39ec6a0) at thread/qthread_unix.cpp:320
#10 0x00007f7da4755d25 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f7da350cfdd in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f7d69fad710 (LWP 5222)):
#0  0x00007f7da475a23c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da49df8ab in wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7d991ce2e4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x507d130, th=0x409c3d0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7d991d0973 in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x409c3d0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7d991cf75f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7d69face70, parent=0x507d130, th=0x409c3d0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:87
#6  0x00007f7d991cf7e8 in ThreadWeaver::Thread::run (this=0x409c3d0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:142
#7  0x00007f7da49df1c5 in QThreadPrivate::start (arg=0x409c3d0) at thread/qthread_unix.cpp:320
#8  0x00007f7da4755d25 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7da350cfdd in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f7d697ac710 (LWP 5223)):
#0  0x00007f7da475a23c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da49df8ab in wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7d991ce2e4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x507d130, th=0x4b1f800) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7d991d0973 in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x4b1f800) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7d991cf75f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7d697abe70, parent=0x507d130, th=0x4b1f800) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:87
#6  0x00007f7d991cf7e8 in ThreadWeaver::Thread::run (this=0x4b1f800) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:142
#7  0x00007f7da49df1c5 in QThreadPrivate::start (arg=0x4b1f800) at thread/qthread_unix.cpp:320
#8  0x00007f7da4755d25 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7da350cfdd in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7d6b7b0710 (LWP 5224)):
#0  0x00007f7da475a23c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da49df8ab in wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7d991ce2e4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x507d130, th=0x344b2f0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7d991d0973 in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x344b2f0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7d991d098c in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x344b2f0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f7d991cf75f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7d6b7afe70, parent=0x507d130, th=0x344b2f0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f7d991cf7e8 in ThreadWeaver::Thread::run (this=0x344b2f0) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f7da49df1c5 in QThreadPrivate::start (arg=0x344b2f0) at thread/qthread_unix.cpp:320
#9  0x00007f7da4755d25 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7da350cfdd in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7d6afaf710 (LWP 5225)):
#0  0x00007f7da475a23c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da49df8ab in wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x5017d70, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f7d991ce2e4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x507d130, th=0x5363500) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f7d991d0973 in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x5363500) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f7d991d098c in ThreadWeaver::WorkingHardState::applyForWork (this=0x5026d80, th=0x5363500) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f7d991cf75f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7d6afaee70, parent=0x507d130, th=0x5363500) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f7d991cf7e8 in ThreadWeaver::Thread::run (this=0x5363500) at /usr/src/debug/kdelibs-4.6.5/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f7da49df1c5 in QThreadPrivate::start (arg=0x5363500) at thread/qthread_unix.cpp:320
#9  0x00007f7da4755d25 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7da350cfdd in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7da5e5c720 (LWP 2622)):
[KCrash Handler]
#6  deref (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/lib/qt4/include/QtCore/qatomic_x86_64.h:133
#7  ~QString (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/lib/qt4/include/QtCore/qstring.h:883
#8  ~QueryMatchPrivate (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/querymatch.cpp:37
#9  ~QSharedDataPointer (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/lib/qt4/include/QtCore/qshareddata.h:90
#10 Plasma::QueryMatch::~QueryMatch (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/querymatch.cpp:74
#11 0x00007f7d9bb94157 in Plasma::RunnerManager::run (this=0x500ae30, id=<value optimized out>) at /usr/src/debug/kdelibs-4.6.5/plasma/runnermanager.cpp:565
#12 0x00007f7d8091028d in Kickoff::KRunnerItemHandler::openUrl (this=<value optimized out>, url=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/applets/kickoff/core/krunnermodel.cpp:151
#13 0x00007f7d80914bf0 in openUrl (this=<value optimized out>, index=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/applets/kickoff/core/urlitemlauncher.cpp:81
#14 Kickoff::UrlItemLauncher::openItem (this=<value optimized out>, index=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/applets/kickoff/core/urlitemlauncher.cpp:129
#15 0x00007f7d80b6a181 in Kickoff::Launcher::eventFilter (this=0x34606d0, object=0x5001f00, event=0x7fff58e61570)
    at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/applets/kickoff/ui/launcher.cpp:784
#16 0x00007f7da4ac9567 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x5001f00, event=0x7fff58e61570) at kernel/qcoreapplication.cpp:846
#17 0x00007f7da3c64871 in QApplicationPrivate::notify_helper (this=0x248e250, receiver=0x5001f00, e=0x7fff58e61570) at kernel/qapplication.cpp:4458
#18 0x00007f7da3c69cfc in QApplication::notify (this=<value optimized out>, receiver=0x5001f00, e=0x7fff58e61570) at kernel/qapplication.cpp:4023
#19 0x00007f7da5851e06 in KApplication::notify (this=0x249d070, receiver=0x5001f00, event=0x7fff58e61570) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#20 0x00007f7da4ac93dc in QCoreApplication::notifyInternal (this=0x249d070, receiver=0x5001f00, event=0x7fff58e61570) at kernel/qcoreapplication.cpp:731
#21 0x00007f7da3c658a5 in sendEvent (receiver=0x5001f00, event=0x7fff58e61570, alienWidget=0x5001f00, nativeWidget=0x501b770, buttonDown=0x7f7da474c178, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#22 QApplicationPrivate::sendMouseEvent (receiver=0x5001f00, event=0x7fff58e61570, alienWidget=0x5001f00, nativeWidget=0x501b770, buttonDown=0x7f7da474c178, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3122
#23 0x00007f7da3ce5208 in QETWidget::translateMouseEvent (this=0x501b770, event=<value optimized out>) at kernel/qapplication_x11.cpp:4461
#24 0x00007f7da3ce38b9 in QApplication::x11ProcessEvent (this=0x249d070, event=0x7fff58e61ec0) at kernel/qapplication_x11.cpp:3587
#25 0x00007f7da3d0b582 in x11EventSourceDispatch (s=0x24b6880, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007f7da053fdc3 in g_main_dispatch (context=0x24b55b0) at gmain.c:2440
#27 g_main_context_dispatch (context=0x24b55b0) at gmain.c:3013
#28 0x00007f7da05405a0 in g_main_context_iterate (context=0x24b55b0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3091
#29 0x00007f7da054083d in g_main_context_iteration (context=0x24b55b0, may_block=1) at gmain.c:3154
#30 0x00007f7da4af49af in QEventDispatcherGlib::processEvents (this=0x24a2840, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007f7da3d0b21e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f7da4ac8792 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f7da4ac89dc in QEventLoop::exec (this=0x7fff58e621d0, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f7da4acce9b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#35 0x00007f7d93192ead in kdemain (argc=1, argv=0x24313f0) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#36 0x0000000000406cc9 in launch (argc=1, _name=0x2404938 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=
    0x0, avoid_loops=false, startup_id_str=0x40ad4e "0") at /usr/src/debug/kdelibs-4.6.5/kinit/kinit.cpp:734
#37 0x0000000000407840 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /usr/src/debug/kdelibs-4.6.5/kinit/kinit.cpp:1226
#38 0x0000000000407f95 in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.6.5/kinit/kinit.cpp:1419
#39 0x0000000000408be0 in main (argc=4, argv=0x7fff58e636f8, envp=0x7fff58e63720) at /usr/src/debug/kdelibs-4.6.5/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 238556.

Possible duplicates by query: bug 263359.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-09-05 02:16:03 UTC

*** This bug has been marked as a duplicate of bug 238556 ***