Bug 263359 - Crash on "search and launch containment" activity
Summary: Crash on "search and launch containment" activity
Status: RESOLVED DUPLICATE of bug 238556
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-16 21:13 UTC by Malar Kannan
Modified: 2011-01-16 21:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malar Kannan 2011-01-16 21:13:42 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.10-74.fc14.x86_64 x86_64
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:
tryin to launch skype through the search bar on the "search and launch containment" activity

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb8e9302840 (LWP 3810))]

Thread 5 (Thread 0x7fb8cbdfa700 (LWP 4983)):
#0  0x000000389980b8c4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003f42072ddb in wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x0000003c26c0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21efb70, th=0x2f47460) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003c26c0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x2f47460) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003c26c0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb8cbdf9d50, parent=0x21efb70, th=0x2f47460) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003c26c0b5b8 in ThreadWeaver::Thread::run (this=0x2f47460) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003f420726ee in QThreadPrivate::start (arg=0x2f47460) at thread/qthread_unix.cpp:285
#8  0x0000003899806d5b in start_thread () from /lib64/libpthread.so.0
#9  0x0000003898ce4a7d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fb8d2207700 (LWP 4984)):
#0  0x000000389980b8c4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003f42072ddb in wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x0000003c26c0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21efb70, th=0x349fa50) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003c26c0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x349fa50) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003c26c0c75c in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x349fa50) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x0000003c26c0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb8d2206d50, parent=0x21efb70, th=0x349fa50) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:87
#7  0x0000003c26c0b5b8 in ThreadWeaver::Thread::run (this=0x349fa50) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:142
#8  0x0000003f420726ee in QThreadPrivate::start (arg=0x349fa50) at thread/qthread_unix.cpp:285
#9  0x0000003899806d5b in start_thread () from /lib64/libpthread.so.0
#10 0x0000003898ce4a7d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fb8c8801700 (LWP 4985)):
#0  0x000000389980b8c4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003f42072ddb in wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x0000003c26c0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21efb70, th=0x31021e0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003c26c0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x31021e0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003c26c0c75c in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x31021e0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x0000003c26c0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb8c8800d50, parent=0x21efb70, th=0x31021e0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:87
#7  0x0000003c26c0b5b8 in ThreadWeaver::Thread::run (this=0x31021e0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:142
#8  0x0000003f420726ee in QThreadPrivate::start (arg=0x31021e0) at thread/qthread_unix.cpp:285
#9  0x0000003899806d5b in start_thread () from /lib64/libpthread.so.0
#10 0x0000003898ce4a7d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb8bffff700 (LWP 4986)):
#0  0x000000389980b8c4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003f42072ddb in wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x227f4a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x0000003c26c0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21efb70, th=0x2f11fc0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003c26c0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e3c80, th=0x2f11fc0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003c26c0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb8bfffed50, parent=0x21efb70, th=0x2f11fc0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003c26c0b5b8 in ThreadWeaver::Thread::run (this=0x2f11fc0) at /usr/src/debug/kdelibs-4.5.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003f420726ee in QThreadPrivate::start (arg=0x2f11fc0) at thread/qthread_unix.cpp:285
#8  0x0000003899806d5b in start_thread () from /lib64/libpthread.so.0
#9  0x0000003898ce4a7d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb8e9302840 (LWP 3810)):
[KCrash Handler]
#6  deref (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/include/QtCore/qatomic_x86_64.h:133
#7  ~QString (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/include/QtCore/qstring.h:883
#8  ~QueryMatchPrivate (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/plasma/querymatch.cpp:37
#9  ~QSharedDataPointer (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/include/QtCore/qshareddata.h:90
#10 Plasma::QueryMatch::~QueryMatch (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/plasma/querymatch.cpp:74
#11 0x0000003c249ad887 in Plasma::RunnerManager::run (this=0x225e7f0, id=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/plasma/runnermanager.cpp:528
#12 0x00007fb8d650c8ef in KRunnerItemHandler::openUrl (url=...) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/netbook/containments/sal/models/krunnermodel.cpp:80
#13 0x00007fb8d64fa288 in SearchLaunch::launch (this=0x1fcb8d0, index=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/netbook/containments/sal/sal.cpp:351
#14 0x00007fb8d64fdabd in SearchLaunch::qt_metacall (this=0x1fcb8d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffb9bcef0) at /usr/src/debug/kdebase-workspace-4.5.5/x86_64-redhat-linux-gnu/plasma/netbook/containments/sal/sal.moc:119
#15 0x0000003f4217004f in QMetaObject::activate (sender=0x20e45c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffb9bcef0) at kernel/qobject.cpp:3272
#16 0x00007fb8d6504825 in ItemView::itemActivated (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/x86_64-redhat-linux-gnu/plasma/netbook/containments/sal/itemview.moc:119
#17 0x00007fb8d6504de1 in ItemView::qt_metacall (this=0x20e45c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffb9bd010) at /usr/src/debug/kdebase-workspace-4.5.5/x86_64-redhat-linux-gnu/plasma/netbook/containments/sal/itemview.moc:93
#18 0x0000003f4217004f in QMetaObject::activate (sender=0x20cd220, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffffb9bd010) at kernel/qobject.cpp:3272
#19 0x00007fb8d64ff235 in ItemContainer::itemActivated (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/x86_64-redhat-linux-gnu/plasma/netbook/containments/sal/itemcontainer.moc:132
#20 0x00007fb8d64ff2e2 in ItemContainer::itemClicked (this=0x20cd220) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/netbook/containments/sal/itemcontainer.cpp:751
#21 0x00007fb8d6502bcc in ItemContainer::qt_metacall (this=0x20cd220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffffb9bd130) at /usr/src/debug/kdebase-workspace-4.5.5/x86_64-redhat-linux-gnu/plasma/netbook/containments/sal/itemcontainer.moc:111
#22 0x0000003f4217004f in QMetaObject::activate (sender=0x2294060, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#23 0x0000003c249e1ad8 in Plasma::IconWidget::mouseReleaseEvent (this=0x2294060, event=0x7ffffb9bdaa0) at /usr/src/debug/kdelibs-4.5.5/plasma/widgets/iconwidget.cpp:1399
#24 0x0000003f43f80fba in QGraphicsItem::sceneEvent (this=0x2294070, event=0x7ffffb9bdaa0) at graphicsview/qgraphicsitem.cpp:6701
#25 0x0000003f43fa9d80 in QGraphicsScenePrivate::sendMouseEvent (this=0x1c46160, mouseEvent=0x7ffffb9bdaa0) at graphicsview/qgraphicsscene.cpp:1281
#26 0x0000003f43faa775 in QGraphicsScene::mouseReleaseEvent (this=<value optimized out>, mouseEvent=0x7ffffb9bdaa0) at graphicsview/qgraphicsscene.cpp:4107
#27 0x0000003f43fbc7af in QGraphicsScene::event (this=0x1c48780, event=0x7ffffb9bdaa0) at graphicsview/qgraphicsscene.cpp:3440
#28 0x0000003f439b78c4 in QApplicationPrivate::notify_helper (this=0x1b02b20, receiver=0x1c48780, e=0x7ffffb9bdaa0) at kernel/qapplication.cpp:4445
#29 0x0000003f439bc3da in QApplication::notify (this=<value optimized out>, receiver=0x1c48780, e=0x7ffffb9bdaa0) at kernel/qapplication.cpp:4324
#30 0x0000003c20e20596 in KApplication::notify (this=0x1af0da0, receiver=0x1c48780, event=0x7ffffb9bdaa0) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#31 0x0000003f4215b7ac in QCoreApplication::notifyInternal (this=0x1af0da0, receiver=0x1c48780, event=0x7ffffb9bdaa0) at kernel/qcoreapplication.cpp:732
#32 0x0000003f43fd3fcb in QGraphicsView::mouseReleaseEvent (this=0x24634c0, event=0x7ffffb9be520) at graphicsview/qgraphicsview.cpp:3336
#33 0x0000003f43a08fe8 in QWidget::event (this=0x24634c0, event=0x7ffffb9be520) at kernel/qwidget.cpp:8200
#34 0x0000003f43db38e6 in QFrame::event (this=0x24634c0, e=0x7ffffb9be520) at widgets/qframe.cpp:557
#35 0x0000003f43fd70ab in QGraphicsView::viewportEvent (this=0x24634c0, event=0x7ffffb9be520) at graphicsview/qgraphicsview.cpp:2864
#36 0x0000003f4215b937 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2cb5600, event=0x7ffffb9be520) at kernel/qcoreapplication.cpp:847
#37 0x0000003f439b7891 in QApplicationPrivate::notify_helper (this=0x1b02b20, receiver=0x2cb5600, e=0x7ffffb9be520) at kernel/qapplication.cpp:4441
#38 0x0000003f439bcc5a in QApplication::notify (this=<value optimized out>, receiver=0x2cb5600, e=0x7ffffb9be520) at kernel/qapplication.cpp:4006
#39 0x0000003c20e20596 in KApplication::notify (this=0x1af0da0, receiver=0x2cb5600, event=0x7ffffb9be520) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#40 0x0000003f4215b7ac in QCoreApplication::notifyInternal (this=0x1af0da0, receiver=0x2cb5600, event=0x7ffffb9be520) at kernel/qcoreapplication.cpp:732
#41 0x0000003f439b88c5 in sendEvent (receiver=0x2cb5600, event=0x7ffffb9be520, alienWidget=0x2cb5600, nativeWidget=0x24634c0, buttonDown=0x3f4448b938, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#42 QApplicationPrivate::sendMouseEvent (receiver=0x2cb5600, event=0x7ffffb9be520, alienWidget=0x2cb5600, nativeWidget=0x24634c0, buttonDown=0x3f4448b938, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#43 0x0000003f43a36868 in QETWidget::translateMouseEvent (this=0x24634c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#44 0x0000003f43a34f49 in QApplication::x11ProcessEvent (this=0x1af0da0, event=0x7ffffb9bee70) at kernel/qapplication_x11.cpp:3564
#45 0x0000003f43a5c896 in x11EventSourceDispatch (s=0x1b06350, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#46 0x000000389a841e33 in g_main_dispatch (context=0x1b05120) at gmain.c:2149
#47 g_main_context_dispatch (context=0x1b05120) at gmain.c:2702
#48 0x000000389a842610 in g_main_context_iterate (context=0x1b05120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#49 0x000000389a8428ad in g_main_context_iteration (context=0x1b05120, may_block=1) at gmain.c:2843
#50 0x0000003f421868bf in QEventDispatcherGlib::processEvents (this=0x1ad77b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#51 0x0000003f43a5c59e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#52 0x0000003f4215ab42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#53 0x0000003f4215ad8c in QEventLoop::exec (this=0x7ffffb9bf180, flags=...) at kernel/qeventloop.cpp:201
#54 0x0000003f4215f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0x0000003c23037f88 in kdemain (argc=1, argv=0x7ffffb9bf578) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/desktop/shell/main.cpp:118
#56 0x0000003898c1ee7d in __libc_start_main (main=0x400920 <main(int, char**)>, argc=1, ubp_av=0x7ffffb9bf578, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7ffffb9bf568) at libc-start.c:226
#57 0x0000000000400849 in _start ()

This bug may be a duplicate of or related to bug 238556.

Possible duplicates by query: bug 238556.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-01-16 21:40:17 UTC

*** This bug has been marked as a duplicate of bug 238556 ***