Bug 238556 - Plasma crashed when K3b was started via Kickoff
Summary: Plasma crashed when K3b was started via Kickoff
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-kickoff (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 263359 281230 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-23 08:39 UTC by Mark Rooks
Modified: 2011-12-06 13:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rooks 2010-05-23 08:39:35 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.12-115.fc12.i686.PAE i686
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
I had just closed dvd::rip.
I started k3b via the start menu
I had also just inserted a dvd in the dvd drive, but had not selected any action for the dvd

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb776e7b0 (LWP 2353))]

Thread 5 (Thread 0xac5c5b70 (LWP 4227)):
#0  0x00134424 in __kernel_vsyscall ()
#1  0x00b29c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05a5bb7f in wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x06183e60 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x86f7030, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x0618683d in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x86f74b0, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x061830ec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x86f7030, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x0618693a in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8743830, previous=0x0) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x06186959 in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8743830, previous=0x8182978) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#11 0x06184e36 in ThreadWeaver::ThreadRunHelper::run (this=0xac5c5254, parent=0x86f7030, th=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:87
#12 0x061854dc in ThreadWeaver::Thread::run (this=0x8743830) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:142
#13 0x05a5acdf in QThreadPrivate::start (arg=0x8743830) at thread/qthread_unix.cpp:248
#14 0x00b25ab5 in start_thread (arg=0xac5c5b70) at pthread_create.c:297
#15 0x00a51d8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xab9ffb70 (LWP 4228)):
#0  0x00134424 in __kernel_vsyscall ()
#1  0x00b29c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05a5bb7f in wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x06183e60 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x86f7030, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x0618683d in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x86f74b0, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x061830ec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x86f7030, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x0618693a in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8677e90, previous=0x0) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x06186959 in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8677e90, previous=0x8a244e0) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#11 0x06184e36 in ThreadWeaver::ThreadRunHelper::run (this=0xab9ff254, parent=0x86f7030, th=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:87
#12 0x061854dc in ThreadWeaver::Thread::run (this=0x8677e90) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:142
#13 0x05a5acdf in QThreadPrivate::start (arg=0x8677e90) at thread/qthread_unix.cpp:248
#14 0x00b25ab5 in start_thread (arg=0xab9ffb70) at pthread_create.c:297
#15 0x00a51d8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xaadffb70 (LWP 4229)):
#0  0x00134424 in __kernel_vsyscall ()
#1  0x00b29c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05a5bb7f in wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x06183e60 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x86f7030, th=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x0618683d in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x86f74b0, th=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x061830ec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x86f7030, th=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x0618693a in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8e6ebc8, previous=0x8c4d488) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x06184e36 in ThreadWeaver::ThreadRunHelper::run (this=0xaadff254, parent=0x86f7030, th=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:87
#10 0x061854dc in ThreadWeaver::Thread::run (this=0x8e6ebc8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:142
#11 0x05a5acdf in QThreadPrivate::start (arg=0x8e6ebc8) at thread/qthread_unix.cpp:248
#12 0x00b25ab5 in start_thread (arg=0xaadffb70) at pthread_create.c:297
#13 0x00a51d8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xaa3feb70 (LWP 4230)):
#0  0x00134424 in __kernel_vsyscall ()
#1  0x00b29c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05a5bb7f in wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x86f7048, mutex=0x8708a80, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x06183e60 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x86f7030, th=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x0618683d in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x86f74b0, th=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x061830ec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x86f7030, th=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x0618693a in ThreadWeaver::WorkingHardState::applyForWork (this=0x86f74b0, th=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x061840f4 in ThreadWeaver::WeaverImpl::applyForWork (this=0x86f7030, th=0x8c50ff8, previous=0x8da8ef8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x06184e36 in ThreadWeaver::ThreadRunHelper::run (this=0xaa3fe254, parent=0x86f7030, th=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:87
#10 0x061854dc in ThreadWeaver::Thread::run (this=0x8c50ff8) at /usr/src/debug/kdelibs-4.4.2/threadweaver/Weaver/Thread.cpp:142
#11 0x05a5acdf in QThreadPrivate::start (arg=0x8c50ff8) at thread/qthread_unix.cpp:248
#12 0x00b25ab5 in start_thread (arg=0xaa3feb70) at pthread_create.c:297
#13 0x00a51d8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb776e7b0 (LWP 2353)):
[KCrash Handler]
#6  deref (this=0xbfc9f26c, __in_chrg=<value optimized out>) at /usr/include/QtCore/qatomic_i386.h:132
#7  ~QString (this=0xbfc9f26c, __in_chrg=<value optimized out>) at /usr/include/QtCore/qstring.h:869
#8  ~QueryMatchPrivate (this=0xbfc9f26c, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/plasma/querymatch.cpp:37
#9  ~QSharedDataPointer (this=0xbfc9f26c, __in_chrg=<value optimized out>) at /usr/include/QtCore/qshareddata.h:90
#10 Plasma::QueryMatch::~QueryMatch (this=0xbfc9f26c, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/plasma/querymatch.cpp:74
#11 0x06d6f2c2 in Plasma::RunnerManager::run (this=0x86f4d60, id=...) at /usr/src/debug/kdelibs-4.4.2/plasma/runnermanager.cpp:504
#12 0x04c4196a in Kickoff::KRunnerItemHandler::openUrl (this=0x87214a0, url=...) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/applets/kickoff/core/krunnermodel.cpp:151
#13 0x04c45b0d in Kickoff::UrlItemLauncher::Private::openUrl (urlString=...) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/applets/kickoff/core/urlitemlauncher.cpp:81
#14 0x04c4521b in Kickoff::UrlItemLauncher::openItem (this=0x86297a0, index=...) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/applets/kickoff/core/urlitemlauncher.cpp:129
#15 0x043e4bb7 in Kickoff::Launcher::eventFilter (this=0x846fee8, object=0x86f5150, event=0xbfc9f960) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/applets/kickoff/ui/launcher.cpp:784
#16 0x05b4fe3a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x81843a8, receiver=0x86f5150, event=0xbfc9f960) at kernel/qcoreapplication.cpp:819
#17 0x06302d0a in QApplicationPrivate::notify_helper (this=0x81843a8, receiver=0x86f5150, e=0xbfc9f960) at kernel/qapplication.cpp:4296
#18 0x0630a0fe in QApplication::notify (this=0x81777d0, receiver=0x86f5150, e=0xbfc9f960) at kernel/qapplication.cpp:3865
#19 0x053f37cb in KApplication::notify (this=0x81777d0, receiver=0x86f5150, event=0xbfc9f960) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:302
#20 0x05b50c03 in QCoreApplication::notifyInternal (this=0x81777d0, receiver=0x86f5150, event=0xbfc9f960) at kernel/qcoreapplication.cpp:704
#21 0x06308e68 in sendEvent (receiver=0x86f5150, event=0xbfc9f960, alienWidget=0x86f5150, nativeWidget=0x870e5f0, buttonDown=0x6c02638, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#22 QApplicationPrivate::sendMouseEvent (receiver=0x86f5150, event=0xbfc9f960, alienWidget=0x86f5150, nativeWidget=0x870e5f0, buttonDown=0x6c02638, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#23 0x063860d0 in QETWidget::translateMouseEvent (this=0x870e5f0, event=0xbfc9fe7c) at kernel/qapplication_x11.cpp:4373
#24 0x063855e3 in QApplication::x11ProcessEvent (this=0x81777d0, event=0xbfc9fe7c) at kernel/qapplication_x11.cpp:3384
#25 0x063b14fa in x11EventSourceDispatch (s=0x8187240, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00d3ffb8 in g_main_dispatch (context=0x8186490) at gmain.c:1960
#27 IA__g_main_context_dispatch (context=0x8186490) at gmain.c:2513
#28 0x00d438e8 in g_main_context_iterate (context=0xb28eb0, block=1, dispatch=1, self=0x8183f60) at gmain.c:2591
#29 0x00d43a14 in IA__g_main_context_iteration (context=0x8186490, may_block=1) at gmain.c:2654
#30 0x05b78e46 in QEventDispatcherGlib::processEvents (this=0x8162958, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#31 0x063b10e6 in QGuiEventDispatcherGlib::processEvents (this=0x8162958, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x05b4f2da in QEventLoop::processEvents (this=0xbfca0174, flags=...) at kernel/qeventloop.cpp:149
#33 0x05b4f61a in QEventLoop::exec (this=0xbfca0174, flags=...) at kernel/qeventloop.cpp:201
#34 0x05b51ce7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#35 0x06302dd8 in QApplication::exec () at kernel/qapplication.cpp:3579
#36 0x05ff2249 in kdemain (argc=1, argv=0xbfca0374) at /usr/src/debug/kdebase-workspace-4.4.2/plasma/desktop/shell/main.cpp:112
#37 0x0804874c in main (argc=1, argv=0xbfca0374) at /usr/src/debug/kdebase-workspace-4.4.2/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Giorgos Tsiapaliokas 2010-12-26 22:46:47 UTC
i couldn't reproduce the bug.

my box's specifications are,

Qt: 4.7.1
KDE Development Platform: 4.5.4 (KDE 4.5.4)
os:gentoo ~amd64
Comment 2 Aaron J. Seigo 2011-01-16 21:40:17 UTC
*** Bug 263359 has been marked as a duplicate of this bug. ***
Comment 3 Aaron J. Seigo 2011-01-16 22:48:13 UTC
SVN commit 1214926 by aseigo:

QString is not thread-safe; since the matches get shuttled around between threads, we need to protect access to it. as writing is rare, this should hopefully not degrade performance too much. if it passes testing, then i will backport this.
CCBUG:238556
CCMAIL:plasma-devel@kde.org


 M  +37 -0     querymatch.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1214926
Comment 4 Christoph Feck 2011-09-05 02:16:03 UTC
*** Bug 281230 has been marked as a duplicate of this bug. ***
Comment 5 Beat Wolf 2011-12-06 10:03:15 UTC
Does this still happen? the latest duplicate mentions kde 4.6.5. is this fix supposed to be in that version, or only in kde 4.7?